Do the Jetway MI5-G41SGMD2 Support Pentium 4

I've bought this motherboard to replace my RC410-M (by ECS), a Compaq Desktop original board. However, after fitting the processor Pentium 4 517, it is not booting and no post. No beeping. On the CPU support list, this processor is not listed but others belonging to the same family i.e Prescott are listed. Am i to assume that this particular processor is not supported.
4 answers Last reply
More about jetway g41sgmd2 support pentium
  1. If your CPU isn't listed in the Jetway MI5-G41SGMD2 CPU Support List then it isn't supported by the BIOS.

    For the CPU to be supported there needs to be a CPU MicroCode Patch Data Update added to the BIOS for that specific CPU and that's why a list is usually made available indicating which specific processors are supported since a particular BIOS version.
  2. The funny thing is other CPU works, i tried it with a core 2 duo processor and it was working fine. I tried the same processor P 4 in a Gigabyte G41 chipset motherboard and it works. This is my first Jetway board and it is giving me such headache.

    What i don't understand is why other G41 chipset motherboard support this p4 CPU and not Jetways'. Just my ranting :-)
  3. http://www.cpu-upgrade.com/mb-Jetway/MI5-G41SGMD2.html

    The Pentium 4 is considered to be over the specifications.
Ask a new question

Read More

Pentium Support Processors Motherboards