Sign in with
Sign up | Sign in
Your question

MicroSD Corrupt? Freezes Windows, browser, and recovery programs

February 16, 2013 4:02:33 AM

Hello tech gurus =)

I'm a long time reader and first time poster. I can usually find the answer to my questions, but this one has eluded me.

I have a Nikon D5100. I'm pretty sure I know exactly what happened to the card (32gb sandisk Micro sdhc, in adapter). The camera froze when I was ending a video...in retrospect maybe it was the card that actually froze. At any rate, I shut the camera off as it sat frozen for a few minutes -- seemed my only option.

I first thought it was my computer, but it is def the card -- other cards work fine, this does not in any computers. I have tried it in both the sd card slot and a USB reader -- same results. When inserted into the camera it just shows an hourglass n goes nowhere.


It seems like a corruption, but from what I read a corruption is what is usually more recoverable than physical damage, no?

FYI, I'm running Vista 64bit SP2, all Windows updates up to date. Here's what happens, very weird:

When inserted or ejected, windows makes the plug n play noise.

It will immediately "semi" freeze any programs. Meaning, if I have explorer open, i can scroll up and down, but if I try to take any action whatsoever in the program (expand a folder, right click, etc), it will freeze until I eject. When I eject the card, whatever action I took completes immediately. I did see it pop up once or twice, I forget under what circumstances this happened and seem to be unable to recreate it, but when i clicked on the drive to open it said to insert a disk into drive F.

It also semi freezes a browser. I can have many tabs open and click through them, but the pages I wasnt actually on at the time dont actually show up -- I see a blank page. Just as above, as soon as I eject, the page immediately loads.

Lastly, to my dismay, I have tried a number of free and paid recovery programs, such as photorec, Data Rescue 3, Card Recovery, R-studio, Stellar Phoenix. It freezes ALL of these programs as well when inserted, so they therefore cannot even recognize it to even start to attempt a recovery. These all unfreeze immediately as well upon eject. SOME of them show the card upon eject, but think its empty or when I click on it n then reinsert to continue of course it freezes again.

Oddly enough, in device manager it does show up and also says its working properly. When ejected it disappears as it should.

What could be corrupt and is there a way to fix it to even attempt a recovery? The pictures of my daughters 6 month old session is on this card -- so I haven't even attempted to format it, as I want to exhaust any and all recovery options first. The pictures are more important than the card to me. I had read one solution about updating firmware, but the person was talking about a kingston card, and I saw no such firmware on the sandisk site. I would like to consider sending it out, but I'm a single mother and recently laid off, so something like that just isn't within my budget =(

Since it freezes most programs I'm at my wits end here and hoping if theres a way to get around this or fix the corruption somehow. Can running in safemode or a certain mode in these programs help? I imagine some recovery programs have ways to get past something like this, a way of mounting or something, per se, but I haven't found this yet.

Thanks so much in advance for any help any of you can offer -- these images are extremely important to me.
!