Sign-in / Sign-up
Your question

External Storage Formated in NTFS Issues

Tags:
  • NTFS
  • Windows 7
Last response: in Windows 7
December 29, 2009 4:03:28 AM

I built a system a few months back with 64bit Windows 7 and have loved it so far. Until tonight.

I have an external drive that does backups of files for me on a weekly basis through windows, needless to say the backup was getting bigger so I decided to go for a better data storage solution and formatted the external into NTFS. While doing this I also decided to format a USB key into NTFS.

THE external drive format took hours, four or so hooked up via firewire. I blamed the issue on the drive and ignored it for the next couple of weeks. The backups didn't work properly they stopped halfway according to Windows even if I let them run 12+ HOURS. Before I formatted it took only 2-3 hours for the backup. I blamed the entire issue on the drive, maybe time to replace it, but I didn't have time to mess with it cause it was simply annoying me.

Didn't use the key until tonight. Remember it is formatted as NTFS also. I started to copy a movie file to it, 700mb, it stopped at nearly 89% with 5 seconds left and did not move one bit. I hit cancel and it stayed on the cancel screen for 10 minutes with no resolve. At this point I tried to open a firefox window and it was not responding.......so what did I do I pulled the key and just like that Firefox window popped up and all was well.

At that point it hit me, but the external storage solutions are NTFS, could it be my Mobo? Surely not!, Oh Microsoft you make me sad again....Just like with Vista.

I reformatted the USB key back to FAT32, transferred a larger 1.4gig file in about 2-3 minutes and had no hangup issues. I can't blame the issue on the mobo especially since it relates to both USB 2.0 connection and the FireWire has the same issue. I guess windows 7 64bit doesn't like external NTFS connections. My windows appears up to date!

Does anyone have a similar problem or can they possibly test this issue with NTFS on their machine?

Anyone know if Microsoft has a solution or does anyone have a solution. I got no problem sticking with Fat32, but I would like the OS to work properly and not mess with my storage. Internal drive transfer is normal.

ALSO I just realized this: the problem only occurs with single large size file formats. Such a video.......issues doesn't happen when I transfer large folders of word documents.

More about : external storage formated ntfs issues

a c 225 $ Windows 7
December 29, 2009 4:08:06 AM

Strange.... I have a few external drives formatted as NTFS, and have no problems moving files to them at expected speeds relative to the interface I'm using. The only issue so far, is my Archos 5, which is technically formatted as ext3. Moving files to it seems to go at USB 1.1 speeds, but I suspect this to be a firmware issue on the Archos itself.

I'll keep an eye out though.
m
0
l
a c 209 $ Windows 7
December 29, 2009 5:28:47 AM

I have several WD Green 1TB drives formatted with NTFS and I've never had any problems with them. I've also formatted a 2GB USB key with NTFS and it worked fine as well.
m
0
l
Related resources
December 29, 2009 1:54:42 PM

I have multiple WD Black drives that are internal that transfer just fine. The issue is only occurring via external USB and Firewire. I've spent a good part of last night and this morning scouring the net looking for a possible fix. The only thing I found that relates to this is the Nvida USB chipset hot fix from Microsoft that seems to address this issue.
http://support.microsoft.com/kb/976972

This will sadly have to wait until I check which chipset I have cause honestly at this point I am not sure. I am running a EVGA 3X SLI board so it might make sense that I have a Nvidia chipset.
m
0
l
a b $ Windows 7
December 29, 2009 5:42:37 PM

I have 4 WD external usb drives (one about 4 years old, a 2 year old and a 6 month old 1 TB in Welland cases, also a 500 WD My Book) formatted to NTFS, never had a problem.
m
0
l
December 30, 2009 11:05:13 PM

I check for the hotfix, but I don't have the proper USB chip-set that they are having problems with. I reformatted my external back to Fat and it is backing up just fine. I am experimenting with various USB keys formatted in both methods and only the FAT works like it should. When in NTFS the system runs through the copy to almost the end, then seems to stop before the end while it calculates. When I hit cancel the cancellation is also seriously slow.

I still have not been able to find the root cause for both Firewire and USB displaying this issue in NTFS external storage.

Here is my setup if it helps.
i7 920
EVGA 3X SLI Mobo
OCZ 6Gigs of Ram
2- WD Caviar Black HDD
LiteScribe 424 DVD burner
Saphire 5850
HAF 932
V8
Corsair 850HX

System is only OC-ed to 3.3
m
0
l
April 22, 2010 2:58:36 PM

I have the same problem and haven't found any solutions yet. It is very annoying. I am running Windows7 x64 Enterprise and have had two external seagate drives formatted to NTFS, and run into the same problem using either FireWire or USB. It only occurs with large files, over 1gb, and only with the drive formatted to NTFS. If I format to Fat, the problem goes away, but then the system can't create a shadow volume and won't let me use it for backups. Very frustrating, any help would be greatly appreciated.

System Config:
Dell XPS
9gb Ram
Intel i7 3.07
Win7 x64
external drive: Seagate Freeagent Xtreme 1tb
m
0
l
December 30, 2011 7:20:40 AM

leky411, i too have had this problem. You probably have an unstable external hard drive / key. It could be either a manufacturers defect or physical damage. This is what happened to my external hard drive: i used a vista computer to format it the first time NTSF, this worked until recently. I got a new computer using win 7, upon plugging the hard drive in, it tells me to reformat it. so i did so to FAT32 and it at first didn't show up under the "Computer" menu. it did show up though in the disk manager so i reformatted it a 3rd time to NTSF. Now it shows up and seemingly worked until i transferred a file (800MB) to it and it did the same thing to me as it did to you. task manager would not stop the cancel screen and i too had to pull the usb plug. My other external hard drive also uses NTSF and works just fine. After 3 re-formats, it couldn't possibly be the file system. I figure its the device's hardware. It has taken a light "tumble" or two and or was bad from the start (it was making clicks early on). I guess that's what i get for buying a 1tb ultra-portable hard drive used for $75!
m
0
l