Sign in with
Sign up | Sign in
Your question

Radeon 5870 Grey Screen - Freezing

Last response: in Graphics & Displays
Share
September 16, 2010 4:00:57 PM

Hello, I've got this problem since I bought this card. I know that many people have/had this problem but I can't find a fix anywhere. I've got the latest 10.9 driver, I'm just after reinstalling Windows 7, no windows updates installed, card runs at stock clocks, does not overheat, Idle - 38C, Stress - 80MAX. I don't know what to do with that. It's starting to get really anoying now as I can't play any games. The only games I could play(Before reinstalling Windows) were Mafia 2 and GTA IV(From the ones I had installed)
Now, when I run Furmark, it can go on forever and nothing happens. I didn't have any problems with Mafia 2 or GTA IV either. But, when I use MSI Kombustor and run it under Dx11, it always crashes. When I run it under Dx9 or Dx10, nothing happens. It seems to be a DirectX problem. I have installed the latest Dx11 pack but it did not help. I tried I think all of the fixes I have found on the internet including the ones like turning off Windows Aero or setting Idle clocks higher, nothing helped. It doesn't seem to happen now(2D crashes, 3D crashes still occur), but before the reinstall I got the message AMD driver stopped working/responding but has recovered even when I was in 2D mode. Happened when watching movies on YouTube also. When I played a game that was not called either Mafia 2 or GTA IV, the game just froze after 3-4seconds, couldn't do anything, then the screen went black,blue(in kombustor), depending on what was on the screen, and then I get the error, the game crashes and I get the Driver Stopped working message. Please help me and tell me how to fix this. Any help will be much appreciated.

Thanks

//UPDATE: When I was doing the Idle clocks, people told me that the clocks in the profile(before making changes) should be 157000/30000 but they weren't. Basically they were 40000/120000. Don't know why... Also, I tried many forums but somehow people don't know how to help me. I read about this a lot but mostly the posts were from 2009/February. Was the problem not fixed till now?

http://img840.imageshack.us/img840/3305/aticlockiwprofi...

I don't think they should look like this. Anyway, Idle clocks right now are 157/300. ATI Overdrive enabled, High Performance clocks 850/1200
September 17, 2010 10:25:53 AM

Hello and welcome to the forums
Try an older driver like Catalyst 10.4/10.5 and see if it helps
September 17, 2010 2:35:04 PM

Never worked. Tried that before, went from 10.1 up to 10.9 - nothing.
September 17, 2010 5:12:02 PM

Set your 2D clocks to 400/900,here is how:
1_Open CCC and choose Overdrive tab,unlock the settings(by clicking on the " Gold Key" icon)
2_Go top options,profile and choose profile manager.
3_In the composition tab,choose "The following settings" and in the "ATI Radeon HD 5900 series"make sure only ATI overdrive is checked.
Then enter a profile name,then save and close it(Do not activate).
4_Go to C:\Users\Your UserName\AppData\Local\ATI\ACE\Profiles (Its hidden so make sure you unlock hidden files and folders)
5_Open the profile with word-pad and do this edits:
<Feature name="CoreClockTarget_0">
<Property name="Want_0" value="40000" /> (default is 15700)

<Feature name="MemoryClockTarget_0">
<Property name="Want_0" value="90000" /> (default is 30000)


Save the changes and close.

6_Open CCC,in options tab go to profiles,profile manager and choose the profile that you saved before and then click on Activate and close.

Now your cards will idle @ 400/900 and you should not experience any more problems in 2D mode.
!