Possible SSD crash?

I've had my Crucial M4 128GB SSD for about a month now, and only in the past week its starting to act up.

Everything will be running normally on my computer, when suddenly my computer freezes completely and my speakers make a weird buzzing noise. I have tried waiting for the computer to unfreeze, but after 20min it's still frozen. The power buttons on the case and motherboard are unresponsive, so my only option is to turn off the power supply.

When i turn my computer back on, it doesn't recognized my SSD. Only after waiting 30min AND changing the SATA port of my SSD will it recognize it. When my computer finally does recognize my SSD, it runs completely normally.

This has happened once per day in the past 4 days, and twice today.

Anyone know what is happening and how i can fix this?

MBO: Gigabyte Z77-UD5H
CPU: i5 3570K
PSU: Corsair GS600
HDD: WD Caviar Blue 1TB
6 answers Last reply
More about possible crash
  1. I'm assuming that the SSD is your drive with your OS installation on it yes? Assuming that is the case did you install your SSD only install your OS to it and the plug in the HDD? I was having some similar problems, bios wouldnt recognize the drive and fairly frequent crashes with mine. My friend told me to install in that order and after I did my system has been solid.
  2. Update the drives firmware, the M4 has a bug in it that it plays up after a certain number of hours of operation have been reached.

    EDIT: Bransons link deals with that
  3. There's also a "Why did my SSD "disappear" from my system?" sticky over on the Crucial site: http://forum.crucial.com/t5/Solid-State-Drives-SSD-Knowledge/Why-did-my-SSD-quot-disappear-quot-from-my-system/ta-p/65215 it should help you troubleshoot your problem (it's actually a generic post, it applies to most SSDs, not just Crucial's), I have a feeling they missed out 1 thing though - "if it still doesn't work, replace the SATA cable and try again".
  4. Branson dumisani said:
    This article may help you: http://www.anandtech.com/show/5424/crucial-provides-a-firmware-update-for-m4-to-fix-the-bsod-issue

    If it does, pick me as best answer plz :D

    Thanks! I checked the site and used the Windows 7 Updater, but it says my system is up to date. Should i use the Manual Boot file?
  5. Never had any issue with mine, however i've upgraded it to the latest 040H when i first installed it...
  6. xxdreadnaughtxx said:
    Thanks! I checked the site and used the Windows 7 Updater, but it says my system is up to date. Should i use the Manual Boot file?

    If it's already up to date, there's no point in reflashing the firmware, besides, the problem described there only occurs after 5100+ hours of uptime (~6 months) and causes a crash with a 0xF4 BSOD within ~1 hour of every boot - you've only had that drive ~1 month.

    See the link I posted earlier for a possible fix for your issue (I'd also try a new SATA cable if that doesn't work, I reckon they missed that in the sticky).
Ask a new question

Read More

SSD Computers Storage