Installing an X2 5600+ in a Dell C521

I seem to be having trouble installing my new CPU. It wont boot while the dual core is installed. The single core works fine. I do have the energy efficient version of the 5600+ so I doubt it's a power problem. Any ideas? I also have the latest BIOS but I'm starting to think that it flashed improperly, I've read stories of people using higher wattage dual cores on the stock PSU no problem.
72 answers Last reply
More about installing 5600 dell c521
  1. Hello, and welcome to THG.

    What processor have you installed? If you think it is a BIOS issue revert back to the previous BIOS and try to re-flash the BIOS.

    But, before you re-flash, I need to know what CPU you are using.
  2. here is one link to this topic
    http://www.tomshardware.com/forum/295103-28-dell-dimension-c521
    search dell c521 on search
    Malmental really knows his stuff
    he is a former Dell Tech
  3. I tried that thread, sadly to no avail. I currently have a Sempron 3400+ (SDA3400IAA3CN) installed and I'm trying to install a AMD Athlon X2 5600+ (ADO5600IAA5DO). I've seen questions online before of people using these model processors, even the 89W version. The reason why I got the idea it wasn't flashed properly is because it reads unsupported system when I try to re-flash via the EXE given by Dell. I don't know how I would flash it with only an EXE, seeing as I'm going to have to use a boot-able media of some sort.
  4. The exe usually eithier creates a boot disk for you or it flashes right from the OS.
  5. There are tons of posts on this subject
    try this
    http://www.tomshardware.com/search.php?s=dell+c521+upgrade
    I am not trying to avoid answering you but better minds than
    mine have worked on this situation.
    the C521 upgrade to x 2 5xxx is very popular
  6. also flashing BIOS is tricky
    I have owned many Dells and I am always a little scared when I flash.
    It is always an exe file done in windows
    all unnecessary usb devices besides keyboard and mouse should be removed.
    also it is best done in stages v1.1 to v1.2 to v1.3 etc though I have been lucky and done a few where i skipped some revisions.
    check dell support for the cmos resetting procedure for the c521
    usually moving a jumper over on the mobo and also removing and reiinstalling the
    battery can do wonders.
    i have seen BIOSes do weird things until they were reset (I repair towers constantly)
  7. here is link to resetting cmos BIOS
    http://support.dell.com/support/edocs/systems/dimc521/en/SM_EN/syssetup.htm#wp1055788
    also to service manual
    http://support.dell.com/support/edocs/systems/dimc521/en/SM_EN/index.htm
    If I read your posts right you are still using the computer with old CPU?
    If that is true then I doubt you fried the BIOS
    Usually with a Dell the BIOS works or doesnt work.
    If the flash didnt work right you would have and expensive "brick"
    try reinstalling the 5600 than doing the resetting bios procedure and then removing
    and replacing the battery (leave it out for a few minutes)
    then reboot into bios and see if cpu is recognized
    sometimes BIOSes without being cleared are expecting to see the old cpu
    when you reset it will give it a clean slate and read a new cpu
    good luck
  8. Well I removed the battery on the mobo for 15 minutes, put it back in, booted, and it still hung at the BIOS screen. (I don't know if this is important but the lights 2 and 4 light up. I already tried removing the graphics card I have installed to see if that was it but it wasn't) I also tried resetting the BIOS using the jumper method. Still didn't boot. I don't understand. I have Windows 7 64 Bit Ultimate on the HDD, 4GB of RAM, and a Sapphire HD 5570 1GB. I don't know if that helps or not but those are my specs.
  9. Quote:
    I got a PM to check this thread.
    I'm not around to much on Tom's like I use to be.
    this is an interesting development huh...?
    It's 930PM EST FL-US and I will take a better look in the morning.
    A few quick things:
    1.) does the unit run windows properly right now with the old cpu or are you constantly stuck and it doesn't boot with the new cpu only.?
    just wanting clarification..
    2.) how did you attempt to update the BIOS.? and is the BIOS version 1.1.11 or what.?
    as a listed in the reference thread, I downloaded the BIOS while in windows and ran the BIOS update while still in windows
    and let the Dell utility do it for me with all USB devices unplugged except for keyboard and mouse..
    3.) if you have removed your gfx card (video card) and try to boot the unit with the old and then the new processor and the new processor
    doesn't work then:
    I KIND OF THINK THAT THE PROCESSOR (NEW) ITSELF IS BAD.

    important:
    DOES THE OLD PROCESSOR REGISTER IN THE BIOS AND THE NEW PROCESSOR DOESN'T.?

    you might be in good shape if you can run windows like in question 1.)
    if not then you might want to think about eBay and a replacement motherboard but, we can try a few things before it MIGHT come to that.
    that's if by chance that the new processor is indeed good and not bad.
    don't worry just yet.
    perform the steps above and report back.
    good-luck and I'll check back tomorrow..

    To clarify, the unit does indeed work while using the old CPU. For the BIOS update I am on revision 1.1.11 (Which I assume is the latest). No, I have not tried the steps suggested in question three. I will try that out now.

    Here is how the system behaves when trying to install the 5600+: I install the CPU and it will go to the blue Dell BIOS screen but the bar will not move and it will hang there with the frontal diagnostic lights reading 2 and 4. When I remove the new processor and I install the old one, it will boot no problem.

    By the way I have actually purchased two of these thinking that the first one I got must've gotten damaged during transit and/or it was too demanding power wise (I'm still running on the stock 280W PSU). So I have the following models.

    The processor that came with the machine: SDA3400IAA3CN (AMD Sempron 3400+ @ ~1.8 GHz)

    The processor I wanted to install originally: ADA5600IAA6CZ (AMD Athlon 64 X2 5600+ @ ~2.8 GHz [Non-EE, Windsor Core])

    The processor I purchased as a result for the first one not working: ADO5600IAA5DO (AMD Athlon 64 X2 5600+ @ ~2.9 GHz [EE Model, Brisbane Core])

    If you want to know the specifications here they are:

    AMD Sempron 3400+ (@ ~1.8 GHz)
    http://products.amd.com/en-us/DesktopCPUDetail.aspx?id=143&f1=AMD+Sempron%E2%84%A2&f2=3400%2b&f3=1800&f4=256&f5=AM2&f6=F2&f7=90nm+SOI&f8=62+W&f9=1600&f10=False&f11=False&f12=False

    4 GB of DDR2 (@ 533 MHz)

    80 GB (74 GB Real) Western Digital HDD (SATA)

    Sapphire ATi HD 5570 (1GB of GDDR3)
    http://www.sapphiretech.com/presentation/product/?psn=000101&pid=318

    Windows 7 Ultimate X64 Bit
  10. Quote:
    and have you tried the new processor without the gfx card installed, just using the on-board.?.
    Oh, you are trying that now.
    OK.


    Well I tried removing the discrete GPU I had installed, installing the drivers for on-board, and installing the new CPU (The Windsor and the EE Brisbane). Neither booted while installed, they did both, however, cause the screen to have some artifacts of some sort on the BIOS splash. I find that to be very odd, this makes me think that the motherboard has some sort of defect or hardware problem.

    Here is a picture of what it does. By the way the 2 and 4 frontal diagnostic lights are still lit. On one boot it has artifacts, power down and reboot, it doesn't, reboot again it does... Very odd.

    Artifacts:


    Boot without artifacts:


    Higher Resolution download if you can't see them well.
    http://www.megaupload.com/?d=3QJI7VV5
  11. Quote:


    Why wouldn't it do this with the old CPU installed, I don't understand that part.
  12. this is link to diagnostic lights
    http://support.dell.com/support/edocs/systems/dimc521/en/SM_EN/tshoot.htm#wp1056453
    lights 2 and 4 are possible graphics failure.
  13. king smp said:
    this is link to diagnostic lights
    http://support.dell.com/support/edocs/systems/dimc521/en/SM_EN/tshoot.htm#wp1056453
    lights 2 and 4 are possible graphics failure.


    Yes that's what drove me to remove the graphics card before posting here, but it didn't work. I don't think it's the on-board drivers being out of date because that would affect it after BIOS posting correct?
  14. Quote:
    OK.
    install the working processor
    boot into windows and perform nVidia 'clean sweep' and un-install everything.
    you shouldn't have to install drivers for the on-board video.
    and did you have drivers installed with your old gfx card or just the drivers that windows installed.?


    "Clean sweep"? So I assume you mean unstall all the nVidia drivers. Also, yes I installed my graphics card drivers at first from the CD then updated them via the ATi website.

    Edit:

    So do you want me to again remove my discrete graphics card, then use the drivers that windows provides for me when I boot via on-board graphics?
  15. http://support.dell.com/support/downloads/format.aspx?c=us&cs=19&l=en&s=dhs&deviceid=3841&libid=13&releaseid=R150579&vercnt=4&formatcnt=0&SystemID=DIM_P4_C521&servicetag=&os=WW1&osl=en&catid=-1&dateid=-1&typeid=-1&formatid=-1&impid=-1&checkFormat=true
    link to dell diagnostics software
    SOMETIMES useful
    not sure in this case
    I also like using a Hiren Boot CD for diagnostics.
    You would download the iso file and burn to disk (Burnaware Free is decent)
    then boot to cdrom and rund testing tools
  16. Quote:
    after removing ALL nVidia drivers do not install any drivers.
    just boot unit and let windows install what it wants and feels it needs.

    then check for the pixel-ated or artifacts in screen


    OK, I understand now. Sorry for the confusion, I'll try that now.
  17. OK, I removed CCC (Catalyst control center) and I removed nVidia drivers and the PhysX even. I'm going to try installing the dual-core now.
  18. Quote:
    nevermind that too SMP.
    just relax for a moment will you.
    i do not want to OP trying to do different things at once....
    I have a more direct actual seeing is believing method at the same time learning your system.



    Sorry Mal
    your posts werent up when I posted
    I will back off and leave it to an 'Ol Pro" :)
  19. OK, it booted once with the dual core, after having the artifacts for the first initial boot, not the second, then turning on. I restarted the computer because Windows 7 told me because it added a driver by itself, now won't start and has artifacts and doesn't at random boot intervals. This is extremely confusing as to why it's doing this. As usual if I install the old CPU it's fine...
  20. Also sometimes the frontal diagnostic lights only read 2 and sometimes they read 2 and 4. lol This thing is possessed or something.
  21. -Church- said:
    OK, it booted once with the dual core, after having the artifacts for the first initial boot, not the second, then turning on. I restarted the computer because Windows 7 told me because it added a driver by itself, now won't start and has artifacts and doesn't at random boot intervals. This is extremely confusing as to why it's doing this. As usual if I install the old CPU it's fine...


    so just to clarify
    it booted successfully with the 5600+ then Win7 installed a driver and now it wont boot?
  22. Yes but I don't think that's why, I didn't apply much thermal compound could it be that it's overheating and causing it not to boot?
  23. Alright, I'll try that. This is quite possibly the most uncooperative computer I have ever owned. lol
  24. OK, everything removed, floppy drive, CD drive, everything. Besides the HDD and the dual core. Still randomly boots with artifacts and without, but will not do a successful post. The 2 light only comes on after I have taken out and installed a CPU, after a second attempt to pass POST the 2 and 4 lights come on.
  25. lol Does anyone have some holy water?
  26. If it booted ok then windows installed a driver then it didnt boot ok then
    logic says the driver seems to be issue.
    boot up with old cpu and if that goes well then maybe do a restore before driver installed.
    then deactivate Win7 from automatically installing drivers (there is a way;would need to google it)
    then install the new 5600+ cpu that did boot ok
    if it runs ok then it had to be the driver
    What do you think Mal?
  27. Quote:
    pull all but 1 stick of RAM and try once more....
    i am now starting to think that my initial thought of needing a new mobo is coming back to life...


    Well, that didn't work. Should I try a different HDD? I mean there is nothing else that it could be.
  28. How would we go about doing that, lol sorry for the huge delay I was fiddling with all my other systems installing HDD's etc.
  29. Well I have my music on my primary computer, and this still isn't taking the dual core. lol
  30. Yes, yes I have. So how would we test the PSU, then again it seems to be the motherboard. Why would a faulty PSU cause artifacts?
  31. IMHO it seems to me that if the Sempron works in motherboard then motherboard is good.
    Also after removing all ati and nvidia drivers it BOOTED into WIN7 with 5600 so everything seems fine hardware wise.
    Then Win7 installs UNKNOWN DRIVER then it DOESNT work again.
    So if everything is working ok with Sempron then more than likely nothing is wrong with PSU and MOBO.
    When DRIVERS removed it BOOTED into Windows.
    Then Driver loaded and on restart didnt work.
    I personally would remove graphics drivers again and try the 5600 before buying a new motherboard or PSU.
    Always try the nickel and dime fix first.
    First rule of auto diagnostics.
    Learned from my uncle who pro drag raced in early 70s
    Applies to computers too.
  32. Well it still had the artifacts for the first two boots, booted properly, then didn't. So something is wrong with something other than the OS. I doubt Windows would have a driver that made something non-functional. I'm going to try to look even harder for a problem similar to mine on the internet tomorrow. But I do think I'll end up just building a new computer. It just doesn't seem worth it to drop 100 or even 50 for a PSU or motherboard when I could put that forward to a new computer, I've already spent 150 on this thinking I could make a cheap and decent gaming rig, needless to say my attempts have failed.
  33. Quote:
    boot up with old processor and perform a clean install of windows..
    format HDD or use a new HDD that has not been populated or one you can format..

    OK, I did that. I didn't do anything to the system, I let it install what ever drivers it wanted and then tried to install the dual core (both models). It still gave me the 2 and 4 error, I'm beginning to think that it's the motherboard.
  34. Mal if it was the mobo why would it still work with the Sempron?
  35. It was shipped on 11/06 which is a year after the dual core that I'm trying to install came out.
  36. Hmm, what should we do. I'm more software based in my knowledge, hardware I'm so so.
  37. Would you like to continue this on a more immediate means of communication? I don't know if you've heard of X Fire but I use that for IM.
  38. Quote:
    Artifacts? With what tool are you testing it?

    On page one I have pictures of the artifacts I'm talking about.
  39. Hmm, should I re-install the factory OS (XP)? I'm on windows 7 64 bit and this thing was running on XP 32 bit when it came out of the factory. AMD has processor drivers but only for XP or Server 03. So it might be that. This thing also rolled out of the factory with a modem that I removed, I don't know if that would affect anything. Yeah it has some nVidia SMBus drivers and other things exclusively for XP that are marked urgent by Dell. I'm beginning to think it actually might be that the OS isn't designed to run this hardware.
  40. Hmm, so what do we do. I'm fresh out of ideas. Except for re-flashing BIOS, perhaps it got corrupted while flashing. I've tried to re-flash or revert Dell BIOS's before and it's not an easy thing to do at all, in fact I've never been able to. When I open the EXE to flash to 1.1.11 (which it's already at supposedly) it reads this.

  41. Quote:
    I've never reverted back and I am unaware of doing so.
    If you have version 1.1.11 now then what are you going to d, download and install (try to install) an earlier version like 1.0.6.?
    will it even let you do that.?
    Like I stated, I have never tried to go back.


    Nope, if the EXE even opens, which for some odd reason the older ones do and don't, it will read unsupported system. I think it did get corrupted while flashing, the artifacts at the POSTing and BIOS splash do suggest something on the motherboard is corrupted. The HDD or anything else hardware/software related can't really be blamed. Wouldn't it be effected while trying to load the OS? Or during operation? The PSU doesn't seem to be it if people with the Windsor have used them (The 89W one) when I'm trying to use the 65W energy efficient one. I've tried both and neither worked.

    Edit:
    I'm not sure if this means anything but it's using the Pheonix BIOS right now. Isn't Dell and Pheonix two different companies?
  42. Well I would have to catch it pre-boot and use a floppy, problem is they conveiniently don't provide the files needed easily. I would have to figure out how to open a .bin file, which I haven't figured out how to do yet. Then again I haven't spent too much time on it.

    Edit:
    How much would the Opti-plex motherboard cost? You said it would support the Phenom class AMD CPUs? A quad core would really be something, I could run an external PSU. Wouldn't be fun to do though would it?
  43. For more powerful CPUs. also for a beefier graphics card. Which would be nice, but I'm debating on whether or not it would be practical.

    Edit:
    Aren't the powerful Phenom's 125W? I'm not sure that a 280w supply could take it along with a GPU.
  44. Quote:
    That artifact at boot? Thats no driver thats failing gpu ram. Happened to a nvidia card one but it was the same just red. That gpu is a goner

    No the ATi and nVidia both work fine on the single core, I doubt it's that. The BIOS must've gotten corrupted during the flash. I could've been doing some school work (EG typing) which I didn't know at the time, could cause corruption.
  45. Quote:
    the mGPU is a goner yes, also called GPU...

    and no, older phenom i's are 95-watt (X3) and the (X4) has 65, 95 and 125+ chips..


    Oh then it should be fine then, how much is the Opti-plex motherboard? (Wait let me see if you posted a link before)
  46. Quote:
    that 2 pics on the previous page. top pne was the ati and the one at the bottom what card did you use there the nvidia?


    Using either resulted in identical occurrences while using the dual-core. They both work fine one the single core.
  47. Quote:
    I'll look it up when I get back, time to eat...
    I've been building and troubleshooting a unit all day for the guy who wanted to build one for Christmas.
    Building it would be simple but finding out what the ass did wrong is a pain at first..


    Well good luck with the machine. By the way thanks for all the help, I would've never figured out the problem.
  48. So what model motherboard (C521) supports the dual core athlons, would a dell e521 motherboard work, and which model optiplex motherboard would work in here?
  49. Quote:
    e521 motherboard is too big.
    the Optiplex 740 desktop unit is the c521 'evil twin'..

    you will give up the better audio but in return you get a better processor.

    http://www.dell.com/us/en/dfh/desktops/dimen_c521/pd.aspx?refid=dimen_c521&cs=22&s=dfh
    http://www.dell.com/us/dfb/p/optiplex-740/pd

    http://img2.prosperent.com/images/250x250/www.pacificgeek.com/productimages/xl/OPTIPLEX-740-RCD-1R.jpg
    http://reviews.cnet.com/sc/32069566-2-440-front+back-2.gif

    every c521 should support the dual athlon 64x2 it's just your motherboard is bad.

    Could I use the full-size barebones version of the Opti-plex 740, by just transferring all my parts? It would expand my possibilities for a GPU and PSU.
Ask a new question

Read More

CPUs Product