Sign in with
Sign up | Sign in
Your question

Game graphics problem...

Tags:
  • Prebuilt
  • Graphics
  • Systems
Last response: in Systems
Share
November 9, 2010 5:18:22 AM

Hi guys,

I'm new in here. I was having an irritating prob lately that my PC randomly shut down after 5-10 mins of starting windows. I upgraded my PSU to 1000W Thermaltake but still same prob occurred. Then I reassembled all the hardwares and reinstalled XP again. Surprisingly there is no more the same prob, but a new one. Every single game I play gives poor graphics; no more freezing but slows down in times of special powers or too many characters or so on.

My PC spec: Intel Core 2 Duo 2.66 GHz, 9600GT 512MB PCIE, 1 TB HDD, 4GB RAM etc. I’ve cleaned the dust in the chasis with a blower, kept the monitor framerate to 75 Hz at 1024X768, defragmented the files, cleaned crap files with CCleaner, checked for unwanted files or viruses etc. Now I don’t find a clue how I can solve this prob. Please help me to solve this problem guys.

~Dipro.

More about : game graphics problem

November 9, 2010 5:26:46 AM

Do you have all the latest drivers , especially for your graphics card ?
Btw, my 9600 gt, had some dust problems, i had this problem before, clean it will air. Might do the trick.
And about your refresh rate, is it native 75 hz ?
m
0
l
November 10, 2010 10:23:35 AM

@55range: Yeah, I've downloaded the latest drivers. I've cleaned it with air blower carefully and set the refresh rate from the Nvidia control panel....
m
0
l
Related resources
November 10, 2010 2:26:50 PM

The refresh rate- should be at default- do not increase it -
So is 75 hz default ?
m
0
l
November 14, 2010 10:21:40 AM

go into the nvidia control panel and shut physx off. Then check other settings while in game and make adjustments.
m
0
l
November 14, 2010 8:43:53 PM

set it so that the gpu is doing all the physx work, i had a problem where my cpu was set to process physx and i had horrible rates till i changed it to my gpu
m
0
l
November 14, 2010 8:58:53 PM

knotes said:
set it so that the gpu is doing all the physx work, i had a problem where my cpu was set to process physx and i had horrible rates till i changed it to my gpu


NO! If physx is enabled on the card the game will lagg more. It's not a high end card and there isn't enough video memory on it. So disabling it altogether should help a little.
m
0
l
November 15, 2010 8:31:03 PM

It's just your card, can't run what you are asking of it smoothly.
m
0
l
November 23, 2010 1:55:23 AM

I still have 1 years warranty more with the card and even a few day ago I could run Darksiders 2 quite smoothly. I also have changed the processor fan ( I got it for free- because of the paste thing was messed up on the previous one), still the problem remains. Yeah, I also think that it's probably with the card.

My question is if one or more of the hardwares are troubling, why it runs OK on the second time I turn on the PC? (As every time I shut down my PC, next start up the problem happens. If I turn it off and touch/reassemble the hard wares/ wires- The PC is OK until the next turning off).... weird.

I have my birthday coming up on January, my mom intends to give me an ATI 5770 Card. But before that I have to make sure that the problem is actually with the Card (9600GT).

Thanks all of you for contributing with suggestions to solve this creepy trouble.

-Dipro.
m
0
l
!