Closed Solved

5850 flickering and complete grey/green screen lately....?

After I installed the 10.9 cats. in two games.. The Witcher and Mafia II i've experienced the game at random points.. even during the start menus, the screen going completely grey or grey with green lines etc... forcing me to hard boot the computer. Both games are running thorough steam so I started up SC2, which does not run through steam, and saw the same thing happen. My system is overclocked so I rebooted with default bios settings and still I was seeing the same things.

I had this happen once before in the witcher when i was running the 10.7 cats. I have not had this happen with the 10.8's so i uninstalled the 10.9's and reinstalled the 10.8's and now im seeing it with the 10.8's

Anybody have any idea what this might be. Is my card crapping out on me or is it just driver instability? Mind you I just staring seeing this after having the computer running all day.

Specs:

Specs:

i7 920 @ 3.85ghz (182x21)
X58A-GA-UD3R Rev. 1.6 (Bios FB)
Saphilre Radeon 5850 (10.9)
DDR3-PC1600 6Gb Ram
Win7 Ultimate
21 answers Last reply Best Answer
More about 5850 flickering complete grey green screen lately
  1. Card temps?
    use DriverSweeper before install the new driver:
    http://www.guru3d.com/category/driversweeper/
  2. I used driver cleaner and cleaned all things ATI out of my system... completely new install of 10.9 drivers.. Still getting the same problem. This is happening when my gfx card temps are still below 40C so i dont think its card temps. Since this started ( since i installed Mafia2) i cant even run any application even those not tied to Steam. Same thing keeps happening.. grey screen etc.. Im at a loss. I looked on the steam forums and ive noticed alot of other people are having this problem.. both ATI and Nvidia users alike.

    Maybe its a Direct X component installed during the Mafia 2 installation that is causing a serious instability in the operation of the card or drives regardless of what the drivers may be since going back to previous drivers doesn't seem to help.

    I'm at a loss.
  3. Well, if that's true then i would suggest you to re-install/format windows and never install that mafia 2 again...

    Okay, for now, uninstall again your current driver and use driver sweeper again, after that install 10.4, try that first.
  4. Same thing happens with 10.4.
  5. hmm, okay, now if you have another PC with a decent PSU then try your card there, if the same thing happened again then RMA your card...
  6. I don't think the problem is with the card itself, seeing how you only saw it happen after installing the 10.9's. The consensus seems to be now that the 10.9 drivers are terrible, so here's what I suggest you do:

    1. Uninstall ATI Application Profiles (in Add/Remove Programs).
    2. Uninstall the driver from Add/Remove Programs.
    3. Go to the Device Manager, right click your ATI card, go to Properties, Uninstall the device (and check the box that says "uninstall driver software").
    4. Go to msconfig and find the settings that determine the boot type (should be under one of the tabs).
    5. Check "safe mode - minimal services" or something to that effect.
    6. After you apply and hit OK, it will ask you to restart, do so.
    7. It will then reboot into safe mode. Run driver sweeper for all ATI software once you are in safe mode.
    8. Go to msconfig, and uncheck the safe mode settings and check the default normal boot options.
    9. It will ask you to restart again, do so.
    10. You'll probably have to go into control panel and change your resolution back to your native resolution.
    11. Install the 10.8 catalyst drivers once you have restarted.
    12. Find the 10.8a Application Profiles and install them.
    13. Make sure you have the correct settings in Catalyst Control Center, and after that you should be good to go.

    Sources:
    How to boot into safe mode:
    http://www.howtogeek.com/howto/windows-vista/force-windows-to-boot-into-safe-mode-without-using-the-f8-key/

    Catalyst 10.8 Windows 7 64-bit Download:
    http://support.amd.com/us/gpudownload/windows/10-8/Pages/radeonaiw_vista64.aspx?&lang=English

    Catalyst 10.8a Application Profiles (download link at bottom):
    http://www.hardocp.com/article/2010/08/26/ati_crossfirex_application_profile_108a_performance/


    Hope this fixes your problem!
  7. Now im having problems going back to 10.8. I can install 10.9 but when clean everything my 10.8 install keeps showing a failed install. I did install the 10.9's through steam(big mistake) previously. After i restarted the computer i got a windows update(recommended) wanting to install updates to HD5800 series hardware. I let it update, restarted and now im able to get into ccc and under the information tab it's showing 10.8. I tried to run a 3dmark06 and it again went to the grey screen etc...

    Are applications profiles necessary. I'm not running a crossfire config.

    Could it be bad RAM? My system boots into windows just fine.
  8. The grey screen is a hardware problem with the 5 series cards. I'd imagine some tolerance changed in some board component. Your going to have to rma the card
    http://www.geeks3d.com/20100208/tips-what-is-the-gsod/
    http://www.overclock.net/hardware-news/659262-toms-ati-confirms-grey-screen-crash.html
  9. Yes, application profiles are necessary, whether you are running Crossfire or not. Make sure you do all the steps that I listed. If that still doesn't work, THEN rma the card.
  10. Ive tried most drivers.. and i keep getting this grey to black screen with fine lines. My card was purchased in december of 09. I contacted saphirre technical support, just waiting for them to get back to me. Hopefully they say the same thing.
  11. You need to try the 10.8s on a totally clean install like I outlined before. I gave you the steps to do a completely clean install.

    If your 10.8s are failing on the install, redownload them, something may have gotten corrupt. But seriously, you need to try everything before you RMA. RMA is the last resort.
  12. I tried different download locations of the 10.8s and they all seem to install all components except the display driver (the 10.8 install regardless doesnt install the display driver for some reason) . So I did a clean install with a driver that i remember worked fine which was the 10.6 ( the 10.7 were giving me grey screen in two applicatins). First time i installed them everything installed except there was no ccc so i did a new clean install and again running a 3dmark06 it goes grey or black screen within 30 secs-1 min. I don't know what else to try. I don't have another psu to try if thats it or sticks of compatible ram lying around to try that ( my system boots into windows just fine, i'm only seeing problems when i try a game or a benchmark like 3dmark06.
  13. Best answer
    I don't know what to tell you if newly downloaded drivers are failing to install. My only guess would be that something is going wrong during the system recognition process in the install, and it can't get all the information it needs from your card.

    If I were you now, I'd throw in the towel and go for the RMA. It seems like you've tried everything.
  14. I've emailed sapphire which according to their website all vga cards are under a two year warranty, but it also says it's handled by the distributor and when i go to newegg it's saying that its ineligible. I was planning on calling newegg to talk to someone about it. It would suck if they tell me they can't rma it since i've had it for less than a year and i've never tampered with it in any way.

    If I have to buy a new card I might seriously consider going over to Nvidia. they seem to have the edge on ATI when it comes to drivers.
  15. I thought Newegg only does short term returns (30 day and such). Longer warranty returns should be done directly with the manufacturer (Sapphire).
  16. I had the same thing happen !! Drop down to 59HZ in the game and it will work.. I hope they FIX this in the next catalyst

    System specs CROSSFIRE\ powersupply 1200wattts\windows 7 64 \12gig ram


    Primary Adapter
    Graphics Card Manufacturer Powered by ATI
    Graphics Chipset ATI Radeon HD 5800 Series
    Device ID 6899
    Vendor 1002

    Subsystem ID E146
    Subsystem Vendor ID 174B

    Graphics Bus Capability PCI Express 2.0
    Maximum Bus Setting PCI Express 2.0 x16

    BIOS Version 012.020.000.004
    BIOS Part Number 113-E14601SA-00C
    BIOS Date 2010/03/02

    Memory Size 2048 MB
    Memory Type GDDR5

    Core Clock in MHz 765 MHz
    Memory Clock in MHz 1125 MHz
    Total Memory Bandwidth in GByte/s 144.0 GByte/s


    Linked Adapter
    Graphics Card Manufacturer Powered by ATI
    Graphics Chipset ATI Radeon HD 5800 Series
    Device ID 6899
    Vendor 1002

    Subsystem ID E140
    Subsystem Vendor ID 174B

    Graphics Bus Capability PCI Express 2.0
    Maximum Bus Setting PCI Express 2.0 x16

    BIOS Version 012.020.000.023
    BIOS Part Number 113-14030SA-T54
    BIOS Date 2010/06/14

    Memory Size 1024 MB
    Memory Type GDDR5

    Core Clock in MHz 765 MHz
    Memory Clock in MHz 1125 MHz
    Total Memory Bandwidth in GByte/s 144.0 GByte/s
  17. I already RMA'd my card. If this is a fix for this, when I get my card back and if i'm still experiencing this problem, I'll try this before I start looking at alternate solutions such as new RAM, or an new PSU..etc..
  18. Droping it to 59 works on-

    Call of duty modernwarfare 2
    Quake 4
    Mafia 2
  19. Best answer selected by mriviecc.
  20. I just received my replacement card from Sapphire tech. They actually offered to send me a 5850 toxic addition in replacement of my stock 5850 which I gladly took ( its just an increase in a 15 mhz and 50mhz core and mem clock repectively, but the cooling is better). Popped it in, reinstalled the latest Cats, and every app. i ran thus far is working fine. No grey screen. Thanks for all your help guys... really appreciate it.
  21. This topic has been closed by Mousemonkey
Ask a new question

Read More

Radeon Green Screen Graphics