Powercolor customer support

Hello,
I bought PowerCololor 5570 one day before... I formatted my existing operating system and installed Windows 7 64 Bit..then I installed my motherboard drivers and ATI driver...and after that I'm facing continuous crashes...My system freezes again and again.

My PC config is :
AMD X2 7750 BE
Gigabyte AM2+ motherboard
4gb RAM
500 GB HD
450 Watt PSU
7 answers Last reply
More about powercolor customer support
  1. Have another PC? So you can try your card in another PC, just to make sure whether it's okay or DOA...
  2. wa1 said:
    Have another PC? So you can try your card in another PC, just to make sure whether it's okay or DOA...


    Na...I dnt have another PC but 2 laptops...and the card definitely would not fit there...
  3. Quote:
    What video card did you have before?

    Maybe your power supply is failing.



    I didn't had any external card...all I had was an Onboard Nvidia 6100...something like that
  4. Quote:
    Did you disable the onboard video in the bios and remove the Nvidia graphics drivers?


    I formatted my "C" drive so there won't be a driver issue...about Disabling in BIOS...I didn't do that.
    Let me try.
  5. The Onboard card was automatically disabaled, so I didn't have to do anything.

    Any more suggestion people...I'm tired of my display now. I had to uninstall ATI driver and now I've to work on my 20" TFT with 800X600 resolution...

    Please Help.

    Thanx.
  6. Quote:
    Try installing 10.4 Catalyst.


    Thanks, I'll try that.

    Anyways if that won't work I'll get the card replaced. Though it's unlikely that a brand new card could have such issue.
  7. Quote:
    Try installing 10.4 Catalyst.


    Nope...even that didn't work... may be getting it replaced is the best option.
Ask a new question

Read More

Radeon PowerColor Graphics