Sign in with
Sign up | Sign in
Your question

Just installed Samsung 840, having wireless internet issues

Last response: in Storage
Share
February 21, 2013 7:37:51 AM

Hey guys, new to the forums here.

I've got a Samsung Series 3 11.6" laptop (NP300U1A) and I just upgraded the HDD to a Samsung 840, non-pro.

I used the Samsung migrating software and everything seems to have worked flawlessly, except for the wireless internet.

At first, the internet lagged horribly, and now the speed generally seems to be okay (sometimes spotty), but out of the blue I will get disconnected and see that red X in the bottom right corner, as if I had no wireless adapter installed. I'd either have to restart or put the computer on sleep and wake it up.

I've updated the drivers and everything else works great. Any guesses on what the culprit could be? Appreciate the help!
a b G Storage
February 21, 2013 8:22:11 AM

This has nothing to do with the SSD. Try to re-install the driver of your wireless card adapter, and it shall work fine with you, hopefully!
m
0
l
February 21, 2013 8:37:18 AM

Sorry, correction to the original post. The red X isn't the same as if I had no adapter installed. It is the one that shows the signal bars, with an X over it, and says "not connected, no connections are available." I've uninstalled and reinstalled the driver a few times but unfortunately, it hasn't changed the situation.

Also, the disconnections seem to happen when I download large files using more bandwidth.
m
0
l
Related resources
February 21, 2013 10:46:51 AM

Check that you didn't accidentally dislodge the wireless aerial when you opened the laptop to replace the SSD.
m
0
l
February 21, 2013 6:08:10 PM

Okay you may be right, it might be a hardware issue. I plugged in my wireless adapter from my desktop and low and behold, the speed is blazing fast. 30+ megs vs 1ish. I'm gonna open up the laptop again...any idea where I should be looking and what it looks like?
m
0
l
February 21, 2013 6:25:19 PM

The wireless adapter seems to be intact. The two wires that come out of it and the aerial are as well. I'm not sure what the issue can be...
m
0
l
a b Ô Samsung
a c 299 G Storage
February 21, 2013 6:41:48 PM

I am fairly certain it is not the ssd itself. You might have to do a little more than just install drivers.

If you are using a Microsoft Windows operating system open the control panel and go the Network and Sharing Center.

1. Click on trouble shooting and see what happens.

2. If trouble shooting does not repair the problem click on "connect to a network". Select the appropriate network.

3. If that doesn't fix the problem click on "set up a new connection or network".
m
0
l
February 21, 2013 7:00:07 PM

Alright well as of now it seems to be a reception issue. If i take my laptop into the next room with the wireless router and cable modem, the connection is fine. If I bring it back to my room, the bars may or may not drop, but the speed is ridiculously slow regardless.

Thing is, I've kept it at the same place in my room since day one and reception and speed have been fine. It only changed since the SSD install. Could I have tampered with something during the installation? I checked the adapter, wires coming out of it, and the metal plate that seems to be the antenna in the laptop case and things seem to be normal. Why would the reception get so weak all of the sudden?
m
0
l
February 21, 2013 7:53:11 PM

So desperate times call for desperate measures. I decided to experiment by wrapping a piece of heavy duty aluminum foil around the metal wireless "antenna" inside the laptop and guess what...things are back to normal again.

My suspicion is that the issue had to do with some sort of interference that the SSD was giving the antenna, as the connection to the SSD was located directly next to the antenna, almost touching. But that's just my guess. I'd still like to hear some theories from some more knowledgeable folks out there though...
m
0
l
June 12, 2013 1:14:35 PM

I had the same issue and after several rebuilds resorted to google and found this thread. I disconnect the antena that resides under the SSD and bingo, the wireless is working again wow. On boot up it doesnt always connect first time which is still a bit strange, but when connected its fine. I'm going to try reposistioning the antena so I can reconnect it.
m
0
l
September 12, 2013 7:49:01 PM

I had a similar issue. The Samsung drive is sitting next to the wifi/bluetooth card and began having trouble after installing the new drive...I had to restart several times and disable/enable the card several times before it would connect...it would in, fact, connect the other times but the wifi would say it was limited...or something to that effect. Eventually it would connect and would be perfect until shut down...they I'd have to start all over again. I thought ti was the proximity of the drive itself and I tried shielding it with plastic and tin foil...nothing changed. I figure I should try putting the old drive back in to see if the problem would go away...this would test out the theory that something with the new drive was interfering with the wifi. It turned out nothing changed. I was still having wifi connection issues. I figure I'd try to troubleshoot the problem with the old drive. I now suspected the Samsung software I installed to clone the drive. I did a restore to before the Samsung software so it would restore everything as it was before. However, this did not work. I checked the version of the WIFI drivers to the one on the Intel site and they looked the same...but the connection was not happening easily still. I decided I was going to reinstall the drivers. After installing over the old drivers...still nothing. Finally I decided to uninstall the drivers completely and reinstall them....this finally did the trick. I think somehow the Samsung software is messing with the Wifi drivers or DLLs and causing trouble. After doing all this with the old drive I put the new drive back in and removed the drivers and reinstalled them and so far I've restarted several times and I'm no longer having connection problems,...whew!
m
0
l
!