Sign in with
Sign up | Sign in
Your question

Reboot and select proper boot device

Tags:
  • Motherboards
  • Boot
  • Devices
Last response: in Motherboards
Share
October 8, 2011 4:20:35 AM

Alright whenever I try and boot to my SSD (boot drive) my computer will end up saying "reboot and select proper boot device or insert boot media in selected boot device and press a key". However if I use the same SATA and power connections and attach my Linux hard drive, with no changes to the BIOS, it will boot just fine. If I have my SSD set up as a slave drive, I can access the files fine and browse the drive as if nothing is wrong. Anyone know why this is happening?

Specs:
Mobo: ASUS M4A79XTD evo
CPU: AMD Phenom II X4 965
RAM: 2x(2x 2GB A-Data Gaming Series)
SSD1: Kingston SSDNow 64GB
SSD2: OCZ Onyx 32GB
HDD: WD Caviar Black 640GB
Linux HDD: Hitachi Deskstar 320GB
DVD Drive: Some LiteON drive
Graphics card: AMD Radeon HD 6950

If anyone has an idea as to why this is happening, please let me know. The system has been working fine up until I took it apart earlier to clean it out.

More about : reboot select proper boot device

a c 180 V Motherboard
October 8, 2011 4:41:10 AM

In the bios under the boot tab do you have the ssd listed as the first boot option? When you cleaned out your Pc you may have loosened the sata cable either on the MB or the ssd , make sure they (power and sata) are pushed in all the way. Take them out and put them back in to be sure.
m
0
l
October 8, 2011 5:05:24 AM

SSD is first. It's not a problem with connection. It won't boot at all with the SSD as the first priority. If I plug in my HDD with Linux on it it'll boot just fine.
m
0
l
February 22, 2012 6:36:42 PM

I came here looking for answers but my original problem was different. I am running Ubuntu 10.04 and had to do a hard reboot (restart would not respond). By "hard reboot" I mean holding in the power button for fifteen seconds or so and shutting off the power supply. When I tried to restart the computer, I got the error you were getting. I tried restarting a few times as that would be the easiest, obviously. I could only get to the bios page, and the DVD rom would not open. So I shut the computer off, pulled the power plug for about 30 seconds, and plugged it back in. Everything started working again. This is a trick an IT guy showed me at work when certain faults occur at start up. I think there are risidual gates held on/off by the PS that needed to be reset. Don't know if it'll work for you, but I got here looking for answers and maybe somebody else with a similar problem will find this useful. I personally think my CPU is dying. It is an AMD quad core, the second one to die in this HP computer. : ( I'm starting to lose functionality. Going back to Intel after this.
m
0
l
!