Sign in with
Sign up | Sign in
Your question

Bad Motherboard/Chipset/ USB Ports?

Last response: in Motherboards
Share
October 8, 2011 4:25:03 AM

First of all thanks for reading, and trying to help. here are my speccs

AMD Phenom II X4 955 3.20 Ghz
MSI 870A FUZION socket AM3
4 GB DDR3 Kingston HyperX memory
Nvidia Geforce Gtx 460se
3 SATA HDs, 1 DVDRW
650W ANTEC powersupply Trio

The problem is that when I'm transferring data from the pc to the flash drive, it ejects by itself. There random ejects, in the beginning, half ways, and when it's about to finish. These are the things I've done:

Tried my Kingston 8gb traveler on another PC. Works fine!
Updating Drivers: Chipset
Disconnecting front USB Panel cables just in case the cables were bad, No Good!
Tried my friends flash and it still doesn't works
Added a PCI USB Adapter
Last thing I tried was using an external hard drive, this works fine. but I think it works because it has it's own power cable.

I've tried going through the bios and it doesn't give me any usb options. So if you guys any other tips or tricks. I'm guessing the there's not enough juice going to the USB ports. Thanks in advance1
a b V Motherboard
October 14, 2011 8:45:05 PM

antecfan said:

The problem is that when I'm transferring data from the pc to the flash drive, it ejects by itself. There random ejects, in the beginning, half ways, and when it's about to finish. These are the things I've done:

By "it ejects by itself"... do you mean it disconnects for safe removal?

antecfan said:

Last thing I tried was using an external hard drive, this works fine. but I think it works because it has it's own power cable.

Does the USB Flash drive LED flash? If it does, it has power... in my personal opinion, I don't think this kind of damage would be likely this soon in your mobo's life but then again I don't know what kind of use it's been subjected to. The reason an USB external HD works is probably because it runs on a different driver than usb flash drives... read on this at the end.

antecfan said:

I've tried going through the bios and it doesn't give me any usb options. So if you guys any other tips or tricks. I'm guessing the there's not enough juice going to the USB ports. Thanks in advance1

870A Fuzion Power Edition Manual
http://us.msi.com/product/mb/870A-Fuzion-Power-Edition....
Check the BIOS Options on page 3-10 of the MSI 870A FUZION POWER Manual. Enable all options .

Have you checked the USBSTOR driver Service in the registry?
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\USBSTOR\DWORD Start = default (3)

I'm not sure what 0 exactly means, but I think 0 or blank would mean not enabled. 4 would mean the driver service is disabled... 1 to 3 are; startup, manual, automatic start. If blank, 0 or 4 are in the data field, transfering data to and from a usb flash drive would be disabled.
October 19, 2011 3:57:57 AM

Yes I tried Front and directly to the back on the motherboard usb2.0 and usb3.0 still no luck. I RMA'd the motherboard last week. I just got the new one. same model. When it ejects it sounds like I unplugged it. and the usb flash drive keeps on flashing. Even with this new I get the same problem. But my flash work perfect on other computers.
Related resources
a b V Motherboard
October 19, 2011 8:37:10 PM

Did the OS boot without reinstalling it, no repair installation was necesary?.. probably affirmative because the same model motherboard would most likely not require it.. so if the problem is software, replacing hardware would not make a difference. If the problem is OS, more precisely registry corruption, even a repair installation would not guarantee USB flash drives would work in the computer. You would probably have to do a clean installation, or install a second OS on another partition to get the flash drive working on that computer. It may sound radical but I say this because I experienced such a problem a few weeks back and even reinstalling the system twice, trying everything I know, and applying every trick and tweak I could find, did not solve the problem... It took a clean installation to finally solve it.

USB flash drives normally flash a few seconds after insertion and even if yours keeps flashing, it means it's being powered, and the problem is not hardware but software and a clean istall would prove it.

I still don't understand what you mean by "ejects":
You've said; "it ejects by itself", "There random ejects", "when it ejects"... What exactly do you mean "ejects"?... So may I understand the problem better. I know USB flash drives don't physically eject, or make a sound, so please explain this...
October 21, 2011 10:11:47 PM

I didn't have to repair or reinstall the OS, I am planning on reinstalling Windows 7 soon. Before BF3 comes out. I've tested with Windows XP and Live Cds and it still doesn't work. What I mean by ejecting is that the flash disappears from "My Computer" Then it makes the sound like if I unplugged it. But the USB light keeps on flashing. After it disappears I have to reconnect it again. I will let you know if it works with a clean install. I am also planning to buy a different brand Flash this weekend. Thank for your time.
!