Sign in with
Sign up | Sign in
Your question

Issues with Windows 7 new build

Last response: in Systems
Share
November 12, 2010 8:09:57 PM

Hi Guys,

I am not sure if this is the right place for this but here I go ...

I have just built my own home built machine (Spec at end of post) and I am having some problems installing windows 7. I have tested this system with my old 80gb IDE drive and I can boot into the ubuntu partiton so the rest of the system is ok.

When I try to install windows 7 it gets to "where would you like to install windows" and there are no drives available. I have checked all of the cables are plugged in (sata and power) and tried serveral SATA ports on the mother board but still no luck. The drive has also been formatted.

There are serveral settings in the BIOS for "PCH sata control" (IDE, AHCI, RAID (XHD)) and I have tried them all, when I set this as IDE the hardrive is visible in the BIOS where as either of the other two settings it is not. In all of these cases the drive is not recognised when I get into the windows install. The M/B guise suggested the AHCI mode.

I have also Tried using the M/B disk to install SATA drivers once I get to the windows install page also no joy.

I have checked the specs on the website I bought these from and they are both Serial ATA-300 compatible and the HDD is Windows 7 compatible.

I am somewhat out of idea's here.

The only thing i can still see is that there appear to be two jumper pins on the back of the HDD but the HDD was OEM and had no manual and i cannot find any description of what they do if anything.

If someone has any idea why this isn't working I would greatly appreciate the help.

Cheers,
Possum

Samsung SH-S223C 22x Internal DVD±R/RW SATA Drive - Black
Intel Core i5 760 2.8GHz (Lynnfield) (Socket LGA1156) Processor - Retail
Thermaltake Frio CPU Cooler
EVGA GeForce GTX 460 1024MB GDDR5 PCI-Express Graphics Card with HAWX2 PC-Game
Xigmatek Midgard Pure Black Edition Gaming Case
Microsoft Windows 7 Home Premium 64-Bit - OEM
Gigabyte GA-P55A-UD3 Intel P55A (Socket 1156) DDR3 PCI-Express Motherboard
Hitachi HDS721010CLA332 1TB 3.5" SATA II Hard Drive
Corsair XMS3 4GB (2x2GB) DDR3 PC3-12800C9 1600MHz Dual Channel Kit (CMX4GX3M2A1600C9)
OCZ ModXStream Pro 600W Modular Silent SLI/Crossfire Ready ATX2.2 Power Supply

More about : issues windows build

a b $ Windows 7
November 12, 2010 10:55:52 PM

Since you are not using RAID, try setting the PCH SATA Control Mode to AHCI, then open SATA Port0-3 Native Mode (Intel P55 Chipset) and set that to Disabled.
Related resources
November 15, 2010 2:34:22 PM

Fixed!

Don't ask me how but I got an invalid partition on the new never before used disk... figured it out using 'diskpart' a quite handy partiton tool from the windows repair section before the installation on the windows 7 disk.

Also allowed me to wipe the old partition and quickly create a new one (less than 10 minutes!)
a b $ Windows 7
November 17, 2010 2:18:47 AM

Interesting! Glad you got it working.
!