Sign in with
Sign up | Sign in
Your question

Motherboard ASRock970 Extreme 4 no onboard video

Last response: in Motherboards
Share
October 10, 2011 7:30:39 PM

Hi,

I just finished building a new system with the ASRock 970 Extreme 4 motherboard with no onboard video.

I have all of the components plugged in and powered up, but my monitor will not show anything. The video card is running (ASUS GTX 560) but nothing shows on the screen. I've tried two different monitors but neither are getting a signal. I cannot see my BIOS screen or anything.

Does anyone know if maybe I missed a step or something?

This is my second build but the first one I did had onboard video so I had not issues.

Thank you in advance.

Brad
October 10, 2011 9:43:29 PM

I am also getting 5 beeps when the dr. debug shows a code of d6.

Some research shows 'Without VGA card' or possible memory issue.

Thanks

Brad
May 25, 2012 3:36:47 PM

I installed the 970 extreme 4 and it did come up on screen. but then i couldnt use my mouse or keyboard so i restarted in hopes it would reconize it. but when i restarted i had no screen i switched pci slots with gpu and even tried a different gpu and still nothing. also my debug light isnt on anymore. i tried clearing cmos and tried resetting bois but still no screen.

i have the 970 extreme 4 amd fx 4170 with 8 gigs of gskill 1600 650W power supply

any help would be nice, thanks
Related resources
August 15, 2013 5:42:43 PM

This is a VERY old thread, but I am currently having this exact problem. If you managed to find a solution, please help me, I do not want to buy a new motherboard just to get onboard graphics. I was not aware that I purchased a motherboard without it, and I will never make that mistake again.
August 15, 2013 6:34:59 PM

Its not that hard.
August 15, 2013 8:18:36 PM

I purchased a motherboard without it, and I will never make that mistake again.
August 18, 2013 4:26:13 PM

jokewhere said:
I purchased a motherboard without it, and I will never make that mistake again.


110% agreed. I assumed that all motherboards had on-board graphics.

gomezan94 said:
Its not that hard.


Did you honestly make an account just to make that completely uncalled for comment? If it worked like it was supposed to, then no one would have this problem.
a b V Motherboard
August 18, 2013 4:33:20 PM

I had this same exact problem in the beginning when i built my amd rig, use 1 stick of ram. try that first
September 19, 2013 3:50:31 PM

May sound weird. But for future reference. If the lights on this motherboard fr the built in power and reset button are not on. You will need to "flash" the power. If you have a supply with a switch, switch it off then on quickly. The lights should then appear on. That is what I stumbled upon by accident. Hope I helped anyone who will see this
!