Sign in with
Sign up | Sign in
Your question

Renamed drives leave there old letter too!

Last response: in Storage
Share
February 23, 2013 6:25:35 PM

I renamed my drives on a x64 W7 PC, as there were four assigned to flash media which naturally are only ever used individually anyway. D is the CD/DVD reader/writer, E a card reader. I have renamed F for my Paragon image and G an external HD for my W7 image. Is there a means to remove the old drive letters next to the new ones? So now when I open "Computer" I see F (K:) ; G (I:) ; H (F:) ; etc. Thank you!
a c 888 G Storage
February 23, 2013 6:31:17 PM

Do you have a multi-card card reader in your system?
m
0
l
February 23, 2013 7:28:49 PM

I do! It's E. Then F is a mounted drive (not RAID) I store the images I make with Paragon.
m
0
l
Related resources
a b G Storage
February 23, 2013 7:50:24 PM

You cannot rename drive letters. You need to reassign them.

Start -> right-click Computer -> manage -> disk management

That will give you a list of all the drives on your system. Right-click the drive(s) you wish to give new letters, and select Change drive letters and paths. Click Change in the box that pops up and assign it a new letter.

If you wish to give a drive a letter that's already in use (e.g. you want to swap the letters on your D: and E: drives), you will first have to assign one to an unused letter, then rename the other first. e.g.
D: -> Z:
E: -> D:
Z: -> E:

Don't try to reassign the C: letter. It is possible to boot off a drive other than your C: drive on recent versions of Windows, but will cause all sorts of problems if you don't know what you're doing. Also be aware that any software which looks for things on certain drives (you said you set Paragon to backup to F:)  will continue to use the same drive letter, not the same drive. So you will need to change all those software settings.
m
0
l
February 23, 2013 8:17:56 PM

Thank you for the reply. I've already changed them. Initially I renamed F M. Then I renamed my backup drive which originally was K to F. I renamed G to N then renamed my external HD, which was I to G. Now when I view "Computer" I see (F:)  (K:)  and (G:)  (I:)  instead of just Drive F and G.
m
0
l
a c 888 G Storage
February 23, 2013 11:48:39 PM

I'm guessing you renamed M to K and N to I and forgot about it otherwise M and N should still show yet you make no mention of them.

Oh, wait. I bet you changed the drive NAME and not the drives' LETTER. which explains what you're seeing. Change the name back to the drives description and to change the actual drive letter; this article helps.

http://windows.microsoft.com/en-US/windows-vista/Change...
m
0
l
February 24, 2013 12:50:34 AM

popatim said:
I'm guessing you renamed M to K and N to I and forgot about it otherwise M and N should still show yet you make no mention of them.

Oh, wait. I bet you changed the drive NAME and not the drives' LETTER. which explains what you're seeing. Change the name back to the drives description and to change the actual drive letter; this article helps.

http://windows.microsoft.com/en-US/windows-vista/Change...

I thank you! It sort of helped in that the drive is now (F:)  (F:) ! lol If I choose remove, it goes back to one "F" but then it doesn't show up. I even temporarily changed it to "O" which was never used before and when I tried to change back to F both Fs showed up again. I suspect you are correct that it has to do with the multi card reader. I didn't even try the external HD but if push comes to shove, double "G" will control my obsession.
m
0
l
February 24, 2013 5:23:31 PM

I was pretty moronic about the whole thing but I figured out how solve it. I just removed the volume and then created new volumes (with letters I wanted). Thanks for your help!
__________________
m
0
l
!