Sign in with
Sign up | Sign in
Your question

ATI 4850 with flashing screen

Tags:
  • Radeon
  • Graphics
  • Product
Last response: in Graphics & Displays
Share
September 21, 2010 9:00:24 PM

hi,

My spec is :


Intel Core 2 Duo E6600 Conroe 2.4GHz

ASUS P5N32-E SLI Plus LGA 775 C55+MCP55P
(http://www.newegg.com/Product/Product.aspx?Item=N82E168...)

6GB Kingston HyperX Blu 240-Pin DDR2 SDRAM DDR2 800 (PC2 6400)

Antec earthwatts EA500 500W Continuous Power ATX12V v2.2 80 PLUS Certified
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

ATI Radeon HD 4850 1GB 256-bit GDDR3
http://tw.asus.com/product.aspx?P_ID=nOpTykoMNknmU1uh&t...


so after i have install/upgrade from 7800GTX to the new one i just bought 4850

first into the windows with 800X600 resloution, with win7 it automatically install the 4800 driver for me and ask for restart.

after the restart, takes over 2 mins to enter the windows welcome screen
and after enter the desktop, the monitor just kept refreshing and loads reallly realllllllly slow

basically i cant even right click on the desktop, the mouse has over 5s delay movement.
enter with the safe mode, everything is fine.

i am wondering if its the power supply that i have is not enough with 12v+ rail

i have tried to switch back to the old videocard 7800, and it works fine again
also installed the driver first w/o new card in, and in the safemode also

still after change to the 4850, the screen either kept refreshing or just takes forever to load

please help~ thanks

More about : ati 4850 flashing screen

September 22, 2010 12:54:58 AM

Well, don't use the default win 7 driver, that's only default driver, install the latest driver from amd site:
www.amd.com
m
0
l
September 22, 2010 1:43:46 AM

wa1 said:
Well, don't use the default win 7 driver, that's only default driver, install the latest driver from amd site:
www.amd.com


i did, updated the lastest version, i tried 8.1 9.7 10.1 a lot of them
still the same
m
0
l
September 22, 2010 1:55:38 AM

Then try 10.3 or 10.4, that's the most stable driver for now, make sure you use Driver Sweeper after uninstall and before installing the new driver.

If that's not working then try your card in different PC, if the same problem appears then you got a bad card.

P.S:
(9.7 and 10.8 are works for my HD4850).
m
0
l
!