Sign in with
Sign up | Sign in
Your question

Intel 520 SSD: how to unlock

Last response: in Storage
Share
February 24, 2013 7:01:11 AM

Hello,

I replaced the original Intel 520 SSD of my Lenovo X230 by another SSD. Now I would like to re-use the old SSD, but whatever I tried, I get only an I/O error.

I tried to use the Intel SSD toolbox to perform a secure erase. The result was: "Secure Erase can not be done, because ATA security is enabled. Disable ATA security before erasing the current drive." But the toolbox didn't tell me how how to disable ATA security.

In my Lenovo the user as well as the master password was set, which I know both. I tried to unlock the device with hdparm, but no success. In the meantime the SSD is not recognized by the Lenovo anymore.

So what can I do, to put this SSD into something like an initial state ?

More about : intel 520 ssd unlock

February 25, 2013 11:29:04 AM

thanks for answering, but I couldn't find a proper download for this Intel RST.

But I found a solution: fortunately the SSD was still recognized by my X230 (I should have watched carefully that the SSD is plugged in correctly...). What you need to know and this is not documented anywhere: the Hardware Password is not stored in the BIOS, the password und the user/user+master option are both stored in the SSD. Whatever is shown in the BIOS depends solely on the actual SSD. You can safely play around with this password, it will no impact the configuration of any other SSD.
To make ist short: I deleted the Hardware Password of the old SSD and then I could
reuse it in another PC.
If you have no access to the original notebook, like when buying a locked SSD from ebay, then the chance to reanimate the SSD is small. Most probably you then have an expensive door stopper.
June 23, 2013 4:30:41 AM

Hi rumpumpel1,

Sorry to revive this thread, but I am currently faced with a similar issue. I am getting the message that the device has a security freeze lock enabled when attempting to do a secure erase with Intel SSD Toolbox . I have tried power cycling and also unplugging the sata connector/rebooting/replugging, and I cannot get around the problem to do a secure erase.

Can you be more specific on how you accessed and disabled the HW password on your 520 series drive?

Mine is connected to a stand-alone PC via Asrock z77 extreme4 with hot plug capabilities enabled. I have SSD Toolbox version 3.1.5 with 400i firmware as required.

Please let me know if you require additional info. This thread is one of the only ones I've found where someone was successful in getting around hardware security, specifically for the 520 series model.

Thanks,

cupper24
!