Sign in with
Sign up | Sign in
Your question

CPU max frequency problem and i7-2600k

Tags:
  • CPUs
  • Intel i7
Last response: in CPUs
Share
February 8, 2011 6:01:31 PM

Hello all, thanks in advance to anyone that can help. Hope this is in the right section as I don't know if it's a CPU, motherboard, or W7 issue.

Have recently built a new computer around the i7-2600K, Asus P8P67 Deluxe motherboard. I'm a new at this, but learn very fast. A lot of great info was gleamed from posts here easing the build, thanks for that.

All seems well with the build except that I recently noted an issue with W7 Resource Monitor. Whenever the CPU is stressed (via Prime95 or various other things like ltspice or CAD), the "maximum frequency" plummets to around 13% or less in Resource Monitor. This is odd and disturbing as all other indicators seem to show that the CPU is indeed running at max frequency (3.5GHz) -including Real Temp 3.65, CPU-Z 1.56.3, as well as real world tests that are finishing faster than my previous stock i7-860 system (ltspice sims and CAD rendering for example).

So am confused here, a pic attached below to show the issue in resource monitor. Left side is running Prime95, right side is shortly after stopping Pime95 back to idle. Note the max CPU frequency line is low there when CPU is being stressed, rebounds at idle. Also note Real Temp and CPU-Z indicate full CPU speed while W7 resource monitor shows the exact opposite when prime95 (or other apps) is running.

Computer has been rock stable, only overclocked up to 4.3Ghz so far, but not a single glitch along the way. No BSOD, no hangs, nothing. CPU temps have not been above 60C on hottest core. Have things set back to stock/auto in the bios now (upon noting the resource monitor issue) except for memory timings, memory speed, and memory voltage. Was a fresh W7 64 bit install, updated drivers and such as ASUS indicated (Intel INF Update, Intel Management Engine Interface Driver Update 1184). Memory was tested as well as drives before and after install... no issues.

Resource Monitor issue remains the same whether overclocked or not, BIOS settings no effect. Upon startup, the Resource Monitor shows higher CPU frequency as per normal and matching Real Temp or CPU-Z data, but plummets when running apps or stressing the CPU otherwise (with Prime95 or such), reads opposite of what CPU-Z or Real Temp seem to indicate.

System Specs:
i7-2600K
Asus p8p67 Deluxe 1204 bios
EVGA GTX470 SOC+
G. Skill Ripjaws x 16GB ram (1.5V CL9 "for p67")
1TB F3 Spinpoint main HDD on 6Gb Intel sata for now
500 GB Spinpoint HDD backup on 6Gb Intel sata for now
Hyper 212+ cooler
Corsair 650HX PSU
W7 64 bit

Thanks for any advice or help, would be much appreciated. Tried to search for this issue but came up empty handed. Am I just overlooking something simple here? Anyone else have the same issue with these CPUs or P67 boards or W7?

More about : cpu max frequency problem 2600k

a b à CPUs
February 9, 2011 2:18:54 AM

Hello, and welcome to THG.

You cannot really rely W& RM as an OC monitoring tool. We have CPUZ for a reason.

I would consider monitoring in the BIOS for now, then try to see if the RM is different. In my opinion, trust CPUZ and Real Temps.
m
0
l
a b à CPUs
February 9, 2011 3:05:41 AM

I hadn't checked Resource Monitor before, but after I read your post I did. My Max Frequency reads 100% no matter what, even when CPU Usage is at 0%. I know that my CPU is throttling down when not loaded because of Core Temp and CPU-Z.

I think that Resource Monitor is a bit confused by Sandy Bridge itself or maybe confused by the different methods Cougar Point mainboards use to overclock.
m
0
l
Related resources
a b à CPUs
February 9, 2011 3:32:43 AM

It is not Cougar Point. CP is only a SATA issue.

I don't see any issue here. Maybe the RM only sees current activity as a whole rather than what the whole CPU is performing at?
m
0
l
a c 127 à CPUs
February 9, 2011 3:41:46 AM

I would try running Orthos instead as its geared towards multicore CPUs a bit more than Prime95. Might not be loading the cores properly.
m
0
l
February 9, 2011 2:35:18 PM

Thanks for the replies so far.

Tried some experiments last night, found that if I just let the computer go to sleep and then wake it up, W7 resource monitor gives me full speed in Prime95, LTspice, and everything else (102% max frequency instead of 13% or less). Now if I shutdown the computer and restart, W7 resource monitor drops again to 13% max frequency or lower. Monitoring programs read the same whether the computer is actually running full speed (after sleep) or not, aside from some slight discrepancies as can be seen below.

When the computer is dragging after a restart, running Throttlestop in monitoring mode does boost max CPU freq in W7 monitor, but only to around 30% max with no notable improvement in speed.

I ran some LTspice "benchmarks" (just a program that's very important in my day to day use and does stress all CPU cores nicely), and when W7 resource monitor reports 102% Max Frequency (after waking from sleep), the analysis does complete notably faster. When same test is run after a regular start up, when W7 resource Monitor is dragging at or below 13% max freq, the same LTspice test does take notably longer.

So, despite what Real Temp, CPU-Z, and now Throttlestop seem to be telling me, the computer does appear to be running slower when W7 Resource Monitor Max Frequency is indicating low max CPU freq.

Waking the system from sleep seems to be the only way to get W7 resource monitor to go full speed as well as speeds up the system notably (not extremely drastic, but a very clear difference). Real Temp, CPU-Z, etc seem to indicate all is well regardless if run after a startup or wake up, but something is definitely different when the computer wakes from sleep.

Does the slight difference in indicated CPU speeds in Real Temp and Throttle stop mean something here? Hopefully the waking from sleep "curing" to the issue will give an idea what the problem may be.

Also should note, I've not had resuming from sleep issues with this motherboard as many others have, not had to change BIOS settings there. Also running 1600MHz memory, but letting it default to 1333Mhz makes no difference.

Thanks for any help, very much appreciate the responses so far.

m
0
l
a b à CPUs
February 9, 2011 4:04:50 PM

Maybe the sleep setting is the problem. I have mine set to Performance mode -- the only thing that powers down on my system is the monitor. Everything power-saving in the UEFI is set to Disabled. No sleep, no hibernate, no nothing.

dogman_1234: "It is not Cougar Point. CP is only a SATA issue."

What I was saying is that Resource Monitor might be confused by some mainboards overclocking by Turbo and some overclocking by base multiplier. I know my mainboard can do both, but it's overclocking by Turbo right now. And Cougar Point is the H67/P67 chipset, so any mainboard with a Sandy Bridge CPU is a Cougar Point mainboard. People seem to be getting Sandy Bridge and Cougar Point confused nowadays.
m
0
l
a b à CPUs
February 9, 2011 5:11:00 PM

Not really, not with the help of the fiasco.

I thought you were trying to say that the P67 NB chip was the reason RM was not recognizing SB to the true potential.
m
0
l
February 9, 2011 7:13:22 PM

Seems sleep is this computer's best friend. Tried disabling all power saving and sleep in the BIOS and W7. No real effect/help. Setting W7 power profile to high performance does keep the CPU frequency from ever dipping below 80%, but actually seems to prevent the CPU from ever reaching 100% max frequency or above too. Bounds around 85-95% under load, 90's at idle. Performance still suffers the exact same as when the CPU drops to 13% or below in W7 resource monitor as well.

So far cannot figure out anything that cures the issues aside from just letting the computer sleep (for even just a second or two). Do that and all is perfectly well in W7 resource monitor and everything else -whether running stock speeds or overclocked to 4.3GHz. Leaving the CPU at stock speed though, until this is sorted.

What changes (or could be changing here) once a computer is awoken from sleep?
m
0
l
a b à CPUs
February 9, 2011 9:09:12 PM

Nothing. All the data begins to move around again.
m
0
l
a b à CPUs
February 10, 2011 2:22:13 AM

Are you running the newest BIOS for that board? If not, update it.

If it continues to happen after the BIOS update, then I'd RMA the board. Something's not right if the best performance only happens when coming out of sleep mode. I've never heard of that kind of problem, but I wouldn't have checked Resource Monitor for that particular gauge either so I wouldn't have ever known there even was a problem. Lucky for me that my system runs at 100% like it's supposed to.
m
0
l
February 10, 2011 6:22:32 AM

I'm running the current "official" BIOS, 1204. May just be a buggy W7 resource monitor, but real life performance does seem clearly effected, seems to back up the W7 resource monitor (at least in that something isn't right, not that the CPU is really that slow). Synthetic benchmarks show a bit worse performance pre-sleep, but nothing too significant.

Don't know, but I know I shouldn't be seeing the below just from letting the computer sleep for a few seconds. Without sleep, W7 Resource Monitor will give readings as below bottom indefinitely when running prime95 or other CPU stressing apps. After a couple seconds of sleep, all goes to normal as seen on the top. Something must be changing after sleep here??

m
0
l
a b à CPUs
February 10, 2011 7:38:08 AM

Well ... you'll be getting a new board anyway soon. Hopefully that one will work correctly out of the box, or someone will have come up with a fix/workaround by then.

By the way ... have you mentioned this issue to ASUS at all? I know at other forums, they have official tech support guys that respond to things like this.

As far as overclocking goes, go ahead and do it if you want to. The overclock isn't going to hurt anything.
m
0
l
a b à CPUs
February 15, 2011 1:58:21 AM

I don't know that it means anything, but I've got some new info on this issue...

I've done quite a bit of fiddling with UEFI settings over the past few days, trying to get the maximum overclock out of my Sandy Bridge CPU. I was only partially successful, but I noticed some things.

At stock CPU settings, the Max CPU Frequency gauge fluctuates. Nowhere near as much as sdm's, but it does. Depending on the program that's loading the CPU, it can be anywhere from right around 45-50% to 90-95%. I run Einstein@home and it hovers around 50% when that's loading all four cores and the GPU core too. It's higher with Prime95 and IntelBurnTest though.

Using manual overclock settings, it does the same type of thing.

However, when I use the overclocking presets in the ASRock UEFI the gauge stays at 100% whether the CPU is idle or fully loaded. No matter which preset is chosen, the gauge reads 100%. I was using one of the presets when I initially responded to this thread on the 9th. I have no idea what's different about the presets though. Maybe it switches a certain register within the CPU and Resource Monitor is reading that change. If that's the case, then the same register is switched when coming out of sleep mode on sdm's machine.

I haven't done any testing to see if performance fluctuates along with the gauge and I don't plan to.
m
0
l
February 15, 2011 4:56:53 AM

Some things I've tried recently:
Created a new user profile, just to see if my usual one is corrupt. This does have an effect, but CPU freq still drops erratically and more along the lines on 50-75% max (when running Prime95 or such). Despite a bit better results there, real life usage tests showed no improvement over the original pre-sleep profile. Sleep, as always, resolves the issue. Got nowhere meaningful there, so deleted the new profile.

NVIDIA drivers have been a bit iffy lately (at least on my old machine), so thought I'd remove and reinstall them (clean reinstall). No difference.

Double checked all Intel, USB,, etc.. drivers are the newest available, no effect.

Tried disabling some more services and such, but I run the computer very lean to start with, no effect.

All adjustments are made in the BIOS, I don't have the ASUS OC'ing software installed. Currently running perfectly stable 4.3GHz (except sleep issue still persists though of course). Haven't really tried any ASUS auto OC'ing in BIOS or such as voltages are set for far more than this chip needs, temps suffer, but maybe I'll see if that has an effect. I'm OC'ing using offset to keep CPU voltage much lower (temps as well). The OC has no effect on the issue, still need to let it sleep as usual.

Any way just thought I'd throw in an update. Also tried ASUS tech support and forum. Have heard nothing back from ASUS tech support, forum no help either unfortunately.

m
0
l
February 23, 2011 11:05:45 PM

Ok, guess one last plea for help here. Spent a good deal of time trying to see if anything service or process-wise changed before and after sleep to no avail.

Since I use an NVidia graphics card, I have always have EVGA precision set to run when Windows starts. On my I7-860 machine (also has W7 64 bit), I don't have this issue, so it never dawned on me to turn Precision off.

Well after turning off Precision (and before letting the computer sleep), running no other monitoring software, the max CPU frequency rebounds in W7 resource monitor while running Prime95. Not a stable full speed line like I get after sleep, but it generally bounds between 90%-112% max frequency (computer is OC'ed to 4.4Ghz). If I turn on Precision, max CPU freq plummets as usual. If I turn that off and turn on real temp 3.67, CPU freq also plummets, same deal for Throttlestop. CPU-Z is the only thing that won't plummet the CPU freq in Resource Monitor while Prime95 is running.

Now after letting the computer sleep, I can run all of these programs individually or together and the max CPU frequency in W7 Resource Monitor will stay pegged and solid at 126% running Prime95. Still don't know what changes after sleep here, but hoping the above may give someone here an insight as to what the issue may be, and hopefully how to resolve it. Would much appreciate it, thanks.

-Steve
m
0
l
July 28, 2012 3:46:53 PM

My fresh install of W7 revealed the same problems you described. Fortunately, after reading your thread, I found that the solution which is to put the computer into SLEEP mode works for me also. Wasn't really expecting it to, but it does!!

I believe it to be an outdated chipset driver. But I can't seem to upgrade it correctly. I was curious to know if you found out what the core to this problem was? Have you more info since?

-Jason
m
0
l
August 4, 2012 5:42:03 AM

Problem was resolved, but not 100% sure why. What ultimately fixed it was the rev B3 motherboard replacement I received after the SB recall.

I had tried reseating things (even rebuilding the thing), reinstalling W7, updating or just trying different drivers/BIOS/etc.. with original board, but nothing helped.

When new board arrived, I did not do a fresh reinstall of W7, just installed new MB, tried booting up and issue was simply gone from that very first boot. Set up a 4.3GHz OC, issue has never returned with the replacement B3 board.

Do not recall if the B3 replacement board had a newer BIOS when it arrived, possible, but highly doubt it. Had the replacement cross shipped, computer was not down long at all (only a couple/few days maybe). Kept on top of the BIOS updates right up until I needed to ship back (since this was my main computer). Had hoped that would eventually solve my problem, but of course nothing ever did- well, until I simply swapped in the B3 motherboard.

So, can only guess it may have just been a motherboard issue. Possibly BIOS, but I doubt that as again it was only down for the swap maybe a few days at the most, and I hadn't heard of anyone else having this issue with any BIOS.

Another thing, just remembered, is that I started to have trouble resuming the system from sleep. After a lot of time trouble shooting that, realized it only occurred if the room temperature was below a certain point (exact temp I cannot recall now). Below that room temp though, computer could not resume from sleep. Above that room temperature, computer resumed from sleep every time, no problem at all. So maybe had a bad sensor or flexing solder joint/s or such, not sure, but seems to add credence to the motherboard having issues/being defective.

This was (and still is) my first build, so I can't say anything with certainty, but hope any of the above helps. Know this issue really bugged me (despite otherwise seemingly running OK), hope you can resolve it in your build.

-Steve
m
0
l
!