Is this normal for a 5770???

iam playing assasins creed and iam getting alot of flickering uneven shadwos and so on and this well this just take the cake



so driver issue iam using the 10.9 drivers and this is the first time i bought ati cards starting to regret it :( should i try to change the driver or is this acard issue???? plz help would be appreciated the card never really gets past 75 celcius and it goes down to 60 if set the fan speed at 70%
25 answers Last reply
More about normal 5770
  1. what do u mean by set up the card???
  2. theunkown said:
    what do u mean by set up the card???

    Who are you talking to?
  3. Did you overclocked the card?

    Did you set up the card properly in CCC?

    Have you tried a different driver?


    Quote:
    what do u mean by set up the card???


    well, when you install the card and the driver the first thing you do is open the Catalyst Control Panel and adjust your settings/resolution/visuals etc..
  4. oh yeah i did that
  5. If you have a different connector to the monitor like DVI or HDMI, then try running it on those.If that does not work uninstall the drivers completely using driver sweeper and install catalyst 10.4.
  6. and iam getting fps 30+ only on max with 1440x900 rez and no overclocking
  7. Mousemonkey said:
    Who are you talking to?


    I had deleted my post right when he replied :D
  8. nope iam using the dvi to vga adapter thought
  9. OvrClkr said:
    I had deleted my post right when he replied :D

    Righteo! :lol:
  10. oh yeah i had the intel hd graphics drivers but they where disabled automatically when i started using the first card
  11. Have you still kept those onboard VGA drivers?Uninstall them immediately and try to get catalyst 10.4.
  12. i uninstalled them iam going to use catalyst 10.4 DAMMIT THIS SUCKS i regret getting the 5770 i prolly will eat my words in a few minutes
  13. theunkown said:
    oh yeah i had the intel hd graphics drivers but they where disabled automatically when i started using the first card


    Try this :

    1. Download the driver to your desktop + uninstall your current driver from the control panel.
    2. Download driver-sweeper and make sure you uninstall ALL your video drivers including the 10.9’s. (CCC/ATI/Nvidia/Physx etx..)
    3. Re-boot and run driver-sweeper again making sure you have no leftover files.
    4. Install the new driver that you saved to your desktop and re-boot.
    5. Done..

    Driver-sweeper
    http://www.guru3d.com/category/driversweeper/
  14. did all that but i cant access ccc anymore weird???
  15. dammit now i have broken drivers
  16. ook ill uninstall them from windows try driver sweeper again and then instal the 10.4 drivers again WTF I CANT UNINSTALL IT SAYS THE FILES ARENT THERE BUT IF I RIGHT CLICK I CAN STILL SEE CCC
  17. OKI CMON PEOPLE PLZ NO DRIVER NOW installs after i do the driver sweaper thing everything is exactly the same when i tyr to install the 10.4 drivers whe i reboot ccc wont open
  18. Try to to the above steps in safe mode.
  19. Stop bumping your thread or I'll close it.
  20. ok mouse but iam stuck with inactive drivers and i have done druver sweaper in safemode
  21. Have you got .NET framework installed?ATI requires it for installing their drivers.
  22. yeah i do and when i try to install the 10.4 drivers i get this in the log ATI Display Driver
    Final Status: Fail
    Version of Item: 8.723.0.0000
    Size: 90 Mbytes
  23. i think ill just do a system format and see where i get from there
  24. i did a fresh reinstall with the 10.4 drivers and now iamgetting twice the normal fps in cod usually 60-70 in the heavies places now its 120-150 just had 1 micro stutter throught an entire level and its max is 220
  25. for anyone who cares its probably the game becuz i got it from gamevalley and i just realised they sell pirated games thats why it was so cheap its a tdp version downsapled movies and only english language and a downgraded graphics engine i guess
Ask a new question

Read More

Graphics Cards Graphics