Sign in with
Sign up | Sign in
Your question
Solved

AHCI regedit disaster

Last response: in Motherboards
Share
October 12, 2011 3:11:44 AM

Hello all I have just noticed that I never had AHCI enabled and performed the following regestry edit

1.Exit all Windows-based programs.
2.Click Start, type regedit in the Start Search box, and then press ENTER.
3.If you receive the User Account Control dialog box, click Continue.
4.Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINESystemCurrentControlSetServicesMsahci
5.In the right pane, right-click Start in the Name column, and then click Modify.
6.In the Value data box, type 0, and then click OK.
7.On the File menu, click Exit to close Registry Editor.

After this you’ll have to restart your computer, go to BIOS and enable AHCI. When you log in to Windows again, you’ll notice the installation of drivers for AHCI. Another restart will be required to finish the driver installation.

These steps are provided at your own risk and not suggested unless you know and understand the risks. You will want to make sure the controller driver and MB BIOS support this option before you enable it

But after that when I restart in AHCI mode I get this message:
Error CD-ROM boot priority ...no boot Medium Reboot and select proper boot device and press a key or just shoot yourself

The only way I can get windows to boot is to change the storage configuration back to IDE.

Any help would be ferkin brilliant, I have No Idea.

More about : ahci regedit disaster

October 12, 2011 12:54:24 PM

I just re-read what I posted and realized that with what I have written it looks as though I should probably have posted this in the Windows section but what I'm actually asking is where do I get the drivers I need for my Asus M4N98TD EVO that I'm being asked for during the boot process, and once I have them do I have to burn them to a disc and insert it once it asks?...
I can't find them at the official ASUS site and it also looks like I'm missing my coprocessor driver which I also can't find!.
m
0
l
a b Ĉ ASUS
a b V Motherboard
October 12, 2011 1:34:04 PM

Hello hankmarvin;

drivers for AHCI = SATA drivers.
What version of Windows are you working with?
m
0
l
Related resources
October 12, 2011 1:36:26 PM

Windows 7 Home premium 64 bit
m
0
l
a b Ĉ ASUS
a b V Motherboard
October 12, 2011 1:45:03 PM

Which already has SATA drivers installed.

Have you tried a System Restore yet?
m
0
l
a b Ĉ ASUS
a b V Motherboard
October 12, 2011 1:46:34 PM


Actually, I recommend you punt this question over into the Storage forum.
m
0
l
October 12, 2011 1:49:46 PM

This is a fresh install after that didnt work
m
0
l
October 12, 2011 1:58:28 PM

Both of those are set to 0, they already were.
m
0
l
October 12, 2011 1:59:59 PM

Just to double check it is in the storage configuration on the first page of the BIOS that I set it from IDE to AHCI isn't it?...why is it asking me to put a disc in and hit any key, what disc is it referring to do you know?...
m
0
l
a b Ĉ ASUS
a b V Motherboard
October 12, 2011 2:01:51 PM

I'm not familiar with your BIOS:
As far as I know there will only be one place in the BIOS where that change ACHI would be possible.
m
0
l
a b Ĉ ASUS
a b V Motherboard
October 12, 2011 2:02:37 PM

hankmarvin said:
This is a fresh install after that didnt work
Before the fresh install had you switched over to ACHI at that time?
m
0
l
October 12, 2011 2:13:18 PM

I didn't know about AHCI before I installed windows the first time. I changed the registry manually via those instructions when I changed the BIOS settings to AHCI it goes to the black screen asking for the boot cd. I unselected AHCI back to IDE it boots to windows again. I ran Microsoft updates until the cows came home. I manually checked all my drivers via device manager, there is only one driver with a problem, the coprocessor is not there and windows cannot find an update for it and neither can I. I figured something had become messed up somewhere along the line and re-imaged windows. Still no joy so I re-installed windows and still no joy. I tried to install windows with AHCI option enabled and it would not do anything, it just said it could not install windows to disc 0 partition 1, the only way to re-install windows that I could find is to just re-install in IDE mode and re-try to manually adjust the AHCI option after again. No joy.
The strange thing is I re ran the Windows System performance test and the hard drive rating did increase even without the AHCI option enabled in the BIOS. It went from 5.9 to 6.5?...how's that even possible!.
m
0
l
a b Ĉ ASUS
a b V Motherboard
October 12, 2011 2:26:53 PM

I've run out of ideas. A punt to the Storage forum is still an option.
Also - you can edit the topic title here to mention your motherboard and see if you can get a M4N98TD EVO owner to peek in who might know something more.
m
0
l
October 12, 2011 2:33:27 PM

Thanks for your help anyway, at least that way I know it isn't something obvious I'm missing. How do I edit the thread title?...does a moderator have to do that?...
m
0
l
a b Ĉ ASUS
a b V Motherboard
October 12, 2011 2:35:11 PM

You can edit your own posts - the first post you made will give you the option to edit the title too.
m
0
l

Best solution

a b Ĉ ASUS
a b V Motherboard
October 12, 2011 2:36:30 PM

hankmarvin said:
I know it isn't something obvious I'm missing.
Agree - there is something a bit different going on it seems.
Share
a c 207 Ĉ ASUS
a c 717 V Motherboard
October 12, 2011 3:38:30 PM

The simplest is to run Fix It -> http://support.microsoft.com/kb/922976

Some MOBO's allow 'some' of the SATA ports to be IDE and others AHCI; it's best to have them ALL one way or the other. THEN go into the Registry or use 'Fix It' but be careful to ONLY change the Start = 0 and nothing else.

See:


IF you accidentally created a corruption, the simplest 'fix' is to play musical SATA Ports with ALL the drives, be careful if there's a RAID and reboot. This causes ALL of the drivers to be re-installed and the Registry values re-written.

m
0
l
October 19, 2011 1:59:26 AM

Best answer selected by hankmarvin.
m
0
l
!