Sign in with
Sign up | Sign in
Your question

ASRock Z68 Extreme4 Gen3 Usb Laggy

Last response: in Motherboards
Share
October 12, 2011 2:32:52 PM

Hi,

I just built a new PC with an ASRock Z68 Extreme4 Gen3. From the first time I started the PC, both my USB mouse and USB keyboard lag out for periods of time ranging from barely noticeable to as much as 3 or 4 seconds at a time. When this occurs the rest of the system runs normally. If I am playing a game, the game continues to run at the same framerate with no stuttering or slowing down. Sometimes it is just the mouse, and other times it is just the keyboard. Sometimes it is both. It can occur with no programs open. I leave the windows system monitor open and see no CPU spikes or other indications that the system is experiencing issues.

The system sees the problem both on stock CPU speeds and overclocked speeds. The problem occurred before I ever attempted overclocking.

This occured the very first time I started my system up. I am convinced that both the mouse and keyboard are fine as I have used them both on two other computers now without an issue. I played a few games on two other computerss with them for over an hour and had no input lag. I switched back to my new PC with this motherboard and immediately saw the issue again.

I am on Windows 7 Home Premium SP1, fully patched as of today.

Troubleshooting (tested USB for lag before attempting the next step. Saw lag after each step):

1)Restart system.
2)Update the BIOS. I am currently on the latest BIOS version 1.1. I continued to experience issues.
3)USB drivers. I updated to Etron USB 3.0 driver ver:0.96_WHQL. This did not fix the problem.
4)Beta USB drivers, Etron USB 3.0 driver ver:0.104_WHQL. Still no improvement.
5)Try different USB ports. I have now tried every port on the system, both USB 2.0 and USB 3.0.
6)Try a different mouse.

I am STILL seeing issues with input lag that is making gaming extremely difficult. The problem is intermitant. Sometimes I will play 30 minutes without a problem. Other times I will experience lag every 5 seconds or so. In one game, you fire a machine gun by holding down the mouse. Even with the mouse button being held down, my gun will stop firing, then start firing, then stop firing, all without me ever releasing the button! During this time the gameplay does not stutter or show signs of slowing.

It seems as though added bandwidth makes the problem worse. Previously, all my tests were done with only a mouse and keyboard in use. I tried a Logitech G35 USB headset and the problem seemed to get worse. At times the sound would start to cut out in the headset and there would be static.

Does anyone have any ideas?
a b V Motherboard
October 12, 2011 4:30:34 PM

Sounds like an Issue with the USB controller.

By any chance do you have anything else plugged into the USB? say a USB HDD, or a flash drive? If so disconnect those as well.

Also, does your BIOS have USB options? Say for example - USB- Legacy or Enhanced option. If one of them is selected - try selected the other one.
m
0
l
October 12, 2011 7:25:56 PM

Thanks for the quick reply. I'll try that tonight when I get home from work. If I can't get it working soon I'm probably going to order a similar mobo from another company and return this one. I built the PC to play BF3 and Skyrim and I don't have time to wait on a repair or swap.
m
0
l
Related resources
October 12, 2011 11:52:01 PM

In the BIOS the USB controller was set to legacy on. I turned legacy off and restarted the system. I'm still getting input lag, though maybe at a slightly decreased frequency.

The only things plugged into the USB ports are the mouse and keyboard dongle and the USB headset. I've tried with and without the headset and get lag both ways.

Any more ideas?
m
0
l
a c 716 V Motherboard
October 13, 2011 12:14:58 AM

Seems the assumption is USB itself, what about the Keyboard/Mouse drivers?

Q - What changes to the BIOS above 'Load Defaults' have you made?
Q - How does the Keyboard/Mouse work on another PC?

IMO don't use 'ASRock XFast' at least not yet, uninstall and test if being used. In addition, most of the Utilities are bad: ASRock Extreme Tuning Utility, ASRock XFast, and Instant Boot.

Run MSCONFIG and select Diagnostic, boot and compare lagging. IF corrected then there's a conflict.
m
0
l
October 13, 2011 12:26:24 AM

The only changes I've made to the 'Load Defaults' were CPU multiplier and voltage. The USB inputs were experiencing issues before I ever changed a single BIOS setting. The first time I changed BIOS settings relating to the USB was on my last reply.

I'm using the same Logitech drivers on two other Windows 7 PCs with no issues. The mouse and keyboard work fine on those systems. I will uninstall the drivers on this system and see what results I have.

I did not use Xfast when the problems started. Earlier tonight I installed Xfast, just to see if it would fix the problem (it didn't). From what I understood after installing it, it is ONLY active when transferring data. It does nothing for peripherals. I can tell this because when I plug in my external hard drive, the Turbo options turn on, but the rest of the time the options are disabled.

Instant boot is not installed.

ASRock Extreme Tuning Utility is installed. However, it is not a background service and is only active when opened. It only makes modifications to your BIOS through windows, and does not actually activate those changes until you restart the system. I do not see how this program could affect USB settings.

I will try doing as you say with MSCONFIG and post the results soon.

Thanks for your help. I'll post more info as I test.
m
0
l
a c 716 V Motherboard
October 13, 2011 12:43:58 AM

You're assuming quite a bit. ASRock Extreme Tuning Utility {same as ASUS AI and Gigabyte's Easy Tune6} runs open or not and frequently conflicts with manual BIOS settings, and causes more problems than I can count.

I'm not going to guarantee uninstalling it will correct the problem(s), but it's one big BIOS invasive {variable} out of the equation. Re-install it afterwards.

Unfortunately, there are very few Apps that I trust that ASRock or ASUS writes. Less = More.

That said, the Keyboard and Mouse I'll assume are functioning properly.

Failure, shutdown and pull the USB Front Headers (USB 2.0 and if equipped USB 3.0) -- i.e. just use the Rear I/O USB, and reboot/test.
m
0
l
October 28, 2011 2:13:59 AM

Hi!

I am having the same issue. Did you find a solution to this problem?
m
0
l
October 28, 2011 2:24:59 AM

Yes, I did.

I returned the ASRock motherboard and bought an EVGA board instead.

Problem went away.
m
0
l
March 20, 2012 7:16:05 PM

Hello. I'm having the exact same problem, only that the problems are accuring more and more often.

I tried:

- Deinstalling all drivers and switching back to the CD-drivers
- Patching BIOS to 1.1, 1.2 and 1.3
- Updating to the very latest drivers on Asrock Homepage
- Updating to latest USB 3 drivers

Nothing worked. Any suggestions?
m
0
l
March 27, 2012 12:55:26 AM

I wish I could help, but I seriously just ended up switching boards to another brand and the problem went away. Best of luck.
m
0
l
!