Sign in with
Sign up | Sign in
Your question
Closed

BIOS won't recognize my SATA hard drive

Last response: in Motherboards
Share
October 12, 2011 3:14:55 PM

Hi everyone, i'm new to Tom's but it looks like this would be the best place to get some advice on a problem that i'm having. I'm at a loss with what to do.

I'm doing a fresh build (not my first), and i'm using an MSI 870S-46 motherboard. Everything fires up beautifully with the configuration, but for some reason the BIOS won't recognize the hard drive. I've done some tests and it looks like all of the SATA ports work (the BIOS recognizes my optical drive in all ports), but the hard drive just won't show up for some reason. To make sure it wasn't a bad hard drive I picked up a second brand new drive, and it won't recognize it either. The strange part is that when I try and format windows, it says it can't recognize a drive, but when it gives me the option to search for drivers to upload, a C drive option is on the list. So some part of the hardware recognizes a drive is attached, but the BIOS doesn't. I've tried downloading drivers from a flash drive from the main MSI site, but it can't seem to find any compatible drivers when I try and load them. Does anyone have any suggestions? Any advice would be greatly appreciated!

MSI 870S-G46
Western Digital Caviar Blue 320GB SATA Hard Drive
EVGA Geforce GTX 460
OCZ 700W Power Supply
4GB of RAM (2x2 sticks) DDR3 G.Skill Ripjaw
AMD Phenom II Quad Core 3.4 GHZ

a c 212 V Motherboard
October 12, 2011 3:53:25 PM

What mode (in your BIOS) is your SATA ports set to (IDE, AHCI, or RAID)? I suggest IDE mode if not already set that way, for now.
Score
0
October 12, 2011 3:57:18 PM

I've actually tried all 3 of the modes to no avail. I currently have it set to IDE, though.
Score
0
Related resources
a c 716 V Motherboard
October 12, 2011 4:09:49 PM

Welcome to Tom's Forums! :) 

Q - What OS?
Q - What SATA Port(s)?
Q - Does the ' Caviar Blue 320GB' show-up on another PC's SATA?

Use SATA Port 1 for the Primary HAD, top closet to the MOBO's PCB.

I assume that both the SATA Cable and SATA Power are both connected and 'Good'.

If the failure persists then 1st do a Clear CMOS, I prefer the Jumper method and to know you had a successful Clear CMOS both the Date/Time should be cleared, Load Defaults and set Date and Time -> http://www.youtube.com/watch?v=rdHH9KrceR0 BIOS RAID Mode -> AHCI.

Failure again, go to WD -> http://support.wdc.com/product/download.asp?groupid=606... create a CD with 'Data Lifeguard Diagnostic for DOS (CD)' {Diag504fCD.iso} then boot and run 'QUICK' tests. Use Acronis True Image WD Edition and Format.
Score
0
October 12, 2011 4:28:15 PM

Thanks for the welcome!

A: Windows 7 X64
A: 6 ports on the board, two facing up on the board (assume these are the two primaries), and there are 4 sideways, which I assume are for RAID. I've tried all of them.
A: Haven't tried the HD on another system, but will definitely try it.

The bios does recognize the optical drive, and i've used the same cables/power and data with the HD and it still doesn't recognize.

I appreciate the CMOS option, and will try that as well. Am not familiar with the process. I will aslo try the DOS CD with the WD software.

I've also read somewhere to try updating the RAID drivers in the BIOS, but i'm not sure that it applies since i'm not trying to set up a RAID.
Score
0
a c 716 V Motherboard
October 12, 2011 4:39:07 PM

Use the SATA Ports closet to the 24-pin main (top is primary), not those in the middle (facing up) or bottom. Frankly, it 'shouldn't' matter.
Score
0
October 13, 2011 5:20:32 PM

So I tried updating the BIOS and clearing the CMOS, and neither solution worked. Will try the DOS disk as well. At this point am thinking there might be a problem with the controller, as this is taking far too long to figure out. MSI customer support had nothing additional to provide when I called them either. The joys of technology.
Score
0
a c 716 V Motherboard
October 13, 2011 5:29:35 PM

Failure again, RMA the MOBO :( 
Score
0
a c 212 V Motherboard
October 13, 2011 6:05:52 PM

jaquith said:
Failure again, RMA the MOBO :( 

+1^. I completely agree.
Score
0
October 13, 2011 6:28:15 PM

If ur Mobo have e-sata port, try to test ur HDD at that port.
Score
0
!