Sign-in / Sign-up
Your question

Secong RAID 0 not being seen in Windows

Tags:
  • Asus
  • NAS / RAID
  • Storage
  • Hard Drives
  • Motherboards
Last response: in Motherboards
October 13, 2011 2:16:36 PM

I just installed 5 HDD to make two RAID 0's and a storage drive. However Windows does not see the new array. I have gone under Disk Management and it is not there, I have looked below at dries that aren't partitioned yet, and it's not there. However it does show in BIOS and when booting. I also see it when I go to my NVIDIA control Panel and look at my storage configuration it shows that there is an array but says error and only list one of the drives ( the one that used to be by itself).
Configuration:
ASUS M3N78 Pro MoBo
Win 7 64
(2) WD 160GB Caviar Blue HDDs setup as RAID 0 and my boot drive (Ports: SATA 2 and 3)
(1) WD 1 TB Caviar Green HDD for storage (Ports: SATA 1)
(2) WD 160gb Caviar Blue HDD setup as RAID 0 for a scratch disk. (Ports: SATA 4 and 5)
..... important to note about the scratch disk raid. I had (1) 160gb in there for a couple years now. However I just bought an additional 160gb (same model and everything). cleared the original disk and spanning setup for one disk and created a new array with the new disk. The original drive is the one that is showing in the Storage Configuration list.

In addition while typing this out, I just tried moving the old drive from Sata 4 to Sata 6 to see if that matters (this is one of the boards that as 4 and 6 to the side and set as RAID only). Again both of them show up as healthy when booting. Windows still does not see the new array, and now NVIDIA control panel doesn't even show the new array in the Storage Configuration window. So that leads me to believe that something is going on that windows can't see the other two sata ports.
any ideas? thanks

More about : secong raid windows

a c 207 Ĉ ASUS
a c 716 V Motherboard
October 13, 2011 2:30:12 PM

As an observation, some MOBO's treat SATA Ports 1~4 differently than the remainder SATA Ports, therefore IMO move:
WD 1 TB Caviar Green ; SATA1-> SATA5
WD 160gb Caviar Blue HDD ; SATA5 -> SATA1 and perhaps 'redo' the RAID 0 for that paired RAID.
m
0
l
October 13, 2011 2:42:15 PM

jaquith said:
As an observation, some MOBO's treat SATA Ports 1~4 differently than the remainder SATA Ports, therefore IMO move:
WD 1 TB Caviar Green ; SATA1-> SATA5
WD 160gb Caviar Blue HDD ; SATA5 -> SATA1 and perhaps 'redo' the RAID 0 for that paired RAID.

thanks for the quick response. Since the drive on SATA 1 is in Spanning Array (if any drive is RAID, all drives have to be RAID), will moving it's port make me erase the old array, and therefore delete all the data on the disk?
m
0
l
Related resources
a c 207 Ĉ ASUS
a c 716 V Motherboard
October 13, 2011 2:59:39 PM

RE "(1) WD 1 TB Caviar Green HDD for storage (Ports: SATA 1)"

You have the above listed as an individual HDD, so moving it won't do a thing. It shouldn't do a thing with the RAID 0 either, but IMO I would 'redo to be safe; the one RAID 0. I assume the RAID is set-up in the <F10> RAID Utility of the BIOS, and the Drives are identified with their 'ID' S/N so upon a boot the RAID should link its' correct location.

I assume the problem array is the "2) WD 160gb Caviar Blue HDD setup as RAID 0 for a scratch disk. (Ports: SATA 4 and 5) " ; if not then let me know.

BTW - I just looked at your MOBO's specs and noted "6 xSATA 3 Gb/s ports (Use SATA1-4 for IDE mode.) " which seems to support my 'feelings' of the core problem. I 'get' your in SATA -> RAID mode and this 'shouldn't' apply but maybe it does.
m
0
l
October 13, 2011 3:17:57 PM

I was able to move the ports without removing the data. I hadn't tried that yet because of loosing the data (although i have the files backed up, it's a production machine and I don't have time today to transfer all that data back over.. looks like it may come to that over the weekend though).
all your assumptions are correct.
I moved the new disk from SATA 5 to SATA 1 and moved the 1TB to SATA - 5. I made the new array for the 2 160gb drives.
Now when I go into windows, it sees my new array (SATA 1 and 4), however it no longer sees my 1TB that is now on SATA 5. The 1tb is not in Disk Management or in the NVIDIA control panel. It did show up in the <F10> configuration utility though.
the natural assumption would be that windows will not see anything on SATA 5 and 6 because of some issue. HOWEVER, in the meantime I had moved my new 160 drive to SATA 4 and my old 160 drive from SATA 4 to SATA 5. Did not make them an array, and Windows then saw all of my drives (my boot array, (1) 1 tb, 160gb, and a second 160gb. So it's seeing SATA 5, just not when I want it to. arrrr.
I do have to put this back to normal to get my work done for the day. However any suggestions I'll try later this evening. Thanks for you help!
m
0
l
a c 207 Ĉ ASUS
a c 716 V Motherboard
October 13, 2011 3:46:23 PM

Hmm...that's interesting, my first obvious) thought is the SATA Port 5 is 'bad' or 'data only/unbootable' -- how about SATA Port (6)?

Also, Windows 7 often gets the 'Start' registry values wrong. BIOS = AHCI/RAID <=> Start = 0, in contrast Start = 3 = IDE. A non invasive way to see if this is a problem is to look at the following (2) Registry subkeys:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV
Example note the Start = 0; this is from my SSD + RAID 1 and they're correct:


ref - http://support.microsoft.com/kb/922976

Per manual:
SATA 5-6 connectors support AHCI mode and RAID mode only. Make sure to install the AHCI driver or RAID driver in the bundled support DVD before connecting devices to SATA 5-6 connectors. Otherwise, the devices will not work.
• Due to chipset limitation, when set any of SATA ports to RAID mode, all SATA ports run at RAID mode together.
m
0
l
October 19, 2011 1:39:44 AM

thanks for the help. Since Windows saw the 160gb drive in SATA 5 when I installed it and did not set in the RAID menu as spanning or anything. I went ahead and moved my 4 160gbs to RAID 1-4 and set those RAID 0 configurations and then put my 1tb on SATA 5. I deleted the spanning volume that the 1tb was on by it self and just let it boot up not being configured in the RAID menu. Windows recognized it fine, I just had to format it. Now copying data back over.
I also went ahead an added a 2tb that I had been planning on adding into SATA 6 and again did not configure it in the RAID configuration menu. Again, Windows recognized it fine. Seems like all is good. Just went ahead an bit the bullet to format my 1tb to make life easier on myself.
m
0
l
a c 207 Ĉ ASUS
a c 716 V Motherboard
October 19, 2011 2:02:15 AM

So pretty much as I first said:
perhaps 'redo' the RAID 0
SATA 1~4 WD 160GB ; RAID
SATA 5~6 WD 1TB & 2TB ; non-RAID

Later, keep in mind WD is pretty much screwing customers for 'consumer' HDD's - they turned-off TLER! TLER - http://en.wikipedia.org/wiki/Time-Limited_Error_Recover... so if you have problems later keep that in mind. Also keep in mind RAID 0 is fine for OS and Apps and is Highly Risky of ANY Data, and x4 HDDs in RAID 0 just throws the risk through the roof.

BACK-UP Frequently!!!

Generally, I recommend RAID 10 with x4 HDDs.
m
0
l
October 19, 2011 2:08:15 AM

yes, exactly as you first said I just didn't want to have to reformat the 1TB. I still think there should have been away around that, but oh well.
thanks for the info about TLER as well.
As for the setup, you can sleep tonight knowing that my data is not in RAID!
The 4 drives are configured in two RAIDs. One RAID 0 with two drives is for my OS, the other RAID 0 with 2drives is for my scratch disk.
The 1tb, non raid, is for personal data. and the 2tb non raid is for my Business data.
m
0
l
a c 207 Ĉ ASUS
a c 716 V Motherboard
October 19, 2011 2:36:33 AM

You you seem intelligent, and I needed to sleep with a clear conscious.

Good Luck! :sol: 
m
0
l