Sign in with
Sign up | Sign in
Your question

Tried to install more ram, computer won't boot

Tags:
  • Memory
  • RAM
  • Computer
Last response: in Memory
Share
October 13, 2011 10:09:41 PM

Hello. So I had a friend build this computer for me last christmas and it's worked fine for 9 months without a problem. Recently I've found the need for more RAM and so I purchased some. For reference, here are some specs:

Motherboard - Asus Maximus III
RAM - Mushkin 4G(2x2G)

The following is the RAM I purchased:

RAM - G.SKILL 8G(2x4G)

I opened up my computer, blew some compressed air around to help clean up. The only problem I had with this was that while having the can sideways the liquid spray came out a bit. However, the areas where that happened work fine as I booted up so I'm certain this isn't an issue.

I removed my old RAM and put in the new one and the computer would power on but I'd get no beeps and the monitor, of course, remains blank. I put in my old RAM, including just using one stick, and it still won't boot. Not sure what went wrong but I'd like to know how to troubleshoot it.

What LED's should I be looking to be on to ensure that part of the computer is fine. Keep in mind I didn't build this computer and therefore don't know as much about it as I should.

Any help is greatly appreciated.

More about : install ram computer boot

a c 251 } Memory
October 13, 2011 10:42:13 PM

Stick in your new ram and then reset BIOS to defaults prior to boot!
m
0
l
!