Sign in with
Sign up | Sign in
Your question

Flashed mobo bios, now Areca array not mounting

Last response: in Storage
Share
March 1, 2013 12:37:25 AM

My setup
Asus p8z77-v pro
Areca ARC-1222 8 port PCIe controller
Eight WD Caviar black 2 TB disks in RAID 5 storing data only
booting Win 7 Ult 64 off SSD


I have an Asus p8z77-v pro motherboard. I just flashed the bios a couple versions higher (1015 -> 1504) to one which I've read is quite stable. Well my ARC-1222 raid card (on firmware 1.49) is not having its array mounted in Windows. It's attached to eight 2tb Caviar Blacks in RAID 5. The card is showing properly in device manager under disk drives and storage controllers but the volume under Windows 7 Disk Management represents it as Disk 0 Dynamic Invalid. If I select Activate I get "this operation is not allowed on the invalid disk pack" I also tried offlining it and putting back online. No luck. The array shows as Normal and drives as Normal in Archttp. I had loaded optimized defaults when I flashed the motherboard bios although I didn't remove the card during the flash (maybe I should have?) In any event, how do I get this array to mount? Areca tech support said to check with Asus and Asus has not responded. I really would like to stay with this bios version since it's newer and has good reviews. If not, then I'll down flash and see what happens. Thanks in advance.
March 1, 2013 3:51:33 AM

Flashing the BIOS restores itself to factory settings, I think you need to go to the BIOS settings and reconfigure your RAID array from there. I think you should first set the storage type from AHCI back to RAID or whatever and then access the RAID setup from Ctrl + D or whatever the shortcut is and figure out what's going on there. Good luck.
m
0
l
March 1, 2013 2:38:51 PM

The RAID is pretty much plug and play. With the card in the pciE slot and the hard drives attached, I just went into the interface and built the array. That array is still intact (showing as Normal). As far as I know, AHCI/IDE settings are only used for motherboard SATA connections which does not apply here.
m
0
l
Related resources
March 1, 2013 2:52:20 PM

Check to see if your BIOS has any options for forcing option ROMs. It is probably not initializing the controller properly. If this is not the case try reverting to the previous version of the BIOS that worked correctly.
m
0
l
March 1, 2013 7:29:14 PM

I'm fairly certain the controller is initializing properly because it shows correctly during posting that it is detected and presents the option to enter the admin interface, etc. That is what is puzzling is that everything looks perfect from the posting to device manager to the health of the array itself in the admin interface. The only problem is that it won't mount.
m
0
l
March 6, 2013 3:38:40 PM

I flashed my mobo back down and same situation. Re-installed Windows 7, same situation - Invalid Dynamic Disk. Reactivate and offlining/onlining still doesn't allow the array to mount. I did a volume check and it turned out okay. Areca support is saying the partition table is probably corrupt.

Unless there is something else I can safely try, my question is this: what recovery software is recommended for my situation - a hardware array of disks containing a large amount of data that is detected by Windows but cannot be mounted. I'm looking for a Windows 7 tool that costs less than $100 and is suitable for what I am trying to recover. I'm fairly convinced if I can get the array to mount, the data will be intact.

m
0
l
!