Sign in with
Sign up | Sign in
Your question

Arctic Cooler Freezer 7 pro rev. 2 fan RPM problem

Last response: in CPUs
Share
February 13, 2011 4:36:24 PM

I have a problem with my fan speed on my Arctic Cooler Freezer 7 pro rev. 2. The fan speed is going at ~2300 rpm. From what I understand, the speed should be around 900-1500 rpm. The fan makes a good amount of noise as well. I have it connected to the CPU fan on the motherboard[ASRock Extreme x58 mobo] and went into the bios and switched the settings from "Full On" to "Automatic" and yet no luck. Could anybody with any experience with this cooler+mobo give any insight?

Specs:
Intel i7 920 @ stock speed
ASRock Extreme x58
3x2gb OCZ gold ram @ 1333mhz
Sapphire Radeon 5770 [Juniper XT]
120gb OCZ vertex 2
2tb hitachi deskstar
Antec TP-750 750 Watt Power Supply
Sony Optiarc DVD burner
a c 117 à CPUs
February 13, 2011 5:09:10 PM

Bios
PC Health
Smart fan
Auto
Voltage
Pwm = try that
February 13, 2011 7:03:23 PM

Already did all that. I reseated the cpu and none of that helped. My temps are ~39 deg C also. Anybody have any personal experience with this board?
Related resources
February 14, 2011 12:20:40 AM

Does anyone know if it's safe to change the target fan speed? I have it left at 9, but I see you can lower it. I moved it down temporarily to 4 but my temps went up 8 degrees C. I'm thinking that this is gonna be my last ASRock board that I buy.
a c 117 à CPUs
February 14, 2011 4:13:37 AM

I wouldn't be so quick to blame the mobo.
Sorry to say!
but your cooler isn't really known for excellent performance on a 1366 platform.
It's defintely an improvement over stock but that's all.
Here's Tom's test of coolers on an i7 860 which is a cooler running cpu.
http://www.tomshardware.com/reviews/lga-1156-heatsink,2...
February 14, 2011 12:50:19 PM

Alright, I just ordered a Corsair a70 from newegg. I'll give that a shot and give an update once I get it installed. I appreciate the help Davcon.
!