External WD Passport works on all other computers but custom build

Hey.

I have a WD My Passport SE USB 3.0 external hard drive, which I am trying to use in conjunction with my newly built computer! At first the drive worked fine. In fact it still works fine on all of the other computers in my household, except for my custom build! :(

Basically when I plug it in the computer either doesn't acknowledge its existence (not even in Device Manager) or it pops up with "You need to format drive E: before use" yada yada yada, another popup appearing every 15 seconds or so. Frankly to me it seems like the drive is power cycling constantly, since the automatic driver installation in Windows (7 x64) reads "installation failed: device unplugged". However, I'm not really sure.
Actually, this same issue happened to me when I first installed all my components and tried to boot the computer: as soon as I supplied power to the PSU, the fans seemed to receive power for about 1 second then drop for 1 second, and the power button was turning on for 1 second then off again. Not sure if these problems could be related, even though my computer is working fine itself now. Anyway, I've tried other USBs in all the different ports and they work just fine. Could the drive not be receiving enough power? I really don't know anymore.

Help please :(
1 answer Last reply
More about external passport works computers custom build
  1. Update: Now I've rebooted my system and it loops through
    "Installing driver software......
    Installation failed. Reason: Device Unplugged"
    The drive itself isn't losing power though, the power light is solid.
Ask a new question

Read More

Hard Drives Western Digital Computers External Hard Drive Storage