Sign in with
Sign up | Sign in
Your question
Solved

IDE to ACHI can't find Registry Entry OCZ Vertex 4

Last response: in Storage
Share
March 2, 2013 9:29:28 PM

Hi guys, I'm attempting to switch my SSD from IDE to ACHI by editing the registry without losing Windows. I have followed the guide that everyone has suggested here: http://www.ocztechnologyforum.com/forum/content.php?286... The problem is I cannot find that registry entry... it doesn't exist, so where do I go from here? Can I create that entry somehow? Any insight is greatly appreciated!
a c 124 G Storage
March 3, 2013 12:37:19 AM

If you run win7 it should be there.

If you run win8, then it is in the difference area.
1)Press Windows Key + R, type regedit and press Enter.
2)For Msahci: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci, in the right pane, right-click on Start entry and select Modify to "0".
Also HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\pciide, same as above
Or 2) For intel ahci
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorA, right-click on Start entry and select Modify to "0". HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorV, right-click on Start entry and select Modify to "0".
m
0
l
March 3, 2013 12:49:20 AM

My Start entry seems to be at value 0 already.

Same with the folder for pciide, is should I be editing something in a subfolder of those 2?
m
0
l
Related resources
a c 124 G Storage
March 3, 2013 12:56:36 AM

You don't need that and go back the BIOS change the storage mode to AHCI, then you are all set.
m
0
l
March 3, 2013 1:15:35 AM

I changed SATA and Marvell to ACHI but it won't boot, just stays loading Windows, doesnt get to log in screen. So don't even edit those entries if they are at 0?
m
0
l

Best solution

a c 124 G Storage
March 3, 2013 1:53:01 AM

If you have the problem, try this maybe help " Changing the ATA Drive setting in System Bios causes reboot loop on Windows 8"
http://support.microsoft.com/kb/2751461
Share
a b G Storage
March 3, 2013 2:08:33 AM

The registry may be edited wrong... "0" disables and "1" enables.. so to enable AHCI, storahci may have to be set to "1", IDE disabled with pciide set to "0", and iaStorA enabled with "1".

Set the BIOS to AHCI so you can logon, edit the registry correctly, restart and set the BIOS to AHCI.
m
0
l
March 3, 2013 2:09:24 AM

Best answer selected by chrisafp07.
m
0
l
March 3, 2013 2:10:38 AM

cin19 said:
If you have the problem, try this maybe help " Changing the ATA Drive setting in System Bios causes reboot loop on Windows 8"
http://support.microsoft.com/kb/2751461


That link worked perfectly, I booted in with IDE mode normally, rebooted in safemode with it in ACHI mode, it booted fine, then shut off safe mode and rebooted, that was all it took. Thanks for the help guys!
m
0
l
!