Sign in with
Sign up | Sign in
Your question

ASUS M4A89GTD PRO no beep no fans no mem ok lights - just green light

Last response: in Motherboards
Share
October 18, 2011 12:15:12 PM

Hello all,

ASUS M4A89GTD PRO - AMD 890GX - Socket AM3 - PCI-E 2.0 (x16) - DDR3 2000(OC) - SATA 6Gb/s - SATA RAID - ATX
Corsair CMZ8GX3M2A1600C9 8GB 1600MHz CL9 DDR3 Vengeance Memory Two Module Kit
Corsair CMPSU-650TXV2UK Enthusiast Series TX650 V2 High Performance 650W Power Supply
Samsung F3 HD103SJ 1TB internal Hard Drive SATAII 32MB Cache 7200RPM – OEM
Antec Three Hundred Midi Case
AMD HDZ965FBGMBOX Phenom II X4 965 - 3.4 Ghz AM3 Black Edition CPU, Retail Packaged
LG BH10LS30.AUAU10B 10x Internal Blu-Ray BDRW Bare + Software

Is there something incompatible here ?

Should the processor be an 890 or is the Phenom II X4 965 compatible - all i have is green led - have swapped switch have added sys speaker - no fans - no nothing .... tried each stick of ram in each slot -.

Thanks in advance.
a c 435 V Motherboard
October 18, 2011 12:53:52 PM

Check the cmos jumper position. Also do a bare post test if you haven't tried it yet.
October 18, 2011 1:46:58 PM

O1die - thanks for responding....

Have checked the cmos jumper on 1 2 - have also reset a few times - have stripped out RAM only thing on board is cpu with arctic cooler - fan cables plugged in - power in. Green LED - flick the switch and nothing....

Could this mean the board is fsck'd ? Brand new off amazon uk literally 5 days ago - gutted.
Related resources
a c 435 V Motherboard
October 19, 2011 6:29:19 AM

Tried the screwdriver test to fire it up? You may have the power switch lead on the wrong pins.
October 19, 2011 7:31:45 AM

It does sound like you covered most of your bases, but here's all the info in case there is something you haven't tried.

Here is the link to the CPU Compatibility Chart from ASUS on your board:

http://support.asus.com/cpusupport/list.aspx?SLanguage=en&p=1&s=24&m=M4A89GTD%20PRO&os=&hashedid=Gdf0vtpVf72LTYgs

Here is the link to the Memory Compatibility Chart from ASUS on your board:

http://support.asus.com/QVL.aspx?SLanguage=en&p=1&s=24&m=M4A89GTD%20PRO&os=&hashedid=Gdf0vtpVf72LTYgs

Your CPU is supported just fine on this board since the original BIOS release. Almost any AM3 Socket CPU should work fine on this board. The 890X portion is just the chipset for that board.

Like the other posts would suggest, there are only a few reasons a computer wouldn't power on. The fact that you get the green LED indicates that you are likely receiving power.

Before ruling that it is some major hardware issue, make sure the CMOS jumper is on 1 2 and not 2 3. It's unlikely your board was shipping on the 2 3 slot, but it has happened before. Otherwise, ensure that you have your power switch correctly plugged in to your board. If you still can't tell, use a screw driver and touch both pins for the power to see if it starts up that way.

Other obvious checks are to verify that the 4/8-pin CPU power connector is plugged in and not just the main 24-pin connector.

From that point, there aren't a lot of tests you can do if it won't even power on unless you have other spare components to try in place of the ones you have.

If you still can't get it going, Return the board for a replacement or RMA it with ASUS and try again.

Cheers.
October 19, 2011 1:24:08 PM

Arg... FIXT.... You wont believe it but i will tell the tale - I am not proud.

Took it out breadboard board cpu psu on cardboard box... fired up a treat - added RAM - once again fired up - screwed back into case - carefully aligning tightened screws - clipped the psu into the external case fans and this is the killer - plugged the FD power cord onto the mobo thinking it needed to clip onto the (what i supposed) was the fan control pins... - no fire up. removed FD power off board as should not be in.. and bingo all working a treat.

The moral is - build one piece at a time breadboard is the way to go every time....

Thanks for all your feedback... really sorry to be such a numpty.

Lesson learned.
October 19, 2011 3:00:41 PM

I am having the exact same issue with a new board I'm trying to install as well. Forgive my noobishness but what does FD stand for? Thanks.
October 19, 2011 3:15:52 PM

Floppy Disk power lead has 4 pin holes same as fan pins on MB - it was at the end of my psu leads that go to the fans and i thought it had to go on the MB...

Take the board out of your case with PSU and processor fitted - put on cardboard box and power up.... stage 1... then add in ram etc etc until it stops working. That may give you a clue as it did for me. Sound advice from these guys who know all.
October 19, 2011 3:57:28 PM

Thanks a ton. I'll try that.
!