Sign in with
Sign up | Sign in
Your question

[SOLVED] Remove 'System Partition' from HDD [Laptop SSD + HDD]

Last response: in Storage
Share
March 5, 2013 11:28:02 PM

Hi all, I've recently purchased the "MSI GE60-403AU" which comes with the mSata SSD 64GB. It had a pre-installed Windows 8 and I decided to install Windows 7.

Once I booted up with a partitioning tool, I got rid of all partitions in SSD and HDD, (initially did that so when installing Windows 7 it doesn't create that 100mb partition when formatting partitions via Windows 7 installation).

So when I booted up and installed Windows 7. I opened up "Disk Management" and I realised that my HDD didn't have a path! So I gave it one, and tried to format it however it wouldn't because it's seemed as a "System Partition" a part of Windows.

No matter what I do (use Gparted, get rid of the boot from HDD and enable boot for SSD and activate partition.) I still can't get rid of the HDD's System Partition and because of this it wont allow me to format that disk...

I've re-installed tried everything (4 different partitioning tools, Windows 7 recovery and used CMD Diskpart/BOOTREC when i use fixboot i get "element not found")

I'm just totally clueless now. Is this because the MSata can't hold the System partition or is it because of that specific MSATA-SSD i have which came with the laptop?

It's always pushing the HDD to contain some sort of additional partition which doesn't allow me to format it.


Even though I formatted and deleted and created a new partition. After I installed Windows 7, on the "Disk Management" I see HDD's status which is "Healthy(System, Active, Primary Partition)" however, it's only meant to be "Primary Partition".. not System.

Simply I get "Windows cannot format the system partition on this disk" on Disk management. When attempted to format.

Any hints/tips would help and would really appreciate it thank you.

Regards,
March 6, 2013 11:07:02 AM

Problem Solved!

I've fixed it. But i've did everything manually the DISKPART command prompt doesn't actually initialise the C: primary drive. For me or the MSI GE60 0ND users. The System Partition isn't 100MB or maybe it is but it's not viewable, in fact it's not a separate partition its a bind with the D:\ drive (HDD). like this:


I've used a linux distro 3rd party partitioning tool like "Gparted and MiniTool Partition Wizard 7" I've inactivated and activated C:\ i've unchecked the boot flag on D:\ and i've used the W7-recovery-CD and manually created a system partition and copied booting files to C:\ using the following commands:
Quote:
bcdedit /set {current} device partition=C:
bcdedit /set {current} osdevice partition=C:
bcdedit /set {bootmgr} device partition=C:
bcdedit /set {memdiag} device partition=C:

reg unload HKLM\BCD00000000
robocopy D:\ C:\ bootmgr
robocopy D:\Boot C:\Boot /s


I've restarted the laptop went into BIOS made sure the priority boot was the SSD first. Then booted Gparted software I've deleted the D:\ partition and took out the Gparted CD and Windows finally booted without giving me the "bootmgr is missing" because i've created a boot (system partition) in the C:\ finally I can format do what ever on my D:\ drive which is now independent.

hence, i didn't need to do anything physically (i just purchased the laptop didn't want to void the warranty by screwing through the warranty sticker)
m
0
l
Related resources
!