Sign in with
Sign up | Sign in
Your question

Sabertooth x58 no post

Last response: in Motherboards
Share
October 22, 2011 9:51:01 AM

I am having problems with my computer. It is not POSTing and i don't know why. I have bought a new motherboard and i have had help assembling it so everything is connected. I have a sabertooth x58 mother board and it is showing green power but wont POST. However it is showing red lights for CPU and for RAM and i just want to know if anyone has any input before i just go and spend 500 dollars on a new CPU and another 100 on RAM.

Thank you

More about : sabertooth x58 post

a c 435 V Motherboard
October 22, 2011 12:41:18 PM

New boards won't get out of the factory without rigorous testing, so don't send your board back. First, check your ram; often first time installers don't install it all the way into the dimm slot. I listen for two clicks, one from each lock down tab. Read your manual and be sure you have the ram in the correct slots. Check the white id labels on your board for dimm slot numbering. Did you line up the two notches on the cpu properly before locking it down in the socket? Did you install the 4 or 8 pin power supply lead properly? Finally, check the cmos jumper position. Some boards ship with the jumper in the clear position to save the board battery from running down. This jumper should always cover two of the three pins; never change it with the system on, always with it off.
m
0
l
a b V Motherboard
October 22, 2011 12:42:20 PM

I had that happen to me there is a little button near the ram slots you can push to get the ram to work correctly It is called mem ok.
m
0
l
!