Sign in with
Sign up | Sign in
Your question
Solved

Installing Windows 7 on OCZ RevoDrive X2 PCIe RAID card

Last response: in Storage
Share
March 7, 2013 1:35:27 AM

So, I recently built myself an awesome gaming PC, and I'm attempting to upgrade from my former SATA SSD to a PCIe SSD. The specs of my computer are:

ASUS SABERTOOTH Z77 Motherboard
16 GB Gskill RAM
Nvidia GTX 660 Ti graphics card
Intel Core i7 3770 CPU
OCZ Agility 4, 256GB SSD

I'm now upgrading to an OCZ RevoDrive X2 PCIe SSD. I installed the RAID card in the PCIex4 slot on my motherboard, got the latest drivers from OCZ and installed them, I have the drive set up as RAID0 (Striped) array, and I enabled the UEFI PCIe option in BIOS. The drive shows up in all BIOS boot options, in My Computer, and in disk management, but when I try to install Windows onto the drive, it doesn't show up as an option. I even tried loading the RAID drivers again during the Windows installation to see if that would make it recognize the drive, but it didn't. Finally, there was one other thing I tried which confused me even more. I tried booting up in Windows, loading the Windows install disc, and installing Windows to the drive that way. The drive did show up as an option then, and the installation seemed to be going well, but when the computer restarted to finish the installation, it said "Windows cannot locate the partition selected for installation." I'm really stuck here, and any help would be much appreciated.
March 8, 2013 1:04:14 AM

Ok, so I believe I have determined the problem, but I am not sure how to fix it. I think the problem is that when I'm installing Windows and I try to load the driver for the RevoDrive x2, it doesn't actually load. Instead it gives me an error message about the x64 driver not being digitally signed. I was able to load the x86 driver and install x86 Windows on the drive. Is there any fix for this? Is the x64 driver really unsigned? A friend of mine told me to partition the drive, and install x86 Windows on one partition, boot from it, and install x64 Windows on the other partition from within Windows. I tried that, and it didn't work. After all of the rebooting, it said that there was an error, and all the changes would be undone. Not really sure where to go from here.....
m
0
l
Related resources

Best solution

March 8, 2013 12:42:52 PM

I finally got the problem solved. I used the solution from this thread. The guy in that situation was dealing with a RevoDrive 3, but the issue was the same. For some reason, the Windows installation was telling me that the x64 drivers were unsigned, and it wouldn't load them. If you are having this problem, follow these steps:

1. Download both the x86 and x64 drivers from OCZ, unzip them, and copy both the x86 folder and x64 folder onto a flash drive.
2. Restart your computer, boot from the Windows install DVD, and begin the installation process (if you have an x86 option and an x64 option, make sure you select the x64 option, assuming that you want to install 64-bit Windows).
3. During the install process, when you get to the drive selection screen, click on "Load Drivers". Click on the "Browse" button, and navigate to the flash drive where you stored the drivers. Select the x86 folder, and load the x86 driver that comes up.
4. At this point you should be returned to the drive selection screen, and the RevoDrive should appear as an option. Select the RevoDrive and click on "drive options". Delete any partitions on the drive, format it, and create a new partition. (I'm not sure if this step is actually necessary, but it was suggested in the post that I was using, and I did it myself, so I don't know whether or not it would work without this step)
5. Click on "Load Drivers" again, and this time navigate to the x64 folder. Install the x64 driver (there should actually be three files that show up in that folder). Install the two drivers in that list that say "(x64)" after them. If you still get the "unsigned drivers" error, don't worry... I got that error message at this stage also, but the x64 install still worked.
6. Close the "load drivers" screen to return to the drive selection screen. Select the RevoDrive, and continue with the Windows installation.

Hopefully these steps help all the people out there who are having this problem. It took me 7 hours of solid searching and trying different methods to come upon this solution and get it to work. Good luck!
Share
a b G Storage
March 8, 2013 2:20:10 PM

Best answer selected by aford10.
m
0
l
April 14, 2013 7:10:16 PM

ws1173, wanted to bump this thread and say your solution worked. I had the same issue, and every step you posted INCLUDING creating the partition was important. If I didn't create the partition after installing the x86 driver, my computer would just hard lock when attempting to install the 64 bit driver. For some reason that partition was critical for me
m
0
l
!