Sign in with
Sign up | Sign in
Your question

Battlefield bad company 2 5770

Last response: in Graphics & Displays
Share
September 29, 2010 8:16:40 PM

i recently bought BFBC2 but iam getting alot of micro stutters my fps is 45 min 80+ max at 1440x900 and using a core i3 and 2gb of ddr3 1333 mhz ram
its not really noticable but its slightly jerky at demanding places is my ram bottlenecking me?
September 29, 2010 9:07:00 PM

My computer stutters on that game a lot with a quad core, a GTX 460 1gb, and 8gb ddr3.
It usually only happens during explosions or looking far down a map, which will happen even more if you're using DX-11.

More ram may help, but the game is very demanding when a bomb (or several bombs) goes off.
I would recommend turning down the effects a little and enabling v-sync.
m
0
l
September 30, 2010 12:35:09 AM

Question. Have you tried paying attention to this issue in both single player and multi-player?

Typically I find that a lot of the micro stuttering can be eliminated by joining a server that is close to my area in multi-player, although some areas (like the city on the Arica Harbor map) demand a lot more of my system than others.

You will be able to tell whether or not your issue is being caused by latency or framerates simply by playing the game in single player and multi-player.
m
0
l
Related resources
September 30, 2010 3:36:41 AM

I'm running xfire 5770's and can say that i dont get any stutters besides when i join the game. The way its netcoded you shouldnt see stutters until over 1k MS.
You could try lowering the settings to see if the stuttering is being caused by that. If you have AA maxxed even at that resolution on 1 5770 it may be a bit much, AA + building debris = harsh.

I would add more ram yes.
m
0
l
September 30, 2010 1:07:31 PM

SRY people for the late reply i was at school anyways everything is on high and 2xaa with vsync enabled iam at the first level when i enter a building everything is fine but when iam in an open field i get little microsttuter the fps is at 40+ except during bombs drops to 10+ the goes back up again. the avg fps is 42 i think
m
0
l
a b U Graphics card
September 30, 2010 1:23:37 PM

theunkown said:
SRY people for the late reply i was at school anyways everything is on high and 2xaa with vsync enabled iam at the first level when i enter a building everything is fine but when iam in an open field i get little microsttuter the fps is at 40+ except during bombs drops to 10+ the goes back up again. the avg fps is 42 i think

Could be an issue with driver support, my 5770 is overclocked but it doesn't get that kind of framerate drop when a bomb or explosion goes off(unless of course I get bombarded and smoke flies in your face) and I have it at 1680x1050 16xaf and 2xaa. I find resolutions don't really affect me though, as I went to 1440x1050 and even 1280x720 and get about the same fps.
40-50fps outside, 80-90fps inside buildings.
m
0
l
September 30, 2010 2:12:16 PM

well iam using the 10.4 drivers i could try out the 10.8 drivers but i had a bad experience when i switched drivers (had to reinstall windows cuz of broken drivers) ok ill describe what exactly happens i stutter when iam running for instance enviroment is alil late to refresh so its not completly smooth at a distance when iam playing u dont feel it much but in cutscenes ITS really obvious i dnt know how to switch between dx10 and dx 11 btw
m
0
l
September 30, 2010 2:15:07 PM

and it doesnt make a difference if i use it on high or medium settings its the same fluttering
m
0
l
September 30, 2010 2:24:53 PM

so its not my gpu ah well so whats my best option another stick o ram and then what? oh an can you tell me how to switch the dx i cant find it on google
m
0
l
a b U Graphics card
September 30, 2010 2:32:20 PM

theunkown said:
and it doesnt make a difference if i use it on high or medium settings its the same fluttering

Are you having a weird problem with resolutions and settings not actually giving you an increase in fps as well?
m
0
l
September 30, 2010 2:32:45 PM

nvm did it and now its on dx9 the fluttering has decreased and the fps is now 60+ but with no AA it looks real crappy
m
0
l
September 30, 2010 2:36:13 PM

dalta centauri said:
Are you having a weird problem with resolutions and settings not actually giving you an increase in fps as well?

nope if i decrease the settings i get more fps kinda double the fps actually.
m
0
l
September 30, 2010 2:46:44 PM

the system.ini has DxVersion=auto near the end i changed it to 9 then i used 10 the stuttering is the same the fps is slightly bettern than dx11 but now it only flutters when i run so its berable ill add another 2gig stick when i have the money and i finnaly know wth is the probmlem its fram skipping lol
m
0
l
!