Sign in with
Sign up | Sign in
Your question
Closed

Artifacts gone, is card o.k.?

Last response: in Graphics & Displays
Share
September 30, 2010 12:06:09 AM

I recently had issues with some artifacts showing up during gaming. see thread: http://www.tomshardware.com/forum/299465-33-luck-else

I believe I have solved the issue by replacing a failing surge protector. Strange imo.

Prior to changing surge protectors I got artifacts immediately after starting a game. Strangely now they are gone. Since WOW is not gpu intensive i decided to use a benchmark to test for artifacts.

I ran EVGA OC Scanner Benchmark and it reported zero artifacts on a 10 minute test.


Now that the issue is gone do you think that my graphics card is permanently damaged? It has a 2yr warranty and I could just RMA it to be safe.

More about : artifacts card

a c 189 U Graphics card
September 30, 2010 1:55:27 AM

I would say RMA your card, it's better to get a replacement since it's on warranty...
Score
0
a b U Graphics card
September 30, 2010 5:40:15 PM

Wa's right, RMA it. Also, that's a little strange that a surge protector would fix that issue.

Normally a PSU would be able to regulate that power to your GPU, even if you have a kooky surge protector, however if the surge protector wasn't providing enough juice (for whatever reason) then your card would have been underpowered because the PSU wasn't getting enough juice to begin with.

Glad it's working though!
Score
0
Related resources

Best solution

a b U Graphics card
September 30, 2010 5:44:56 PM

It is likely that you have caused perment damage to the card. You can never be sure that it is not going to show problems the next time you use the card. RMA the card and start off with a new one so you can have confidence in your card/system.
Share
October 7, 2010 12:09:31 AM

Will do!!

Thanks for the help.
Score
0
October 7, 2010 12:11:53 AM

Best answer selected by supertdubzz.
Score
0
a c 273 U Graphics card
October 7, 2010 8:52:38 AM

This topic has been closed by Mousemonkey
Score
0
!