Sign-in / Sign-up
Your question

Seagate Expansion USB Drive not recognized​, beeps and flashes blue

Tags:
  • Hard Drives
  • Seagate
  • USB Drive
  • Storage
Last response: in Storage
March 8, 2013 2:04:35 AM

My 3 month old Seagate Expansion 750 GB Portable Drive can no longer be recognized by Windows. It beeps for a couple of seconds and then the blue light comes on and continually flashes. I don't think it's spinning at all. I've tried it on multiple machines (Windows 7 and XP). It does not show up as a partition using Disk Management, nor in Device Manager. I tried hooking it up to a SATA port on my desktop, but it would never show up. However, I used the same power source as is used for my other desktop SATA drives. Shouldn't this work?

Also, it doesn't show up when I run HD Sentinel. Below is the readout from UVCView. I've got irreplaceable files that were added since my last backup. Any help would be greatly appreciated.



UVCView:

---===>Device Information<===---
*!*ERROR: no String Descriptor for index 2!

ConnectionStatus:
Current Config Value: 0x00 -> Device Bus Speed: Full
Device Address: 0x02
Open Pipes: 0
*!*ERROR: No open pipes!

===>Device Descriptor<===
bLength: 0x12
bDescriptorType: 0x01
bcdUSB: 0x0110
bDeviceClass: 0x00 -> This is an Interface Class Defined Device
bDeviceSubClass: 0x00
bDeviceProtocol: 0x00
bMaxPacketSize0: 0x40 = (64) Bytes
idVendor: 0x0B97idProduct: 0x7772
bcdDevice: 0x0110
iManufacturer: 0x01
*!*ERROR: no String Descriptor for index 1!
iProduct: 0x02
*!*ERROR: no String Descriptor for index 2!
iSerialNumber: 0x00
bNumConfigurations: 0x01
..

More about : seagate expansion usb drive recognized beeps flashes blue

March 8, 2013 6:28:34 AM

Guess your hardware is damaged. Please consult nearest service center...
m
0
l