Sign in with
Sign up | Sign in
Your question

Can't establish Gigabit connection

Last response: in Networking
Share
Anonymous
a b D Laptop
May 27, 2010 1:59:11 PM

Hi there,

I'm having a problem setting up a Gigabit connection between my Laptop and my Desktop (Windows 7 Peer to Peer connection). When I plug the cable, the connection is established but lasts about less than a second before it's disconnected again. After about another 10 seconds, the connection is established again for less than a second etc. When the connection is established during that second, the speed is indeed set to 1Gbit/sec, as it should be.

What I'm seeing on the Laptop's adapter (Compal):
A network cable is unplugged (constantly)

What I'm seeing on the Desktop's adatper (Antec):
A network cable is unplugged (for about 10seconds)
Identifying (for about a second)
Unidentified network (For about less than a second)
And back to "A network cable is unplugged"

The problem lies with the laptop (Compal). I've tried to connect three other laptops to my Desktop (on both Ethernet cards) and they all established a Gigabit connection without any problem.
I've tested the following cables:
Straight cable (Cat5e)
Crossover cable (Cat5e)
Cat5 cables

All of those cables worked with the other laptops, just not with the Compal.

The network interfaces on both computers are all set to the default factory settings. If I go into advanced settings and change the Speed & Duplex to 100Mbits on the Compal, the Compal immediately establishes a connection without any problem but setting it to 1Gbit or Auto Negotiation gives the same problem again.

I've got some Diagnostic software for the Ethernet card on the Laptop, and for the D-Link card on the desktop, so if you need any info from those please don't hesitate to ask. I've even got a packet sniffer available if you'd need some info from those. Also, if you require more specifications from either of the mentioned machines I'd be happy to upload a full hardware report.

  1. Laptop (Compal JHL90) - Referred to as "Compal"
  2. ------------------------------------------------
  3. Operating System: Windows 7 Ultimate (64Bits)
  4. Ethernet: Realtek 8168 (PCIe x1, 10/100/1000)
  5. Ethernet Drivers: Realtek 7.18.322.2010 (22nd of March, 2010)
  6.  
  7. Other info:
  8. Motherboard: Intel ICH9M (Cantiga)
  9. Processor: Intel Core 2 Duo T9400
  10. Memory: 4GB DDR2 800Mhz (Dual Channel)
  11. Graphics card: nVidia 9600M GT
  12. Hard Drive: 320GB 7200RPM



  1. Desktop - Referred to as "Antec"
  2. --------------------------------
  3. OS: Windows 7 Ultimate (32Bits)
  4. Ethernet1: Onboard - nVidia nForce 10/100/1000
  5. Ethernet1 Drivers: nVidia 73.1.4.0 (30th of July, 2009)
  6. Ethernet2: D-Link DGE-530T (10/100/1000)
  7. Ethernet2 Drivers: Marvell 10.51.1.9 (6th of December, 2007)
  8.  
  9. Other info:
  10. Motherboard: Asrock M3N78D
  11. Processor: AMD Athlon 2 X4 635
  12. Memory: 2GB DDR3 1334Mhz (Dual Channel)
  13. Graphics card: ATI Radeon X800 XL
  14. Hard Drive1: Western Digital 250GB (SATA)
  15. Hard Drive2: Samsung Spinpoint F1 750GB (SATA)


Thanks in advance!
DePhille
May 27, 2010 3:17:05 PM

How old is the laptop? It could be that when setting it to run with full gigabit, it shuts itself off because it may not support it. But if the laptop is only a a year or two old it "should" support gigabit.
Anonymous
a b D Laptop
May 27, 2010 3:46:17 PM

The laptop was bought in late 2008 if I'm not mistaken. It should indeed support Gigabit. It's advertised everywhere (I haven't seen any website that didn't say it supports Gigabit) and all benchmarking software mark the Ethernet controller as being capable of Gigabit. Also, I have had a succesful Gigabit connection in the past, but I can't even remember if it was on Vista x64 or Win7 x64 and it happened after an extremely long time (few hours of the cycle Not connected -> Identifying -> unidentified network -> Not connected -> ...) and even then it was an isolated case.

I don't think it shuts itself off because it sais "A network cable is not connected" continuously on the laptop, it didn't ever say that the adapter was off or restarting or anything.

I'm really guessing that it is some sort of configuration setting that I'm missing here, or atleast, I'm hoping it is.

Thanks for your reply!
DePhille
Related resources
May 28, 2010 12:50:13 AM

I'm trying to set up a gigabit link between my router and computer, and I am getting the same sort of response, the connect and disconnect cycles, and eventually connects at 100 Mbit full duplex. I've tried messing around with some of the driver settings, and some fix the cycling, but they still connect at 100 Mbit (sometimes full duplex, half, or none at all).

I know the cabling and router works, as it connects to my MacBook at 1 Gbit, just not the built in Realtek gigabit card. This also leads me along the same route as the OP thinking there is a setting I'm overlooking. Any ideas to point me in the right direction?
Anonymous
a b D Laptop
May 28, 2010 12:00:20 PM

pacman9889, can you post your specifications? Like your operating system, Ethernet hardware and their driver versions? Perhaps we can compare our specifications and look for similarities.

DePhille
May 28, 2010 4:13:17 PM

sure, here's a bunch of reports. If there's anything else, let me know. What's not shown is the desktop is connected with CAT6 to a Trendnet TEW-639 router. Could you try and post some screens of your driver settings, perhaps there are some similarities there.

I wish I knew an easy way to report all the settings... everything is pretty much enabled/auto/default except for Jumbo Frame - disabled, and Auto Disable Gigabit - Disabled. I've tried setting the Speed and Duplex to 1 Gbit, but it cycles then eventually settles on 100 Mbit.


By pacman9889 at 2010-05-28


By pacman9889 at 2010-05-28



Quote:
Realtek PCI GBE Family Controller

[ Network adapters / Realtek PCI GBE Family Controller ]

Device Properties:
Driver Description Realtek PCI GBE Family Controller
Driver Date 3/4/2010
Driver Version 7.17.304.2010
Driver Provider Realtek
INF File oem49.inf
Hardware ID PCI\VEN_10EC&DEV_8167&SUBSYS_1082147B&REV_10
Location Information @system32\DRIVERS\pci.sys,#65536;PCI bus %1, device %2, function %3;(4,0,0)
PCI Device Realtek RTL8169/8110 Gigabit Ethernet Adapter

Device Resources:
IRQ 20
Memory FDCFF000-FDCFF0FF
Port BE00-BEFF


[ Realtek PCI GBE Family Controller ]

Network Adapter Properties:
Network Adapter Realtek PCI GBE Family Controller
Interface Type Ethernet
Hardware Address 00-50-8D-9A-93-A1
Connection Name Local Area Connection
Connection Speed 100 Mbps
MTU 1500 bytes
Bytes Received 113282908 (108.0 MB)
Bytes Sent 40698980 (38.8 MB)

Network Adapter Addresses:
IP / Subnet Mask 192.168.10.102 / 255.255.255.0
Gateway 192.168.10.1
DNS 208.67.222.222
DNS 208.67.220.220


[ Realtek RTL8169/8110 Gigabit Ethernet Adapter ]

Device Properties:
Device Description Realtek RTL8169/8110 Gigabit Ethernet Adapter
Bus Type PCI
Bus / Device / Function 4 / 0 / 0
Device ID 10EC-8167
Subsystem ID 147B-1082
Device Class 0200 (Ethernet Controller)
Revision 10
Fast Back-to-Back Transactions Supported, Disabled

Device Features:
66 MHz Operation Supported
Bus Mastering Enabled

General System

Summary

--------------------------------------------------------------------------------


Computer:
Computer Type ACPI x64-based PC
Operating System Microsoft Windows 7 Ultimate
OS Service Pack -
Internet Explorer 8.0.7600.16385
DirectX DirectX 11.0
Date / Time 2010-05-28 / 08:53

Motherboard:
CPU Type DualCore Intel Core 2 Duo E7300, 2733 MHz (10 x 273)
Motherboard Name Abit AB9 QuadGT (2 PCI, 1 PCI-E x1, 2 PCI-E x16, 4 DDR2 DIMM, Audio, Gigabit LAN, IEEE-1394)
Motherboard Chipset Intel Broadwater P965
System Memory 4096 MB (DDR2-800 DDR2 SDRAM)
DIMM1: A-Data DQVE1A16 1 GB DDR2-800 DDR2 SDRAM (5-5-5-18 @ 400 MHz) (4-4-4-12 @ 266 MHz) (3-3-3-9 @ 200 MHz)
DIMM2: A-Data 1 GB DDR2-800 DDR2 SDRAM (5-5-5-18 @ 400 MHz) (4-4-4-12 @ 266 MHz) (3-3-3-9 @ 200 MHz)
DIMM3: A-Data 1 GB DDR2-800 DDR2 SDRAM (5-5-5-18 @ 400 MHz) (4-4-4-12 @ 266 MHz) (3-3-3-9 @ 200 MHz)
DIMM4: A-Data DQVE1A16 1 GB DDR2-800 DDR2 SDRAM (5-5-5-18 @ 400 MHz) (4-4-4-12 @ 266 MHz) (3-3-3-9 @ 200 MHz)
BIOS Type Award (05/23/08)

Display:
Video Adapter NVIDIA GeForce 8800 GTS (320 MB)
Video Adapter NVIDIA GeForce 8800 GTS (320 MB)
3D Accelerator nVIDIA GeForce 8800 GTS
Monitor Hannstar HW194D [19" LCD] (702HP3CY01358)
Monitor Samsung SyncMaster 2343BW(X)/MagicSyncMaster CX2343BW(X) (Digital) [23" LCD] (H9NS201817)

Multimedia:
Audio Adapter Realtek ALC888/1200 @ Intel 82801HB ICH8 - High Definition Audio Controller [B-0]

Storage:
IDE Controller Intel(R) ICH8 2 port Serial ATA Storage Controller - 2825
IDE Controller Intel(R) ICH8 4 port Serial ATA Storage Controller - 2820
IDE Controller Standard Dual Channel PCI IDE Controller
Storage Controller AQSRQJM5 IDE Controller
Floppy Drive Floppy disk drive
Disk Drive ST3500320AS ATA Device (500 GB, 7200 RPM, SATA-II)
Disk Drive WDC WD1001FALS-00J7B0 ATA Device (931 GB, IDE)
Disk Drive WDC WD1001FALS-00J7B0 ATA Device (931 GB, IDE)
Optical Drive TSSTcorp CD/DVDW SH-S183L ATA Device (DVD+R9:8x, DVD-R9:8x, DVD+RW:18x/8x, DVD-RW:18x/6x, DVD-RAM:12x, DVD-ROM:16x, CD:48x/32x/48x DVD+RW/DVD-RW/DVD-RAM)
Optical Drive VQXWNO 9UJOTYZCXYB4 SCSI CdRom Device
Optical Drive VQXWNO 9UJOTYZCXYB4 SCSI CdRom Device
SMART Hard Disks Status OK

Partitions:
C: (NTFS) 252.3 GB (7.7 GB free)
D: (NTFS) 198.8 GB (18.6 GB free)
F: (NTFS) 146.9 GB (18.1 GB free)
M: (NTFS) 488.9 GB (247.6 GB free)
S: (NTFS) 574.7 GB (63.6 GB free)
U: (NTFS) 341.8 GB (96.7 GB free)
Total Size 2003.4 GB (452.4 GB free)

Input:
Keyboard HID Keyboard Device
Keyboard HID Keyboard Device
Mouse Logitech HID-compliant G3/MX518 Optical Mouse

Network:
Primary IP Address 192.168.10.102
Primary MAC Address 00-50-8D-9A-93-A1
Network Adapter Hamachi Network Interface (5.174.208.197)
Network Adapter Realtek PCI GBE Family Controller (192.168.10.102)
Network Adapter VMware Virtual Ethernet Adapter for VMnet1 (192.168.88.1)
Network Adapter VMware Virtual Ethernet Adapter for VMnet8 (192.168.109.1)
Anonymous
a b D Laptop
May 29, 2010 1:34:43 PM

Seems like we've pretty much got the same Ethernet card (I've got an 8168 and you've got an 8169).

I'm going to try some older drivers and see if there's any diffrence. I'll let you know if I found anything.

Thanks!
DePhille
June 3, 2010 6:22:05 PM

any luck yet?
!