Sign in with
Sign up | Sign in
Your question

IDE slave not recognizing - Windows XP

Last response: in Storage
Share
March 8, 2013 4:37:08 PM

Hello,
I have an older machine that im just trying to save money and keep using.
Running XP sp3
I had a tiny 60g hard drive in it.
took apart an external drive that works fine and wanted to put it in my machine.
I found the IDE connected to my existing hard drive.....black connection....and there is a slave IDE....grey connection...that was free.
I plug it in with the power and IDE connections snugly fastened and when I try to boot it give me a system halted error.
I have gone into bios and changed made sure the boot order is correct.
and it still will not boot.
So I unplug the new drive and keep the master in the excisting hard drive and try again.
boots just fine.
so I tried taking an IDE out of one of my 2 optical drive and plugging that into the new hard drive....
and strangely enough....when I boot the new hard drive is recognized.
what the problem here???
why wont the slave IDE recognize... and why would it not even boot when i plug in the new drive.
? I hope i am making sense
a b G Storage
March 8, 2013 4:41:41 PM

Make sure ALL IDE drives are set to Cable Select on their respective jumpers.

This ensures that, no matter where the device is, all devices will work.
m
0
l
a b G Storage
March 8, 2013 4:43:24 PM

Is the drive jumper set to master, slave, or cableselect? It was most likel set to master in the enclosure, so when installing it in the slave connector on the ide cable it needs to be set to slave.
m
0
l
Related resources
March 15, 2013 9:25:37 AM

so I need to boot to bios and select the new drive and set it to cable select?
Then I can plug it into the slave IDE and it should boot after my OS drive just fine.
am I understanding you correctly?
m
0
l
March 15, 2013 1:18:03 PM

OMG....i had no idea
thank you for this tip
I will try asap
Im going to school for IT and I learn more from trial and error....internet search and forums than anything.
Cheers
;) 
m
0
l
March 15, 2013 1:36:15 PM

It is important to remember that unlike SATA drives which each have their own channel, IDE is a different beast.

Based on your description, it sounds like the Mode jumpers on one (or both) of your drives is incorrectly set. You can see a video on how to do this here: How to Set Jumpers on Your IDE HDD.

Check the jumpers and make sure that they are properly configured for the set-up of your cable. There are two ways to do this: You can either have one jumper set to Master, and one set to Slave... but if you do this, the Master Jumper must match the Master Cable on the IDE (the same is true for the slave jumper too). The other option is to set both of your jumpers to Cable Select. This ensures that no matter where the drives are on the chain that they will work (provided they have no other errors).
m
0
l
a c 900 G Storage
March 15, 2013 1:47:06 PM

The above is incorrect. With using Master/Slave jumpers the actual position on the cable is irrelevant. When the jumper is in Cable Select, then position on the cable determines which is master and which is slave (Hence the same). As always, single drives typically have a preferred setting to use when in 'Single' mode (no other drive on the cable).
m
0
l
March 20, 2013 8:50:26 AM

Sorry I havn't updated since i got some answers.
Moving the jumper worked like a charm ! now the slave IDE cable works with the hard drive.
Thanks bigandnasty for your advice.
but now......I plugged the IDE that I said I had stolen from one of my optical drives back into the optical drive.
the master is in the top one and the slave is in the bottom.....and NOW niether one of the optical drives shows up??
nothing shows up in the BIOS and I have no idea what i could have done.
any ideas??
m
0
l
a c 900 G Storage
March 20, 2013 4:09:18 PM

double check your jumpers on both drives. its either "Both in CS" or "1Master,1slave". You can't mix the two.

Typically the newer drive works best as master but theres no guarantee that they will work together at all. If it doesnt work, thry making the other one master and this one slave. If that doesnt work make them CS. If that doesnt work put them as slave to the HDD's so each cable has an HDD master and a DVD slave.
m
0
l
!