Sign in with
Sign up | Sign in
Your question

Can't get PhysX to work on GTX470

Last response: in Graphics & Displays
Share
October 1, 2010 9:52:21 PM

Hi guys,

The problem is pretty much as I've stated in the topic, but let me describe it a bit more.

I've upgraded my system and replaced gfx card with brand new spanking GTX470 from Gainward, and for unknown reason can't get PhysX to work in GPU mode - so it seems.

I've got the latest drivers and the latest release of PhysX also.

Unfortunately despite PhysX showing in Nvidia control panel, with GTX470 chosen as the card to do the calculations for it - it doesn't seem to be working. In Great Kulu tech demo (and pretty much any other PhysX demo) the framerate is horrible, and in the setup I can't choose the hardware PhysX option - it's greyed out. In Arkham Asylum despite choosing the full PhysX option, I don't see the effects that should be there (papers flying around, water etc.).

I have the GTX470 connected to my screen with DVI#1, Running Windows 7 Ultimate x64, E7500 Intel Core2Duo 2,93Ghz CPU, 10GB of DDR2, P45 mobo.

I was fighting with this for a couple of days now - and I'm absolutely puzzled ... couldn't really find a similar problem anywhere.

Any ideas what to do?

I'd also like to add - I've tried uninstalling the previous drivers (yes, with Driver Sweeper in safe mode as well) - didn't help ...

Anyone?

Also - here are some screenshots that might be useful:






More about : physx work gtx470

a c 620 U Graphics card
October 1, 2010 10:22:29 PM

I had problems with the Control Panel on the beta 260.63 drivers. I had to roll back to the 258 WHQL drivers. Maybe you need to uninstall everything (again, sorry), and reinstall the 258 ones. It's also possible to just uninstall the PhysX driver and install a different version. Also, before you do that, are you able to set the PhysX Configuration to 'Auto'? That will automatically choose the graphics card and not the CPU. To me, unless somehow you have a faulty card, it seems like a software/driver issue.
October 1, 2010 10:30:00 PM

@MattO17secs: yes, I've tried all of the above: I've been trying to uninstall (with the help of Driver Sweeper) all the drivers for GeForce I had and then install different ones ... in fact - I've gone through all the driver versions available on Nvidia's site - to no avail :(  ... .and changing the PhysX config to "Auto" doesn't really change anything either
Related resources
a c 620 U Graphics card
October 1, 2010 10:46:53 PM

I don't have a lot of other suggestions, except to go after the standalone PhysX drivers themselves for an uninstall/reinstall.
October 1, 2010 10:56:49 PM

@MattO17secs: tried standalone drivers as well - didn't help ... it's always the same thing :( 
a b U Graphics card
October 1, 2010 11:03:52 PM

Are you using a dvi cable ? I would select auto and try the other dvi port.
October 1, 2010 11:06:27 PM

@notty22: yes, I'm using a DVI cable ... and I've also tried both ports on auto and on specific setting
a b U Graphics card
October 1, 2010 11:12:23 PM

kill all drivers and pyisics and anything nvidia related - totally remove off the system (driver cleaner?), then download and install the latest driver package again
October 1, 2010 11:18:47 PM

@apache_lives: tried that as well ... I've been using Driver Sweeper ... but I haven't tried using CCleaner yet - maybe it'll clean the system a little bit better than Driver Sweeper :) 
a b U Graphics card
October 1, 2010 11:25:07 PM


Also I don't have any ageia control panel remnants in my current installation. The presence of that control panel might have dll's that are conflicting, with current physX components.
a c 620 U Graphics card
October 1, 2010 11:28:47 PM

Use CCleaner to clean the registry, and get anything Nvidia-related out of the system and try again from the start. This is all just part of the process for diagnosing your problem. Pretty soon, we should be able to rule out a driver issue.
October 2, 2010 12:19:27 AM

ok ... just had a little marathon:

1) uninstalled all the drivers
2) rebooted in safe mode
3) ran CCleaner a few times
4) deleted any files or folders containing words like "ageia" and "physx"
5) deleted all registry keys containing words like "ageia" and "physx"
6) ran CCleaner again
7) installed newest drivers
8) installed newest PhysX software

and guess what ... didn't help :(  still the same thing ... and I've still got the AGEIA panel in control panel
a b U Graphics card
October 2, 2010 12:29:47 AM

Reading some google results and came across this. This fellow also had physX unchecked in gpu-z and had ageia control panel. Sounds like your current predicament.
http://www.tomshardware.com/forum/281045-33-ageia-physx...
You need to find a way to uninstall the ageia.cpl
October 2, 2010 12:37:55 AM

@notty22: well ... there isn't much in that thread you mentioned .. and Driver Sweeper did work for him ... doesn't work for me ... unfortunately :( 
October 2, 2010 2:21:38 AM

ahhhhhh ... ok ... I FINALLY managed to find a solution (so - I'll leave it here - just in case anyone else has the same problem) and - by god - it's so trivial I can't believe it ... apparently all it took was just deleting ONE FILE ... PhysX.cpl from C:\Windows\System32 (or SysWOW64 - in case anyone uses a x64 system) ... and that's all ... :)  well - thanks to everyone who tried to help me (especially notty22 - you were 99% right :D  it's just PhysX.cpl ... not ageia.cpl) :) 
!