Sign in with
Sign up | Sign in
Your question

Sabertooth P67 + memory stick problem

Tags:
  • Asus
  • Memory
  • Motherboards
Last response: in Motherboards
Share
October 25, 2011 9:49:50 AM

Hi!

I have a problem with transferring data from HDD to memory sticks, it either goes fast to 99% and freezes the computer until memory stick is unplugged or when transferring with Teracopy, it goes only @ 2Mbps, finishes correctly tho.

I have updated, uninstalled and reinstalled all chipset drivers, GPU drivers, USB-drivers and still no help. I have tried on different slots with different sticks and all of them do the same thing. Bios updated to the newest, 1904.

The setup is: Windows 7 pro, I5 2500k with no OC, 8gigs of g.skill ram(cant remember the correct model), Asus Sabertooth P67, 2 random sata-HDD's, creative extreme music etc.etc.

All the hardware is new except for the creative card.

Any ideas on where i should continue on this?

More about : sabertooth p67 memory stick problem

a b Ĉ ASUS
a b } Memory
a c 121 V Motherboard
October 25, 2011 2:39:22 PM

Try completely uninstalling the USB drivers and doing a fresh install of the newest version.

Uninstall by going to....


right click Computer > Properties > Device manager (left menu)

Scroll down to Universal Serial Bus Controllers, right click > properties.
October 25, 2011 3:09:06 PM

Thanks for the fast answer :) 

I did that, yesterday and just a moment ago again, i redownloaded all drivers just to make sure but no luck.

Funny thing is, i tried a USB-powered HDD and it works properly, write- and readspeeds are correct, on the same port with 2 different sticks i have here, only 2.3...
Related resources
a b Ĉ ASUS
a b } Memory
a c 121 V Motherboard
October 25, 2011 3:25:39 PM

What PSU do you have in your system? It seems almost like your USB Bus isn't getting enough power :/ 
a b Ĉ ASUS
a b } Memory
a c 121 V Motherboard
October 25, 2011 3:40:09 PM

nope, definitely should not be a PSU problem.

Try this...


Download a free Linux Distro, and create a "Live DVD"

Pop it in and boot to it.

Try copying files to the Flash Drives.

If it still fails = Hardware error
If it works = Software / Win7 error
October 25, 2011 3:52:48 PM

Will do, im downloading it atm, will post results in a few minutes..
October 25, 2011 4:33:53 PM

No luck there either, writingspeeds go from 5mbps degrading to 2.9. On the same port, usb-powered HDD writes @ 40. I dont understand, could this be that something broke 3 of my sticks and all of those at almost the same time. 2 of the sticks were used only once before!
a b Ĉ ASUS
a b } Memory
a c 121 V Motherboard
October 25, 2011 4:44:37 PM

I would suggest contacting Asus and telling them, what is going on. It might be faulty hardware, and you want to get on that as soon as you can. It is definitely a hardware issue, just not sure if it is the memory side, or the MB side.
October 25, 2011 4:55:56 PM

ok, thanks for the help, i will send them an email.
October 26, 2011 7:50:24 AM

Apparently something is breaking my memorysticks, all the sticks tested on my computer seem to be slow for some reason. (tested at work)
All usb-hdd's work just fine.
So i guess my problem is "solved".
a b Ĉ ASUS
a b } Memory
a c 121 V Motherboard
October 26, 2011 2:28:10 PM

Hopefully your MB isn't breaking it. Might want to verify that with a cheap flash drive or something.
October 26, 2011 2:46:44 PM

Will try that when i get to buy one. Ill post the answer here, just in case someone else runs to same kind of problems...
!