Sign in with
Sign up | Sign in
Your question

Rosewill RNX-EasyN4 Router has Local Only, no internet

Last response: in Wireless Networking
Share
August 23, 2010 2:34:41 AM

I tried the setup through the user guide with the following steps:

1. Connected router to cable modem with ethernet cable
2. Connected laptop to router with ethernet cable to setup the wireless
3. Put in the Driver CD and went through the setup wizard and setup a network with my own SSID and Encryption Key
4. Was able to connect wirelessly to my network, except it gives me "Local Only" and I can't get internet access

Does anyone know what the problem could be here?

Oh yes, I have Windows 7 64-bit and I tried using it in AP Router Mode.
Anonymous
August 23, 2010 6:43:03 AM

Presumably you can get internet when computer is connected to modem ?
m
0
l
August 23, 2010 9:58:03 PM

Yes, I've actually been using an Apple Airport for wireless connected to the modem. That has been working fine, just looking to see if this "upgrade" could actually work.
m
0
l
Related resources
Anonymous
August 23, 2010 10:06:41 PM

Check TCP/IP Properties.

Start, Connect To, Connection, Properties, Scroll Down TCP/IP and highlight, click Properties and check that Obtain DNS and IP address automatically are enabled.

Is DHCP enabled in the router ?

Of course it may be an issue between the router and the modem and I'm not too familiar with cable.
m
0
l
August 24, 2010 3:29:47 AM

Obtain DNS and IP address automatically were both checked before. The DHCP was also enabled in the router. What do you mean an issue between the router and modem?

Thanks
m
0
l
Anonymous
August 24, 2010 7:54:31 AM

My understanding (which is limited) is that router and modem have to handshake (usually automatic when you power them down and back up together) and one has to adopt the MAC ID of the other so that the cable supplier's equipment recognises the connection.

I would call the cable company for help at this point.
m
0
l
December 13, 2011 1:14:45 AM

Just had this same issue with Rosewill RNX-N400LX, and now it's resolved:
-Windows 7 Home Premium and cable modem. Have not installed ANY drivers.
-Router worked previously on my Vista Ultimate laptop and DSL. I think I had installed drivers there.

Anyhow, it's working now on the Windows 7 box with cable modem because of the comment "power them down and back up together". Once I did that, everything worked.

I held down the Reset button on the back of the Rosewill for 10 seconds to restore factory defaults. Then, I navigated to http://192.168.1.254 and entered "admin" as the name and "guest" as the password. I then followed the simple wizard and basically took all the defaults, with the exception of WPA security. I simply selected WPA and typed in a password for the network.

Then I applied the changes and followed the previous comment about "power[ing] down and back up together". I can't believe that fixed it. I had power cycled the router and perhaps the modem too but had not powered "back up together". Thanks!
m
0
l
!