Sign in with
Sign up | Sign in
Your question

GTX 480 bad performance?

Last response: in Graphics & Displays
Share
October 4, 2010 1:03:44 PM

I get 27 fps in Unigine Heaven all maxed no vsync and 1680x1050. I get about 25-35 fps in Crysis demo very high 8x
October 4, 2010 1:14:59 PM

What are your system specs? If your using a slow CPU this can really make a difference.
m
0
l
October 4, 2010 1:23:07 PM

I got Amd phenom II X6 1055T with cool'n'quiet turned off, Corsair 1600mhz 2x2gb cl7 ram.
m
0
l
Related resources
October 4, 2010 1:35:20 PM

Drivers could be corrupt?
PSU not providing enough power for the system?

m
0
l
October 4, 2010 1:39:52 PM

I got a 750w Corsair. What should I do :( ?
m
0
l
October 4, 2010 1:43:01 PM

Can you provide us with the full system specs, psu, montherboard, gpu?
m
0
l
October 4, 2010 1:43:49 PM

If your having problems with the drivers, do a full uninstall, driver sweep, and then reinstall after restarting the computer.

Sorry about the double post, I'll try and keep an eye on this, I think I have done this twice lately.
m
0
l
October 4, 2010 1:45:06 PM

What drivers have you got? the 259.xx or the 260.xx Beta ones? I find the 260.xx Beta ones seem to be better for GTX470s in Sli, seems stabler than the previous 259.xx ones
m
0
l
October 4, 2010 1:50:07 PM

MSI GeForce GTX 480, 1536MB GDDR5
LG DVD+/-RW DL 22x, SATA, Musta Bulk
Nine Hundred Two Ultimate Gamer ATX
Samsung 500GB Spinpoint F3, 3.5", SATA II, 16MB, 7200rpm
ASRock 890GX Extreme3, AM3, 890GX, DDR3, HD 4290, SATA3,
Corsair TX 750W 750TX ATX2.2 -virtalähde
Windows 7 Home Premium 64-bit FI DVD, OEM
AMD Phenom II X6 1055T, AM3, 2.8GHz
Corsair 2x2GB, DDR3 1600MHz, CL7

And I am using the 258.96 drivers.
m
0
l
October 4, 2010 1:51:51 PM

Shot in the dark, but try the Beta 260.xx drivers. Seems to improve my system, maybe not in FPS as much, just in stability. But due to you having a single Card, maybe it will imrpove more towards the performance side of things.

m
0
l
October 4, 2010 1:52:51 PM

Ok I downloaded the drivers going to try them now.
m
0
l
October 4, 2010 2:00:40 PM

As mentioned by reccy the drivers may be a problem. Overall I can't see much of a problem from your system specs. Could your card be overheating?
m
0
l
October 4, 2010 2:02:14 PM

Its a max 85c on mafia 2 with auto fan speed so I don't think so.
m
0
l
October 4, 2010 2:17:56 PM

Thats fine for temps, esp for a GTX480, try the Beta drivers and see mate. Let us know what the outcome is, and we'll go from there
m
0
l
October 4, 2010 2:29:15 PM

Installed the 260 divers and I didn't really see any boost in performance. Maybe a slight increase in Unigine score but not sure if that's the drivers or my Nvidia control panel settings.
m
0
l
October 4, 2010 2:51:04 PM

Have you had any problems with performance in other programs or just these two? I could be the probgrams and since they are benchmarks they may not be refelecting what your getting in games you play.
m
0
l
October 4, 2010 2:54:11 PM

For example sometimes in Mafia 2 my fps is 50 and suddenly drops to 15 and the whole game is really slow. And in WoW sometimes getting only 21 fps..
m
0
l
October 4, 2010 2:57:52 PM

Only thing i can suggest is the PSU maybe faulty and is suppling bad power to the system, meaning this drop in frame rate.

Also im pretty sure you should be getting alot more Frame rates in both thoese games with a GTX480.

I know in WOW you defo should be, as me grand father plays WOW alot, and his machien has a X2 4200+ and a GTX465 and he only gets low FPS in Dalaran when the server is most active.
m
0
l
October 4, 2010 3:12:05 PM

I have a friend who has either a Radeon HD 5750 or 5850 and he is getting a lot better fps in WoW than I am. I wonder whats wrong :(  ? How can I check if my psu is faulty?
m
0
l
October 4, 2010 3:13:30 PM

Dropping frame rates like you mentioned about Mafia 2 is commonly associated with a bad PSU. You should try replacing the PSU and see if that helps.
m
0
l
October 4, 2010 3:23:56 PM

The GTX480 is pretty much the top GPU to have, not much will beat it. If you could, try your friends PSU in your machine, or try another PSU in your machine.

What would be a good thing to do aswell with your PSU is to take all the optical drives and just have your system HDD (One with Windows on) and do the benchmark test. This give a little more free power for the GPU.

But givin that i dont think its a lack of power as such, more of a case of "bad" power, hense why it plays, just not flawlessly.
m
0
l
!