Sign in with
Sign up | Sign in
Your question

Sabertooth 990FX chipset problems

Last response: in Motherboards
Share
October 28, 2011 8:47:54 AM

Hi, I bought the Saberooth 990FX motherboard from overclockers.co.uk a couple days ago along with an AMD Phenom II CPU, 8GB RAM and a 750 CPU. I'm using the same HDD and graphics card as I was in my own PC as they're pretty much brand new.

Anyway, I managed to get everything built with no problems, even decided to cable manage for the first ever time and I think I did a pretty good job, too. :)  The problem came when I tried to install the chipset drivers from the installation disc that came with the mobo. During installation, all that pops up is a DOS window and another smaller window saying 'installing sofware'. After a few seconds they both disappear and I get no confirmation of installation, no reboot prompt, no nothing. And as soon as I restart my PC, everything boots up as normal until I get to the Windows 7 login window... or what should be the login window. All I can see is the white cursor. The screen is just black, there's nothing but the cursor. I can move it around and it's responsive to my mouse and everything, the screen is just empty. I've rebooted several times and it's always the same. If I put my Windows 7 disc in and boot from that and do a system restore to before I installed the chipset drivers, everything goes back to normal and I can log on just fine. I've re-installed Windows at least 3 times and every time I get the same problem when installing the Chipset drivers. I've tried installing them from the disc and I've downloaded them from the ASUS website. Always the same result.

Can anyone shed some light on this situation for me? Was really looking forward to getting this bad boy up and running! :(  PC spec is below if it helps. Thanks so much to anyone that can help!

AMD Phenom II X6 Six Core 1100T Black Edition 3.30GHz (Socket AM3)
Asus Sabertooth 990FX AMD 990FX (Socket AM3+) DDR3 Motherboard
OCZ ZS Series 750W '80 Plus Bronze' Power Supply
G.Skill RipJawsX 8GB (2x4GB) DDR3 PC3-12800C9 1600MHz Dual Channel Kit (F3-12800CL9D-8GBXL )
Sapphire Radeon HD 5970 2GB
Windows 7 Ultimate 64-bit.

Thanks so much to anyone that can help!
a c 420 V Motherboard
November 5, 2011 1:33:43 AM

It appears you are doing everything right. I wonder if the board's chipset is defective? Before the warranty is out, and if no solution is found, think about RMAing it for a new board.
November 17, 2011 4:41:45 PM

Everything works fine if you make a fresh install of windows 7, and only install drivers provided by asus on their Website. Don't install drivers supplied on the cd.

I have the same mobo/cpu than yours. I use only drivers on asus website. i install the higher versions only. That way, mine is perfectly stable.
a c 420 V Motherboard
November 17, 2011 4:53:15 PM

It's odd that the CD's drivers and the website's drivers both fail, but the default Windows 7 drivers work fine. Is there any particular driver you need that Windows doesn't automatically load? Is the only problem with the chipset driver?
!