Sign in with
Sign up | Sign in
Your question
Closed

5850 crossfire doesn't work

Last response: in Graphics & Displays
Share
October 6, 2010 6:52:26 AM

So I have 2 asus 5850 cards EAH5850 with 1gig ddr5 each. I7-930 @ 3.6ghz, CM-v8, corsair tx750w power supply, a couple fans, 1 raptor 10,000 rpm hdd, 3x 2 gig corsair dominator gt 1600 ram/triple channel. I just bought and installed the second graphics card and my performance has actually decreased.

I'm using the 10.8 drivers as the newest drivers are completely useless. I removed the drivers then installed the 10.8. My device manager and ccc both show both cards as installed. However, in ati overdrive my current gpu clock value is stuck at 400 mhz and my second card reads 000 for the gpu core clock and the memory clock.

I have both crossfire bridges installed as recommended by the sticky here in tomshardware.

Prior to installing this I was getting around 100 fps in left 4 dead 2. now i get 40 or less. any and all suggestions would be a great great help. hope i put all the necessary information.

This is my first crossfire setup, so don't be afraid to consider me a total noob.

More about : 5850 crossfire work

a c 169 U Graphics card
October 6, 2010 9:44:02 AM

Open Catalyst control center>3D>AI and make sure "Disable Catalyst AI" is unchecked.
Also,how's the performance with the second card only ?
Score
0
October 6, 2010 2:08:52 PM

Two things - one, did you install the application profiles; and two, go to the CCC menu in the system tray and turn on the display Crossfire graphic. That displays an ATI in the upper right corner if the driver enters Crossfire mode.
Score
0
Related resources
October 9, 2010 12:46:01 AM

Maziar said:
Open Catalyst control center>3D>AI and make sure "Disable Catalyst AI" is unchecked.
Also,how's the performance with the second card only ?


Sorry for the late reply, life is busy. AI is indeed unchecked. I slaved in the second card as the primary and voila, works like a dream.
Score
0
October 9, 2010 12:54:02 AM

vvhocare5 said:
Two things - one, did you install the application profiles; and two, go to the CCC menu in the system tray and turn on the display Crossfire graphic. That displays an ATI in the upper right corner if the driver enters Crossfire mode.


No I did not install the application profiles, don't know how, don't know anything about that. And the option to activate profiles is blocked out. also I turned on the crossfire graphic, there isn't one. once i enabled the feature no new icon showed up. just the icon in the system tray for ccc
Score
0

Best solution

a b U Graphics card
October 9, 2010 1:36:39 AM

airlessdavacuum said:
No I did not install the application profiles, don't know how, don't know anything about that. And the option to activate profiles is blocked out. also I turned on the crossfire graphic, there isn't one. once i enabled the feature no new icon showed up. just the icon in the system tray for ccc


When you run CF you need to download both the Driver and Profiles. Here, download this and install. Done.

http://sites.amd.com/us/game/downloads/Pages/crossfirex...
Share
October 9, 2010 1:41:54 AM

OvrClkr said:
When you run CF you need to download both the Driver and Profiles. Here, download this and install. Done.

http://sites.amd.com/us/game/downloads/Pages/crossfirex...


can i use the 10.8 drivers for that profile, or do I need to remove those and install the newest drivers. I can't get my system to function properly on the new drivers, single or dual card.
Score
0
a b U Graphics card
October 9, 2010 2:31:25 AM

You can you use whatever driver you want from 10.3 and up, I still use the 10.4's, try those but make sure you remove the driver via the control panel first, then use driver-sweeper to make sure all leftover files have been deleted. Install new driver and you are done.
Score
0
October 9, 2010 2:49:59 AM

got it to work by installing the entire suite instead of just the driver and profile manager. works now. thanks for the input!
Score
0
October 9, 2010 2:50:26 AM

Best answer selected by airlessdavacuum.
Score
0
a b U Graphics card
October 9, 2010 3:09:35 AM

This topic has been closed by OvrClkr
Score
0
!