ASRock z68 Extreme4 USB issue

I have an ASRock z68 Extreme4 and a Lian-Li PC-9F case. The I/O USB 3.0 ports on my case are plugged into the motherboard and seem to register fine with windows. I can plug in USB drives ok to them without issue. For some reason, if I plug in my wireless mouse/keyboard or more importantly my Corsair HS1 headset they do not.

The keyboard/mouse don't connect
The Corsair HS1 works but gives me static.

I verified the connection on the motherboard and all seems well. I just don't know why a portable USB 2.0 HD would work fine but the Cosair HS1 would not. I also verified the Corsair works on USB 3.0 in the back of the computer so its not a 3.0/2.0 issue.

Any debug thoughts on this? I have no idea where to start.

I also updated to the latest drivers for USB on the motherboard as well.
4 answers Last reply
More about asrock extreme4 issue
  1. IF you can connect the {Devices} directly to the USB I/O off the MOBO, but the SAME USB ports FAIL using the pass-through then it seems clear the problem is the Lian-Li PC-9F's cases USB I/O.
  2. jaquith said:
    IF you can connect the {Devices} directly to the USB I/O off the MOBO, but the SAME USB ports FAIL using the pass-through then it seems clear the problem is the Lian-Li PC-9F's cases USB I/O.


    Tonight I am going to test the ASRock Motherboard front USB 3.0 it comes with to see if using that works, that will definitely tell me if the case is causing an issue or if the motherboard is. Just seems weird some things would work, somethings would not.
  3. If there's a 'short' then nothing will make any sense.
  4. i have the same board. my usb has been... quirky. seems to be working now tho
Ask a new question

Read More

Asus USB Motherboards ASrock