Sign in with
Sign up | Sign in
Your question
Closed

Screen tearing on games above 60fps???

Last response: in Graphics & Displays
Share
October 8, 2010 12:16:18 PM

Hi,
i have a i7 860 @ 2.8ghz, and ATI HD5770, 8 Gig of RAM.
-Mass Effect 2 = 62 fps constant = screen tearing
-Burnout Paradise = 60fps (locked anyway!) = screen tearing
- Crysis on max settings = about 35-40 fps = NO SCREEN TEARING! :) 
-Portal = about 110fps (with vsync on ) :o  = BAD SCREEN TEARING!

so my theory, logically, is that when fps is above refresh rate of 60Hz, TEARING occurs! therefore if i run a monitor @75Hz, which my Benq FP222W cant do, will it should fix problem?
I can't see why games would otherwise run very smoothly, except this darn TEARING! i cannot play burnout at all since the tearing is soo bad!
i have tried forcing vsync on and off in ATI CCC and different combos but nothing works, (even 3rd party software like rivatuner/d3doverrider).

some games like Portal, even turning it on from in game doesnt work, i dunno why in fraps im getting like 110+ fps, and really bad tearing on like every vertical edge in the game, really distracting and crappy.

i did try updating driver, the first time i tried i got blue screen of death, had to system restore! i tried again, it worked, made tearing worse! so i had to roll back to previous original driver.

will buying a new 2ms vs 5ms and 75Hz monitor do the trick, so its faster so respond? or am i missing something here i need to do?
Thanks,
Craig
October 9, 2010 11:56:42 AM

bump.
i've tried more games in the meantime: on nfs shift, it ran fine and was most of the time at around 45 fps. on one particular scene it went up to 60fps, and INSTANTLY i got tearing.
the 60fps mark is CERTAINLY my problem, but how to fix???

i also tried downloading latest ATI CCC 10.9 driver, tried again, still exactly the same.

someone plz help me! ive been trying to fix this for months now..... :(  *sob sob*
October 9, 2010 12:04:41 PM

sorry for bump, im new here and dont know much about forums! :o  sorry

burnout paradise (my main problem) doesnt have a vsync option
i tried forcing it on (and off) in catalyst but doesnt change a thing!
Related resources
October 9, 2010 12:16:36 PM

If you can up the frequency on your monitor to 75, it will help
October 9, 2010 5:51:04 PM

Solution. Get 3D overrider from rivatuner. Run the game, go into Task manager and get the name of the system process of the game. Then open 3D overider highlight (or search for the correct prcoess if it isnt on the list. Set application detection level to high and FORCE TRIPLE BUFFERING and vsync - as well as having vsync on in games settings.

The key is Triple buffering, which generates a third frame in the frame buffer, so there is always a frame ready to be displayed. = no screen tearing.

It does theoretically half fps at times but the game appears so much smoother its worth it. I play Stalker SOC without Triple buffering and get 200-250 fps on maz res and settings. When i force triple buffering i get 60 fps constant, no tearing (as the game is notorious for it. But 60 fps is easily enough - anything above 50-60fps is overkill. It also makes the game feel more realistic.

This will definitely stop the screen tearing. If not on its own but combined with other peoples suggestions it will.

Hope this helps
October 9, 2010 11:18:52 PM

Quote:
I played burnout paradise i believe it has a V-sync option.Get rid of riva tuner,3d overrider or any program which allows tweaking setting.


please please tell me where the vsync option is!!! a screenshot would help - i swear that the is none in existance, i looked over and over
but another forum seemed to establish that its already forced on in the game, and nothing i can do will change it.
October 9, 2010 11:28:47 PM

Babelfish112 said:
Hi,
i have a i7 860 @ 2.8ghz, and ATI HD5770, 8 Gig of RAM.
-Mass Effect 2 = 62 fps constant = screen tearing
-Burnout Paradise = 60fps (locked anyway!) = screen tearing
- Crysis on max settings = about 35-40 fps = NO SCREEN TEARING! :) 
-Portal = about 110fps (with vsync on ) :o  = BAD SCREEN TEARING!

so my theory, logically, is that when fps is above refresh rate of 60Hz, TEARING occurs! therefore if i run a monitor @75Hz, which my Benq FP222W cant do, will it should fix problem?
I can't see why games would otherwise run very smoothly, except this darn TEARING! i cannot play burnout at all since the tearing is soo bad!
i have tried forcing vsync on and off in ATI CCC and different combos but nothing works, (even 3rd party software like rivatuner/d3doverrider).

some games like Portal, even turning it on from in game doesnt work, i dunno why in fraps im getting like 110+ fps, and really bad tearing on like every vertical edge in the game, really distracting and crappy.

i did try updating driver, the first time i tried i got blue screen of death, had to system restore! i tried again, it worked, made tearing worse! so i had to roll back to previous original driver.

will buying a new 2ms vs 5ms and 75Hz monitor do the trick, so its faster so respond? or am i missing something here i need to do?
Thanks,
Craig


It sounds as though may have CCC set to prevent V-Sync from working. You may also have some games that don't support V-sync. Not all games will work with v-sync, although I've only run into 1 personally (Divinity II).

Fraps should not be reading 110+ fps if v-sync is enabled.
October 9, 2010 11:29:27 PM

rv10 said:
Solution. Get 3D overrider from rivatuner. Run the game, go into Task manager and get the name of the system process of the game. Then open 3D overider highlight (or search for the correct prcoess if it isnt on the list. Set application detection level to high and FORCE TRIPLE BUFFERING and vsync - as well as having vsync on in games settings.

The key is Triple buffering, which generates a third frame in the frame buffer, so there is always a frame ready to be displayed. = no screen tearing.

It does theoretically half fps at times but the game appears so much smoother its worth it. I play Stalker SOC without Triple buffering and get 200-250 fps on maz res and settings. When i force triple buffering i get 60 fps constant, no tearing (as the game is notorious for it. But 60 fps is easily enough - anything above 50-60fps is overkill. It also makes the game feel more realistic.

This will definitely stop the screen tearing. If not on its own but combined with other peoples suggestions it will.

Hope this helps



Thanks for the suggestion. I've already tried this, but tried again anyway. Latest version of d3doverrider, didapplication detection level to high and FORCE TRIPLE BUFFERING and vsync as you said.
When i start the game, i hear a windows error sound, and then its as normal with the tearin. Something's incompatible/went wrong?
thx
October 9, 2010 11:32:33 PM

JAYDEEJOHN said:
If you can up the frequency on your monitor to 75, it will help


exactly what i was thinking! so does by Benq FP222W monitor suck or what? it works fine for EVERY other game though. hmmmmmm.......

the monitor i was going to buy soon is the Benq E2420HD 24" high def monitor (with 2x HDMI).
is this a good monitor to get? i "think" it can do 75Hz refresh !?
October 9, 2010 11:35:18 PM

bystander said:
It sounds as though may have CCC set to prevent V-Sync from working. You may also have some games that don't support V-sync. Not all games will work with v-sync, although I've only run into 1 personally (Divinity II).

Fraps should not be reading 110+ fps if v-sync is enabled.



yeah, im really confuzzled about portal. why doesnt v-sync IN GAME work!? other games like avatar and dirt 2 i have actually seen v-sync to smoothen things out and stop tearing, on the same settings! i dont change anything, but i try in portal - and nothing. 110+ fps! :( 
thx for reply
October 9, 2010 11:53:36 PM

OMG OMG OMG (sorry im happy!!!) lol
i've been such an idiot! PROBLEM SOLVED!!!

not drivers, not ccc, not v-sync, not monitor, it was damn 3D drivers!
sorry i forgot to mention, but i havent used them in ages. by iZ3d 3D drivers were conflicting as they use a sort of overlay over games to enable 3D via a hotkey.
i uninstalled driver and cleared registry entries, and voila! problem solved.

sorry for wasting u guys time, really. if anyone comes across someone with a similar issue to me, check if they have 3D drivers :) 

moderator can close this thread. thx
October 10, 2010 12:05:10 AM

Glad to see you fixed it!

I had similar fix with myself the last couple days. I had a 3rd party video card tuner cause issues with Crysis. I was getting sub 10 FPS and couldn't figure out why. Turned out to be an Asus program that killed performance, but only Crysis had the problem.

Damn 3rd party programs!
October 10, 2010 12:13:08 AM

bystander said:
Glad to see you fixed it!

I had similar fix with myself the last couple days. I had a 3rd party video card tuner cause issues with Crysis. I was getting sub 10 FPS and couldn't figure out why. Turned out to be an Asus program that killed performance, but only Crysis had the problem.

Damn 3rd party programs!



roflmao! exactly-damn 3rd party crap! good to see that things like rivatuner work for some, but damn!
wasted much time on this-thought hardware was the problem!
lol
October 10, 2010 1:08:23 AM

Glad you found it, but asking helps, keeps you focused, and we like to help
!