Sign in with
Sign up | Sign in
Your question

Metro 2033 5850 cf problem

Last response: in Graphics & Displays
Share
October 8, 2010 1:54:05 PM

I have a problem with metro 2033 and my graphics card. I'v heard some say that they can easily max graphics out in this game with 5850cf. If I put on very high settings my fps sometimes drops to 20 or in the worst case even under it. If I put on high the game works well. Fps always drops in lighty and open areas and when those monsters appear. Fps drops at the start of the game on very high when you have to put on that mask and the first monster pops out.
I also can't play the game with dx11. In the video options menu I can only choose dx9 or dx10.
I have the latest catalyst 10.9
specs:
I7 930 oc:D  to 3.6ghz with noctua cooler
Asus p6t se
5850 crossfire
6gb 1333 ddr3 extremedark tri channel kit
Corsair HX650
Samsung 1TB
NZXT Lexa redline case
Lg dvd drive
I'm using single crossfire bridge
What is causing my problem and how can i fix it? This is annoying.
Any ideas?

a b U Graphics card
October 8, 2010 2:31:15 PM

There is no problem. Just that the person who is telling you that he can max Metro 2033 with 5850CF is a liar and thats all.

I have a 930 overclocked to 4ghz and a 5970 overclock to 950mhz core (more than 5870CF) and I can't touch max settings on Metro 2033.

The biggest performance hitters on that game is Ambient Occlusions and Tesselation. Enabling either of those would drop your FPS like mad. I suggest turning those off.

Don't use FSAA either, for some reason it takes considerably more than AAA. Stick with Analytical Anti-Aliasing.

Don't worry about the "quality" of the game. I can link you to a forum with dozens of screen shots with and without these settings and you would have a really hard time telling the difference. Even with those settings on, it is tough to say which one actually looks better.

Also what resolution are you running at? I personally have to run the game at medium settings because im using 2560x1600 resolution (nearly double 1080P) but if you are running lets say 1080P then you can probably still max all the other settings.

Also turn of PhysX unless you have a dedicated card for that. Physx is made to be super slow when run on the CPU.
October 9, 2010 11:49:14 AM

Thanx for help :D  I solved my dx11 problem. I deleted asus gamer osd and now dx11 works.

My performance drop in heavy lighty areas is because the games new volumetric lightning setup which i seems to use lots of gpu muscle at least for me so i have to play on high settings and not to go for very high.

I'm playing on 1920x1200 res.

I get good ~60fps with high settings and tessellation on. I don't like advanced dof cos it uses lots of power and doesn't look so cool. I don't also see much difference with tessellation on.

Lightnings and smokes in this game look very nice :D 
!