Sign in with
Sign up | Sign in
Your question
Solved

New Build Wont Boot

Last response: in Systems
Share
December 2, 2010 5:47:46 PM

Alright I just built this today. When i press the power button I here a click from the power supply and thats it. I believe the power supply is giving power because on the led light on the motherboard and laser light on the mouse. All parts are brand new. So help is very much needed.

Specs:
Intel Core i5-760 2.8Ghz Lga 1156 - $209 http://www.newegg.com/Product/Prod [...] -_-Product

ASUS P7P55D-E Pro LGA 1156 - $180 http://www.newegg.com/Product/Prod [...] llFullInfo


Silverstone RV02 - $160 http://www.amazon.com/SILVERSTONE- [...] B002M78KZG


HIS 1GB Radeon 6870 - $240 x 2 = $480 http://www.newegg.com/Product/Prod [...] -_-Product


Mushkin Enhanced Blackline (2x2GB) DDR3 1600 Cas 7 - $80 http://www.newegg.com/Product/Prod [...] 63938&SID=


XFX Black Edition 750W - $130 http://www.newegg.com/Product/Prod [...] =xfx%20750


Samsung Spinpoint F3 1TB - $70 http://www.newegg.com/Product/Prod [...] 6822152185


Tuniq Tower 120 Extreme Rev. 1 - $63 http://www.newegg.com/Product/Prod [...] 6835154011


Lite-on 24x DVD burner/reader - $20 http://www.newegg.com/Product/Prod [...] 63938&SID=

More about : build wont boot

Best solution

December 2, 2010 6:01:14 PM

I had the same problem with my build, turned out the power supply was dead. I also had a similar problem, all I had to do was redo the wiring.
Share
Related resources
December 3, 2010 2:11:12 AM

Well my psu is dead and that sucks. Tried another psu and it booted. Thanks for the checklist also.
m
0
l
December 3, 2010 2:11:18 AM

Best answer selected by hova.
m
0
l
!