Pc Turns on, but doesn't boot what so ever...

Hello everybody, i have a really frustrating problem. The computer turns on fans spin, and everything looks fine inside the pc but it does not boot what so ever. I tried, new PSU, new, 2 new motherboards, new GPU and new CPU. It does not boot what so ever. I took it to 2 different repair shop to get it repaired. However, this also failed both repair shops said that they couldnt identify the problem. I also dont get any beep or anything like that from the mobo with the rams installed or they are not. My question is what could cause this i have been triying to fix this for about 2 months now and its really frustrating. Can this problem caused by any cable that is pluged in any wrong. I am thinking that its the ram because they are the ones that i havent changed. :cry: :cry: :fou: :fou:
11 answers Last reply
More about turns doesn boot ever
  1. Could you post the specs of your computer? Maybe we could help you a little better if we had more info.

    If you already tried changing the motherboard, processor and PSU then the problem might be the RAM, just like you said. Try breadboarding your components like it's explained in this post

    http://www.tomshardware.com/forum/261145-31-perform-steps-posting-boot-video-problems
  2. draggoth said:
    Could you post the specs of your computer? Maybe we could help you a little better if we had more info.

    If you already tried changing the motherboard, processor and PSU then the problem might be the RAM, just like you said. Try breadboarding your components like it's explained in this post

    http://www.tomshardware.com/forum/261145-31-perform-steps-posting-boot-video-problems

    Thanks for you reply,

    I5 750
    2x 2gb kingston rams
    corsair gs 700 psu
    ati 5750 gpu
    Asus P7P55D-E LX mobo
  3. remove all of your ram stick's leave for while then put it again.
  4. pro-gamer said:
    remove all of your ram stick's leave for while then put it again.

    Allready tried that, it didnt work. :cry:
  5. have you tried with other PSU.
  6. pro-gamer said:
    have you tried with other PSU.

    yes, i have changed it.
  7. ok remove your gpu now and check with built-in vga.maybe it helps
  8. pro-gamer said:
    ok remove your gpu now and check with built-in vga.maybe it helps

    The motherboard doesnt built in vga or anything to connect to monitor.
  9. trying with different card then?
  10. pro-gamer said:
    trying with different card then?

    as i said, i have changed THE GPU, PSU, CPU and the motherboard. i think i will change rams and see how it goes.
  11. hmmm.
Ask a new question

Read More

Motherboards Computer Boot