Sign in with
Sign up | Sign in
Your question

9500gt pixelated lagging

Last response: in Graphics & Displays
Share
October 8, 2010 11:15:00 PM

Hello,
Hi, before i describe the problem here are my current system specs:

Motherboard type and Manufacturer:
EVGA nForce 590 SLI

Motherboard chipset:
NVIDIA nForce 590 SLI

Processor Type and Speed:
AMD Athlon 64 X2 Dual Processor 4600+ 2.41GHz

OS Version:
Windows 7 Ultimate (64bit)

EVGA Graphics Card:
9500GT 1GB

Power Supply Wattage and Manufacture:
OCZ 600watt

Video Driver Version: 258.96
DirectX version: 11

Monitor:
Song Bravia 42" 60Hz HD1080p


Problem:

My card used to work just fine under all conditions when I had windows XP installed, then i upgraded to windows 7 and the problems started. Under normal operation the graphics are fine, during start up, web browsing, streaming video, all this looks great and the computer functions fast and reliable.

However as soon as I open any video game my resolution turns extremely grainy and poor, its like playing and old NES rom. Some graphics are laggy and pixelated and others (like any kinda of text) i can hardly read. It does not matter what resolution i turn the game to or what video options i check, the grainy pixelated video stays that way. This has happened on Civilization V and EVE. I installed an older game (Hitman: blood money) which I used to be able to play just fine with maxed out graphics before I upgraded to windows 7 and no pixelation or graininess occurred but it lagged like crazy.

I have done a pretty extensive searching and have not found this to be well known problem. I have made sure by downloading several pieces of windows software that the card is compatible and that its running the correct drivers and that the drives are all up to date (I have installed new drives several times). The problem still persists, can you help?
October 9, 2010 12:08:21 AM

4 Gigs of Ram DDR2 800 (PC2 6400)

AMD Athlon 64 X2 4600+ Windsor 2.4GHz Socket AM2 65W Dual-Core Processor

I know that the 9500GT is old hat now, I got it about a year and a half ago on sale so you get what you pay for, but my main point is that the card was playing these games before the windows 7 upgrade, and now its having some sort of rendering issue. This has got to be some sort of driver problem.

Also another thing to note is that my motherboard only supports PCIx16 1.0, though im not sure if the "bottle neck" problem would cause this, like i said it worked before in XP
m
0
l
October 9, 2010 1:31:06 AM

yes, the 258.96 drivers are the newest Windows 7 64-bit, Windows Vista 64-bit version for the 9500GT from nVidia's web site.

Thanks for the advice on a new card for my system by the way, and i would love to spend $150 on a new card right now but its not really in the budget at the moment. So id like to try and fix the problem, any other ideas?
m
0
l
Related resources
October 9, 2010 6:09:04 PM

ok just found a new bit of interesting data, i booted up portal after installing the even newer beta drivers from nvidia. I have the same problem with the pixelated graphics, however, as soon as i check the "play in window" option, the graphics became crystal clear and they ran fast and smooth. Even with the windowed screen as large as it can go so that there is only a little border, the games run as they should. What do you think about that?
m
0
l
October 10, 2010 2:42:50 AM

ok, I dont use my PC input because its VGA and my video card only has DVI outs. So i hook up my old DVI to VGA converter cable up and hook it up to my PC input on the TV, the color is a little off and the image is not quite as sharp but when i load up a game the image is sharp! but i don't want to put up with the degraded image so i upgraded my tv's firmware on the off chance they have updated the software for the HDMI port. And that worked, so problem solved. Updated Sony Bravia firmware.
m
0
l
!