Sign in with
Sign up | Sign in
Your question

HDD Not Detected (0) but showing in Setup

Last response: in Systems
Share
December 2, 2010 11:46:51 PM

i'm building another PC for my office @ the church (i do media work - photography, graphic arts, video editing, computer animation (maybe on this one) - i'm also IT Staff Support). i've 'installed' an MSI 785gtm-e45 mobo with an AMD Athlon II (X3), and i needed the floppy drive connector (i still use for the fourth backup of certain smaller files). Anyway, i'm using the WD 160GB IDE HDD w/XP Pro x32 and all of my other programs on it, but the system continues to reboot and does not show the drives detected as -0- and -1- the HDD160 is the master to the ZIP100 slave (third backup system). The other Master/Slave is the DVD RW/CD RW drives. The system won't boot too far beyond the mobo splash screen, it is loading all of the peripherals but intermittently goes to 'load best configuration' - 'load windows normally', etc. i've chosen all of the selections, it reboots with any selection i choose. The IDE Scan shows no detection of drives -0- and -1- but does show the DVD as -2- and CD as -3- (master/slave).

i'm sure i need to download the mobo updates, including the bios update - 2009 seems to be awfully old. Should i remove 'flash protection' in CMOS or let that setting remain? Default is DISABLED, i ENABLED it, knowing i'd have to flash the BIOS. i want to use this hard drive as the only one, why won't it boot? it is the HDD i removed from the Dell GX110-P3 that i've completely gutted & will trash. Guess it is holding on to the old board's information - when i update the bios, that ought to fix that, right? Just like the build below, i originally had the same problem - but you all helped me through that one and it is still working Well! i'm really luvin' the AMD processor for graphics - that's where i live! Though, someday, i hope i'll be able to afford the Intel i7, should be time to do another build by then.

So, i'm going to download the updates for the mobo/bios and check back later to see what wisdom i can glean from the experts. i won't be in my office again until Saturday, and i really need my new Microstar build up and running before Monday. Thanks in advance!
December 3, 2010 12:07:20 AM

Have you made sure the Controller is set to IDE in the BIOS?

If not, then it won't recognize an IDE drive.
m
0
l
December 3, 2010 1:31:10 AM

Yes, it is set to IDE, i checked all of that.
m
0
l
Related resources
December 3, 2010 1:33:26 AM

And ALL of the drives are showing in Setup, but when the system does the IDE scan on boot, it doesn't recognize the HDD or ZIP drive (-0- and -1- master/slave).
m
0
l
December 3, 2010 1:37:28 AM

The fact that it reboots w/o errors codes is kinda weird. Try a basic setup, HD, mobo, PSU, GPU (if you have one) and RAM only.

Also, if the HD is off a Dell did you actually reformat it after taking it outta the Dell?
m
0
l
December 3, 2010 4:05:53 AM

The Dell PC was given to me by a Dr - there was no hard drive in it, i had to start fresh-so there is no need for a reformat. i added an ASUS DVD-RW i purchased on eBay, and light-scribe CD, there was already a memorex cd-rw in it. Maybe it is giving me beep codes - i hear them (so the system spkr is connected right!), but forgot the beeps mean something - i'll have to check that out and see what the book or MSI says. i know i'm missing something - probably an upgraded BIOS will help. i need to find the XP OS i installed to boot with! Cant find it yet!
m
0
l
December 8, 2010 7:23:23 PM

I'm still having the same troubles! i've tried many different things and the system won't read the HDD w/the OS on it! And it isn't recognizing SATA at all - i have everything set to IDE, so that may be the case - i am beginning to HATE this mobo! shouldve stuck with Asus! nevertheless, i have this ol' raggedy MSI now, and i need help! can Anyone out there help me?
m
0
l
December 8, 2010 7:31:07 PM

A controller will not recognize SATA and IDE devices simultaneously. You can ONLY have 1 type working at a time.
m
0
l
December 8, 2010 7:37:31 PM

Another weird thing is, if the slave to the HDD is not plugged in, the system doesn't recognise the slave to the DVD-RW drive - the CD drive - this is driving me crazy!!!
m
0
l
December 8, 2010 7:41:23 PM

REALLY!? i didn't have that problem w/my Asus board (below)! i have both IDE and SATA devices in it, maybe i had a problem at first, but was able to work around them and now the system -at home- is working fine! Something MUST be wrong w/this mobo - it won't go into Windows, just keeps rebooting! i am bugged!
m
0
l
December 9, 2010 3:40:12 AM

Depending upon mobo, there are usually several controllers. You can have both IDE and SATA devices connected to a mobo. You just can't have them connected to same controller.

Consult mobo manual, figure out what plugs go to which controller, don' put IDE and SATA and same controller, and make sure that the controller is set in BIOS to correct type.
m
0
l
December 9, 2010 5:05:50 PM

Ok, speaking of the controllers, from what i read in the manual, the main operation should happen on the South bridge, but i'm seeing the North bridge's info on boot. i've never seen SATA ports stacked up on one side of the mobo, and when i disconnect the slave (Zip 100 drive) from the master HDD, the slave (CD-RW drive) on the DVD-RW master doesn't show! BUT, the HDD shows as drive '0' (where it should be) but the system won't boot past the "Boot Windows Normally - last best config, etc" page - it just reboots over & over! it's driving me CRAZY! i KNOW i must be doing something wrong! i do have a 40Gig drive that was used with the original MSI board w/AMD processor that 'jumpstarted' the PC below, perhaps i should try that one - the bios readings on the HDD i NEED to use may be messing things up - since it was removed from an Intel machine - didn't think about that until now. Then, maybe i can 'add' the other one. This mobo came w/only one 40-pin connector - i added a PCI card w/2 additional connectors - one is being used for the DVD-CD master/slave - so they must all be connected somehow! i am SO bummed and OVER THIS mobo! i will NEVER purchase another MSI mobo! bad mistake! baaaad mistake! i'm going back to Intel the next time i build. i HAVE to make this one work though. Got an error page when i went to online tech support at the MSI site! Please help me!
m
0
l
December 16, 2010 12:50:25 AM

I decided to use my 40GB Maxtor from the AMD MSI mobo that died (using the same case) - it may still be ok, i just didnt have time to 'repair' it, figured it was best to rebuild. As usual, it worked like a champ! After much trial & error, i had to make the 40G Maxtor the master & the 160GB WD HDD the slave! But all of my programs are on the 160GB HDD! i have forgotton how to make the other 'active' drive a 'system' drive or bootable drive! i've decided to keep both drives in the PC, i've deleted the larger programs from the smaller drive - i only want to run the OS from there w/the codecs, printer drivers, other important stuff - i want to run most of my programs from the 160GB HDD - but will i have to reinstall them? MSOffice, Adobe programs, etc? What about the OS on the other drive? Can i, or should i uninstall it? how? it is a copy of XPSP3 - same as on the other drive - i just can't boot from it, can't see it, but i know it's there! Anyway, after i uninstalled the programs from the 40GB drive, i noticed MS0ffice 2003 is still installed, but not showing in programs - not a big deal, i have 2007 on the HDD, may have to reinstall over it, as i may have to do all the other programs!
m
0
l
!